]> git.pld-linux.org Git - packages/php-pecl-big_int.git/blobdiff - php-pecl-big_int.spec
- use new php/zend api macros
[packages/php-pecl-big_int.git] / php-pecl-big_int.spec
index 3a406cf9a450c897ef127e2e0232b0351e567fc7..301bc8b34c522585b88239857e7d5e786f337f1b 100644 (file)
@@ -1,25 +1,25 @@
 %define                _modname        big_int
 %define                _status         stable
+%define                _sysconfdir     /etc/php
+%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
 
 Summary:       %{_modname} - set of functions for calculations with arbitrary length integers
 Summary(pl):   %{_modname} - zestaw funkcji do obliczeñ z u¿yciem liczb o dowolnej wielko¶ci
 Name:          php-pecl-%{_modname}
 Version:       1.0.6
-Release:       1
+Release:       2
 License:       PHP 2.02
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
 # Source0-md5: 844332ab0a40ea12aa8339d7d2c20770
 URL:           http://pecl.php.net/package/big_int/
-BuildRequires: libtool
 BuildRequires: php-devel >= 3:5.0.0
-Requires:      php-common >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.238
+%requires_php_extension
+Requires:      %{_sysconfdir}/conf.d
 Obsoletes:     php-pear-%{_modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %{_libdir}/php
-
 %description
 This package is useful for number theory applications. For example, in
 two-keys cryptography. See tests/RSA.php in the package for example of
@@ -60,22 +60,29 @@ phpize
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{extensionsdir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
 
 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
+; Enable %{_modname} extension module
+extension=%{_modname}.so
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
+[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
+[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
 
-%preun
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
+%postun
+if [ "$1" = 0 ]; then
+       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
+       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc %{_modname}-%{version}/{docs,tests,CREDITS,README}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.071182 seconds and 4 git commands to generate.