]> git.pld-linux.org Git - packages/php-pecl-archive.git/blobdiff - php-pecl-archive.spec
- fix obsoletes version
[packages/php-pecl-archive.git] / php-pecl-archive.spec
index 8b168d31c3a29d44218c504c5f8b21b46dc02aad..36fe53b16f3c3335d3b4053a14aff91a0a4c11f0 100644 (file)
@@ -1,72 +1,69 @@
-%define                _modname        archive
-%define                _status         beta
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
-
-Summary:       %{_modname} - manipulate tar/cpio archives
-Summary(pl):   %{_modname} - obróbka archiwów tar/cpio
-Name:          php-pecl-%{_modname}
+%define                php_name        php%{?php_suffix}
+%define                modname         archive
+%define                status          beta
+Summary:       %{modname} - manipulate tar/cpio archives
+Summary(pl.UTF-8):     %{modname} - obróbka archiwów tar/cpio
+Name:          %{php_name}-pecl-%{modname}
 Version:       0.2
-Release:       3
-License:       PHP 2.02
+Release:       18
+License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 1b121440b2c460b2a1af46e31f23e46e
+Patch0:                php-pecl-%{modname}-php52.patch
 URL:           http://pecl.php.net/package/archive/
+BuildRequires: %{php_name}-devel >= 3:5.0.4
 BuildRequires: libarchive-devel
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.230
-%requires_eq_to php-common php-devel
-Requires:      %{_sysconfdir}/conf.d
-Obsoletes:     php-pear-%{_modname}
+BuildRequires: rpmbuild(macros) >= 1.650
+%{?requires_php_extension}
+Provides:      php(%{modname}) = %{version}
+Obsoletes:     php-pecl-archive < 0.2-17
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 archive extension allows to read and write tar and cpio archives using
 libarchive.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
-%description -l pl
-Rozszerzenie archive pozwala na odczyt i zapis archiwów tar oraz cpio
-przy u¿yciu biblioteki libarchive.
+%description -l pl.UTF-8
+Rozszerzenie archive pozwala na odczyt i zapis archiwów tar oraz cpio
+przy użyciu biblioteki libarchive.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
+%patch0 -p0
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
-
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+%php_webserver_restart
 
 %postun
 if [ "$1" = 0 ]; then
-       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+       %php_webserver_restart
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{API.txt,CREDITS,tests}
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{extensionsdir}/%{_modname}.so
+%doc API.txt CREDITS tests
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.095595 seconds and 4 git commands to generate.