]> git.pld-linux.org Git - packages/php-pear.git/blobdiff - php-pear.spec
- fixup horde dirs
[packages/php-pear.git] / php-pear.spec
index 2e3b875e2d8a8cd71fc5b7330c434ec66bf199c9..4c9c8ca8af6cc161c0eb74a967bd274defe8801a 100644 (file)
@@ -1,25 +1,33 @@
 Summary:       PEAR - PHP Extension and Application Repository
 Summary(pl.UTF-8):     PEAR - rozszerzenie PHP i repozytorium aplikacji
 Name:          php-pear
-Version:       1.2
+Version:       1.3.6
 Release:       2
 Epoch:         4
 License:       Public Domain
 Group:         Development/Languages/PHP
-Source0:       channel-phpunit.xml
+Source0:       php-channel-prov.php
+Source100:     update-channels.sh
 Source1:       channel-phing.xml
 Source2:       channel-phpdb.xml
 Source3:       channel-firephp.xml
-Source10:      php-channel-prov.php
+Source4:       channel-symfony.xml
+Source5:       channel-phpunit.xml
+Source6:       channel-phpseclib.xml
+Source7:       channel-horde.xml
+Source8:       channel-rc.xml
+Source9:       channel-ezc.xml
+Source10:      channel-propel.xml
 BuildRequires: /usr/bin/php
-BuildRequires: php-pear-PEAR
+BuildRequires: php-pear-PEAR >= 1:1.9.0
+BuildRequires: rpmbuild(macros) >= 1.570
 Obsoletes:     php-pear-additional_classes
 Obsoletes:     php4-pear
 Conflicts:     php-pear-PEAR < 1:1.7.2-10
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                __reg_provides  php %{SOURCE10}
+%define                __reg_provides  php %{SOURCE0}
 
 # find channel provides
 %define                _use_internal_dependency_generator 0
@@ -51,20 +59,17 @@ php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{php_pear_dir}/{bin,data,tests}
+install -d $RPM_BUILD_ROOT%{php_pear_dir}/{.registry,bin,data,tests}
 
 # add extra channels
-pear -c pearrc config-set php_dir $RPM_BUILD_ROOT%{php_pear_dir}
-pear -c pearrc channel-add %{SOURCE0}
-pear -c pearrc channel-add %{SOURCE1}
-pear -c pearrc channel-add %{SOURCE2}
-pear -c pearrc channel-add %{SOURCE3}
+%{__pear} -c pearrc config-set php_dir $RPM_BUILD_ROOT%{php_pear_dir}
+for xml in $(awk '/^Source[0-9]+:.+channel-.+.xml$/ {print $NF}' %{_specdir}/%{name}.spec); do
+       %{__pear} -c pearrc channel-add %{_sourcedir}/$xml
+done
 
 while read dir; do
        install -d $RPM_BUILD_ROOT$dir
 done <<EOF
-%{php_pear_dir}/.registry
-%{php_pear_dir}/bin
 %{php_pear_dir}/Archive
 %{php_pear_dir}/Auth
 %{php_pear_dir}/Cache
@@ -84,11 +89,16 @@ done <<EOF
 %{php_pear_dir}/HTTP
 %{php_pear_dir}/HTTP/WebDAV
 %{php_pear_dir}/HTTP/WebDAV/Tools
+%{php_pear_dir}/Horde
+%{php_pear_dir}/Horde/Text
+%{php_pear_dir}/Horde/Xml
 %{php_pear_dir}/I18N
 %{php_pear_dir}/Image
 %{php_pear_dir}/MP3
+%{php_pear_dir}/Mail
 %{php_pear_dir}/Math
 %{php_pear_dir}/Net
+%{php_pear_dir}/Net/UserAgent
 %{php_pear_dir}/Numbers
 %{php_pear_dir}/PHP
 %{php_pear_dir}/Payment
@@ -98,6 +108,7 @@ done <<EOF
 %{php_pear_dir}/Structures
 %{php_pear_dir}/Testing
 %{php_pear_dir}/Text
+%{php_pear_dir}/Text/CAPTCHA
 %{php_pear_dir}/Text/Spell
 %{php_pear_dir}/URI
 %{php_pear_dir}/Validate
@@ -139,6 +150,7 @@ check_channel_dirs
 %dir %{php_pear_dir}/.channels
 %dir %{php_pear_dir}/.channels/.alias
 
+# core channels
 %{php_pear_dir}/.channels/__uri.reg
 %{php_pear_dir}/.registry/.channel.__uri
 
@@ -149,6 +161,11 @@ check_channel_dirs
 %{php_pear_dir}/.channels/pecl.php.net.reg
 %{php_pear_dir}/.registry/.channel.pecl.php.net
 
+%{php_pear_dir}/.channels/.alias/phpdocs.txt
+%{php_pear_dir}/.channels/doc.php.net.reg
+%{php_pear_dir}/.registry/.channel.doc.php.net
+
+# addon channels
 %{php_pear_dir}/.channels/.alias/phpunit.txt
 %{php_pear_dir}/.channels/pear.phpunit.de.reg
 %{php_pear_dir}/.registry/.channel.pear.phpunit.de
@@ -164,3 +181,27 @@ check_channel_dirs
 %{php_pear_dir}/.channels/.alias/firephp.txt
 %{php_pear_dir}/.channels/pear.firephp.org.reg
 %{php_pear_dir}/.registry/.channel.pear.firephp.org
+
+%{php_pear_dir}/.channels/.alias/symfony.txt
+%{php_pear_dir}/.channels/pear.symfony-project.com.reg
+%{php_pear_dir}/.registry/.channel.pear.symfony-project.com
+
+%{php_pear_dir}/.channels/.alias/phpseclib.txt
+%{php_pear_dir}/.channels/phpseclib.sourceforge.net.reg
+%{php_pear_dir}/.registry/.channel.phpseclib.sourceforge.net
+
+%{php_pear_dir}/.channels/.alias/horde.txt
+%{php_pear_dir}/.channels/pear.horde.org.reg
+%{php_pear_dir}/.registry/.channel.pear.horde.org
+
+%{php_pear_dir}/.channels/.alias/rc.txt
+%{php_pear_dir}/.channels/pear.roundcube.net.reg
+%{php_pear_dir}/.registry/.channel.pear.roundcube.net
+
+%{php_pear_dir}/.channels/.alias/ezc.txt
+%{php_pear_dir}/.channels/components.ez.no.reg
+%{php_pear_dir}/.registry/.channel.components.ez.no
+
+%{php_pear_dir}/.channels/.alias/propel.txt
+%{php_pear_dir}/.channels/pear.propelorm.org.reg
+%{php_pear_dir}/.registry/.channel.pear.propelorm.org
This page took 0.073215 seconds and 4 git commands to generate.