]> git.pld-linux.org Git - packages/photoqt.git/blobdiff - photoqt.spec
- release 3 (by relup.sh)
[packages/photoqt.git] / photoqt.spec
index a78cb0172433b5c33eceb44c5cbdc5a418d961a2..35e9455b0252ebdac8b0dc64ddb3e1f1bf8a38c1 100644 (file)
@@ -1,45 +1,65 @@
-# TODO
-# - with GM?
-# - optional (runtime) deps:
-#  - XCFtools - https://github.com/j-jorge/xcftools
-#  - libqpsd - https://github.com/Code-ReaQtor/libqpsd
+#
+# Conditional build:
+%bcond_without gmagick         # GraphicsMagick support
 
-%define        qtver   5.1
+%define        qt_ver  5.3
 Summary:       Simple but powerful Qt-based image viewer
+Summary(pl.UTF-8):     Prosta, ale mająca duże możliwości przeglądarka obrazków oparta na Qt
 Name:          photoqt
-Version:       1.2
-Release:       1
-License:       GPL v2
-Group:         Applications
+Version:       1.4.1
+Release:       3
+License:       GPL v2+
+Group:         X11/Applications
+#Source0Download: http://photoqt.org/down/
 Source0:       http://photoqt.org/pkgs/%{name}-%{version}.tar.gz
-# Source0-md5: bc0233279c86db39dc2482583697c9b3
+# Source0-md5: f708ccf9f4e01ad3fac2e893c4f14014
 URL:           http://photoqt.org/
-BuildRequires: GraphicsMagick-devel
-BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: Qt5Gui-devel >= %{qtver}
-BuildRequires: Qt5Multimedia-devel >= %{qtver}
-BuildRequires: Qt5Svg-devel >= %{qtver}
-BuildRequires: qt5-linguist >= %{qtver}
-BuildRequires: cmake
+%{?with_gmagick:BuildRequires: GraphicsMagick-c++-devel}
+BuildRequires: Qt5Core-devel >= %{qt_ver}
+BuildRequires: Qt5Gui-devel >= %{qt_ver}
+BuildRequires: Qt5Quick-devel >= %{qt_ver}
+BuildRequires: Qt5Sql-devel >= %{qt_ver}
+BuildRequires: Qt5Svg-devel >= %{qt_ver}
+BuildRequires: Qt5Widgets-devel >= %{qt_ver}
+BuildRequires: cmake >= 2.8
+BuildRequires: exiv2-devel
+BuildRequires: libraw-devel
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: qt5-build >= %{qt_ver}
+BuildRequires: qt5-linguist >= %{qt_ver}
+BuildRequires: qt5-qmake >= %{qt_ver}
 BuildRequires: rpmbuild(macros) >= 1.596
-Requires:      desktop-file-utils
-Requires:      gtk-update-icon-cache
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk-update-icon-cache
+Requires:      Qt5Core >= %{qt_ver}
+Requires:      Qt5Gui >= %{qt_ver}
+Requires:      Qt5Quick >= %{qt_ver}
+Requires:      Qt5Sql >= %{qt_ver}
+Requires:      Qt5Sql-sqldriver-sqlite3 >= %{qt_ver}
+Requires:      Qt5Svg >= %{qt_ver}
+Requires:      Qt5Widgets >= %{qt_ver}
 Requires:      hicolor-icon-theme
+# psd imageformat plugin
+Suggests:      libqpsd-qt5
+Suggests:      xcftools
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Simple but powerful Qt-based image viewer.
 
+%description -l pl.UTF-8
+Prosta, ale mająca duże możliwości przeglądarka obrazków oparta na Qt.
+
 %prep
 %setup -q
 
 %build
 install -d build
 cd build
-%cmake \
-       -DGM=NO \
-       -DEXIV2=YES \
-       ..
+%cmake .. \
+       %{!?with_gmagick:-DGM=OFF} \
+       -DEXIV2=ON
+
 %{__make}
 
 %install
@@ -62,5 +82,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README CHANGELOG
 %attr(755,root,root) %{_bindir}/photoqt
+%{_datadir}/appdata/photoqt.appdata.xml
 %{_desktopdir}/photoqt.desktop
-%{_iconsdir}/hicolor/*/apps/photoqt.png
+%{_iconsdir}/hicolor/*x*/apps/photoqt.png
This page took 0.193451 seconds and 4 git commands to generate.