]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - perl.spec
adapter
[projects/template-specs.git] / perl.spec
index 044b6300f363e2e79b9e332b5a4a3652b1571749..9113daefaff0b0cf19cf76fd0d1a5a89dd963cba 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -28,6 +28,8 @@ Source0:      http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.t
 Patch0:                %{name}-foo.patch
 # most of CPAN modules have generic URL (substitute pdir and pnam here)
 URL:           http://search.cpan.org/dist/PDIR-PNAM/
+# macros BR if _noautoreq_perl is used
+#BuildRequires:        rpmbuild(macros) >= 1.654
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: -
@@ -41,7 +43,7 @@ Obsoletes:    -
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(anything_fake_or_conditional)'
+%define                _noautoreq_perl anything_fake_or_conditional
 
 %description
 
@@ -59,6 +61,12 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 
+# Build.PL based packages
+%{__perl} Build.PL \
+       perl=%{__perl} \
+       installdirs=vendor
+./Build
+
 %{__make}
 # if module isn't noarch, use:
 # %{__make} \
@@ -75,10 +83,12 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
+./Build install \
+       destdir=$RPM_BUILD_ROOT
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.062471 seconds and 4 git commands to generate.