]> git.pld-linux.org Git - packages/perl-Term-ReadKey.git/blobdiff - perl-Term-ReadKey.spec
- up to 2.33
[packages/perl-Term-ReadKey.git] / perl-Term-ReadKey.spec
index ce34973b1a2de0a316d3652cfba627bee4b6d6f2..e10bd58e0efc478de1312ea132aacfad7bb0bbab 100644 (file)
@@ -1,76 +1,68 @@
 #
 # Conditional build:
-# _with_tests - perform "make test"
+%bcond_with    tests   # perform "make test"
+                       # requires terminal
 #
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    Term
 %define                pnam    ReadKey
-Summary:       Term::ReadKey Perl module
-Summary(cs):   Modul Term::ReadKey pro Perl
-Summary(da):   Perlmodul Term::ReadKey
-Summary(de):   Term::ReadKey Perl Modul
-Summary(es):   Módulo de Perl Term::ReadKey
-Summary(fr):   Module Perl Term::ReadKey
-Summary(it):   Modulo di Perl Term::ReadKey
-Summary(ja):   Term::ReadKey Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   Term::ReadKey ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul Term::ReadKey
-Summary(pl):   Modu³ Perla Term::ReadKey
-Summary(pt):   Módulo de Perl Term::ReadKey
-Summary(pt_BR):        Módulo Perl Term::ReadKey
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl Term::ReadKey
-Summary(sv):   Term::ReadKey Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Term::ReadKey
-Summary(zh_CN):        Term::ReadKey Perl Ä£¿é
+Summary:       Term::ReadKey - Perl module for simple terminal control
+Summary(pl.UTF-8):     Term::ReadKey - moduł Perla do prostego sterowania terminalem
 Name:          perl-Term-ReadKey
-Version:       2.21
+Version:       2.33
 Release:       1
-License:       GPL
+License:       BSD-like
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}%{pnam}-%{version}.tar.gz
-BuildRequires: perl >= 5.6.1
-BuildRequires: rpm-perlprov >= 3.0.3-16
+Source0:       http://www.cpan.org/modules/by-module/Term/%{pdir}%{pnam}-%{version}.tar.gz
+# Source0-md5: 1b60aa12b05b5c59d09061fa03087fdb
+URL:           http://search.cpan.org/dist/TermReadKey/
+BuildRequires: perl-ExtUtils-MakeMaker >= 3.5
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+Obsoletes:     perl-TermReadKey
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-Obsoletes:     perl-%{pdir}%{pnam}
 
 %description
-This module, ReadKey, provides ioctl control for terminals so the
-input modes can be changed (thus allowing reads of a single character
-at a time), and also provides non-blocking reads of stdin, as well as
-several other terminal related features, including
+This module, Term::ReadKey, provides ioctl control for terminals so
+the input modes can be changed (thus allowing reads of a single
+character at a time), and also provides non-blocking reads of stdin,
+as well as several other terminal related features, including
 retrieval/modification of the screen size, and retrieval/modification
 of the control characters.
 
-%description -l pl
-Modu³ perla Term::ReadKey. Modu³ ten daje obs³ugê ioctl dla terminali,
-umo¿liwiaj±c zmianê trybu wej¶cia (co pozwala na czytanie po jednym
-znaku) oraz nieblokuj±cy odczyt z wej¶cia, a tak¿e inne funkcje
-zwi±zane z terminalem, w tym odczytywanie i modyfikowanie rozmiaru
-ekranu oraz odczytywanie i modyfikowanie znaków kontrolnych.
+%description -l pl.UTF-8
+Moduł Perla Term::ReadKey udostępnia obsługę ioctl dla terminali,
+umożliwiając zmianę trybu wejścia (co pozwala na czytanie po jednym
+znaku) oraz nieblokujący odczyt z wejścia, a także inne funkcje
+związane z terminalem, w tym odczytywanie i modyfikowanie rozmiaru
+ekranu oraz odczytywanie i modyfikowanie znaków kontrolnych.
 
-%description -l pt_BR
-Este módulo fornece controle via ioctl para terminais, de tal forma
+%description -l pt_BR.UTF-8
+Este módulo fornece controle via ioctl para terminais, de tal forma
 que seus modos de entrada possam ser modificados (desta forma
-permitindo a leitura de um caracter somente por vez) e também fornece
-leitura não bloqueantes da entrada padrão (stdin), bem como várias
-outras características relacionadas a terminais, entre elas a
-recuperação/modificação do tamanho da tela e dos caracteres de
+permitindo a leitura de um caracter somente por vez) e também fornece
+leitura não bloqueantes da entrada padrão (stdin), bem como várias
+outras características relacionadas a terminais, entre elas a
+recuperação/modificação do tamanho da tela e dos caracteres de
 controle.
 
 %prep
 %setup -q -n TermReadKey-%{version}
 
 %build
-perl Makefile.PL
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make} \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
 
-# tests require terminal
-%{?_with_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -78,10 +70,9 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README
-%{perl_sitearch}/Term/ReadKey.pm
-%dir %{perl_sitearch}/auto/Term/ReadKey
+%{perl_vendorarch}/Term/ReadKey.pm
+%dir %{perl_vendorarch}/auto/Term/ReadKey
 # empty autosplit.ix
-#%{perl_sitearch}/auto/Term/ReadKey/autosplit.ix
-%{perl_sitearch}/auto/Term/ReadKey/ReadKey.bs
-%attr(755,root,root) %{perl_sitearch}/auto/Term/ReadKey/ReadKey.so
-%{_mandir}/man3/*
+#%%{perl_vendorarch}/auto/Term/ReadKey/autosplit.ix
+%attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadKey/ReadKey.so
+%{_mandir}/man3/Term::ReadKey.3pm*
This page took 0.100537 seconds and 4 git commands to generate.