]> git.pld-linux.org Git - packages/perl-Net-SSLeay.git/blobdiff - perl-Net-SSLeay.spec
- tabs in preamble
[packages/perl-Net-SSLeay.git] / perl-Net-SSLeay.spec
index ae5c85f3e1cd6b7cf9704f9b3b0fd25568a48a05..ff6c3beaf154d8d9e02cd67946057ffbe0351b2f 100644 (file)
@@ -1,71 +1,71 @@
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Net-SSLeay perl module
-Summary(pl):   Modu³ perla Net-SSLeay
+Summary:       Net::SSLeay - Perl extension for using OpenSSL or SSLeay
+Summary(pl.UTF-8):     Net::SSLeay - rozszerzenie Perla do używania OpenSSL lub SSLeay
 Name:          perl-Net-SSLeay
-Version:       1.05
-Release:       1
-License:       GPL
+Version:       1.25
+Release:       3
+# same as openssl
+License:       Apache-style License
 Group:         Development/Languages/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/Net/Net_SSLeay.pm-%{version}.tar.gz
-Patch0:                perl-Net-SSLeay-paths.patch
-Patch1:                perl-Net-SSLeay-openssl_path.patch
-BuildRequires: rpm-perlprov >= 3.0.3-18
-BuildRequires: perl >= 5.005_03-14
-BuildRequires: openssl-devel >= 0.9.4-2
-%requires_eq   perl
-Requires:      %{perl_sitearch}
+Source0:       http://www.cpan.org/modules/by-module/Net/Net_SSLeay.pm-%{version}.tar.gz
+# Source0-md5: 87de8a06802fbb63c7c85e89eedbe139
+Patch0:                %{name}-paths.patch
+BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: openssl-tools >= 0.9.7d
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Net-SSLeay perl module
+This module offers some high level convinience functions for accessing
+web pages on SSL servers, a sslcat() function for writing your own
+clients, and finally access to the SSL api of SSLeay/OpenSSL package
+so you can write servers or clients for more complicated applications.
 
-%description -l pl
-Modul perla Net-SSLeay
+%description -l pl.UTF-8
+Ten moduł oferuje kilka wygodnych funkcji wysokiego poziomu służących
+do dostępu do stron WWW na serwerach SSL, funkcję sslcat() do pisania
+własnych klientów, oraz dostęp do API SSL pakietu SSLeay/OpenSSL, co
+pozwala na pisanie serwerów lub klientów dla bardziej skomplikowanych
+aplikacji.
 
 %prep
 %setup -q -n Net_SSLeay.pm-%{version}
-%patch0 -p0
-%patch1 -p0
+%patch0 -p1
 
 %build
-perl Makefile.PL
-make OPTIMIZE="$RPM_OPT_FLAGS"
+%{__perl} Makefile.PL %{_prefix} \
+       INSTALLDIRS=vendor
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_prefix}/src/examples/%{name}
-
-make install DESTDIR=$RPM_BUILD_ROOT
-install examples/* $RPM_BUILD_ROOT%{_prefix}/src/examples/%{name}
-
-strip --strip-unneeded $RPM_BUILD_ROOT/%{perl_sitearch}/auto/Net/SSLeay/*.so
-
-(
-  cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/Net/SSLeay
-  sed -e "s#$RPM_BUILD_ROOT##" .packlist >.packlist.new
-  mv .packlist.new .packlist
-)
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
-        Changes README
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+install examples/*.{pl,conf} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {Changes,README}.gz
-
-%{perl_sitearch}/Net/SSLeay.pm
-
-%dir %{perl_sitearch}/auto/Net/SSLeay
-%{perl_sitearch}/auto/Net/SSLeay/.packlist
-%{perl_sitearch}/auto/Net/SSLeay/autosplit.ix
-%{perl_sitearch}/auto/Net/SSLeay/*.al
-%{perl_sitearch}/auto/Net/SSLeay/SSLeay.bs
-%attr(755,root,root) %{perl_sitearch}/auto/Net/SSLeay/SSLeay.so
-
+%doc Changes Credits README
+%{perl_vendorarch}/Net/SSLeay.pm
+%{perl_vendorarch}/Net/SSLeay
+%{perl_vendorarch}/Net/ptrtstrun.pl
+%dir %{perl_vendorarch}/auto/Net/SSLeay
+%{perl_vendorarch}/auto/Net/SSLeay/autosplit.ix
+%{perl_vendorarch}/auto/Net/SSLeay/*.al
+%{perl_vendorarch}/auto/Net/SSLeay/*.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Net/SSLeay/*.so
 %{_mandir}/man3/*
-
-%{_prefix}/src/examples/%{name}
+%{_examplesdir}/%{name}-%{version}
This page took 0.034041 seconds and 4 git commands to generate.