]> git.pld-linux.org Git - packages/performous.git/blobdiff - performous.spec
- up to 1.3.0
[packages/performous.git] / performous.spec
index 6a81f55ddcc3c0e431d57796f70bfef54020ebe3..8e19d7841e5308a2a692db9b60ae5dea78785690 100644 (file)
@@ -1,19 +1,21 @@
 Summary:       Performous - The All-in-One Music Game
 Summary(pl.UTF-8):     Performous - wiele gier muzycznych w jednej
 Name:          performous
-Version:       1.1
-Release:       10
+Version:       1.3.0
+Release:       1
 License:       GPL v2+
 Group:         Applications/Sound
 #Source0Download: https://github.com/performous/performous/releases
-Source0:       https://github.com/performous/performous/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: cf31d0973cd88b3cd626d312d6d3f5b2
-Patch0:                %{name}-boost.patch
-Patch1:                %{name}-pango1.44.patch
-Patch2:                opencv-const.patch
+Source0:       https://github.com/performous/performous/archive/refs/tags/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 1579905ea88e09611e90b737e9417895
+Source1:       compact_enc_det.tar.xz
+# Source1-md5: c4af58e784fe054b787254acf5c1af12
+Patch0:                ced-no-forced-cxx11.patch
+Patch1:                find-ced.patch
 URL:           http://performous.org/
 BuildRequires: ImageMagick-c++-devel
 BuildRequires: SDL2-devel >= 2
+BuildRequires: aubio-devel
 BuildRequires: boost-devel >= 1.36
 BuildRequires: cmake >= 2.8
 # avformat avresample swscale
@@ -31,6 +33,7 @@ BuildRequires:        libsigc++-devel
 BuildRequires: libstdc++-devel >= 6:4.6
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxml++2-devel >= 2.6
+BuildRequires: nlohmann-json-devel >= 3.10.5
 BuildRequires: opencv-devel
 BuildRequires: pango-devel >= 1:1.12
 BuildRequires: pkgconfig
@@ -38,7 +41,7 @@ BuildRequires:        portaudio-devel
 BuildRequires: portmidi-devel
 BuildRequires: rpmbuild(macros) >= 1.605
 BuildRequires: zlib-devel
-Suggests:      %{name}-tools = %{version}-%{release}
+Obsoletes:     %{name}-tools < 1.3.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -54,32 +57,34 @@ UltraStar, Frets on Fire i StepManii. Mikrofony i kontrolery z gier
 SingStar, Guitar Hero i Rock Band oraz maty do tańca są automatycznie
 wykrywane.
 
-%package tools
-Summary:       Performous tools
-Summary(pl.UTF-8):     Narzędzia do programu Performous
-Group:         Applications/Sound
-
-%description tools
-Several utilities for converting data files for Performous.
-
-%description tools -l pl.UTF-8
-Zestaw narzędzi do konwersji danych dla programu Performous.
-
 %prep
-%setup -q
+%setup -q -a1
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
+cd compact_enc_det
 install -d build
 cd build
 %cmake .. \
+       -DBUILD_SHARED_LIBS=OFF
+%{__make} ced
+cp -p lib/libced.a ../compact_enc_det
+cd ../..
+
+SRC=$(pwd)
+install -d build/game
+cd build
+%cmake .. \
+       -DCMAKE_INSTALL_MANDIR=%{_mandir}/man6 \
        -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-       -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -std=gnu++11" \
+       -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags}" \
        -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
        -DMagick_LIBRARY="$(echo %{_libdir}/libMagickCore-*.so)" \
-       -DMagick++_LIBRARY="$(echo %{_libdir}/libMagick++-*.so)"
+       -DMagick++_LIBRARY="$(echo %{_libdir}/libMagick++-*.so)" \
+       -DSELF_BUILT_CED=NEVER \
+       -DCed_INCLUDE_DIRS="$SRC/compact_enc_det" \
+       -DCed_LIBRARIES="-L$SRC/compact_enc_det/compact_enc_det $SRC/compact_enc_det/compact_enc_det/libced.a"
 
 %{__make}
 
@@ -90,8 +95,6 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cp -p docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
-
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
 
 %find_lang %{name} --all-name
@@ -101,17 +104,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README.txt docs/{Authors,instruments}.txt
+%doc README.md docs/{Authors,instruments}.txt
 %attr(755,root,root) %{_bindir}/performous
 %{_datadir}/games/%{name}
 %{_mandir}/man6/performous.6*
 %{_desktopdir}/performous.desktop
 %{_pixmapsdir}/performous.svg
-
-%files tools
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/gh_*_decrypt
-%attr(755,root,root) %{_bindir}/itg_pck
-%attr(755,root,root) %{_bindir}/ss_*
-%{_mandir}/man1/gh_*_decrypt.1*
-%{_mandir}/man1/ss_*.1*
This page took 0.055248 seconds and 4 git commands to generate.