]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
- up to 6325
[packages/opera.git] / opera.spec
index 63c2f62d4c43cc84ca12c533e7cdb6418e455fbb..b34e3030190d89dc63d727938d50cfc6b34feca0 100644 (file)
 # - HEAD - stable version
 # - DEVEL - development version
 # - WEEKLY - weekly development version (sometimes it's on DEVEL)
-
-%bcond_without shared          # static or shared version
 %bcond_without distributable   # distributable or not
-%bcond_with    snap            # snap version
-%bcond_with    weekly          # weekly snapshot version
-%bcond_with    qt4
-
-%define        ver             10.10
-%define        reltype         snapshot
-%define        magicstr        4594
-
-%define sver            %{ver}
-%define        shver           %(echo %{ver} | tr -d .)
-%define        sreltype        %(echo %{reltype} | tr - _)
-%define        smagicstr       %{magicstr}
-
-# http://my.opera.com/csant/blog/2007/09/06/which-is-which
-# http://my.opera.com/csant/blog/2008/05/20/which-is-which-part-two
-%define        x86_static_rel          gcc4-static-qt3
-%define        sparc_shared_rel        unknown
-%define        sparc_static_rel        unknown
-%define        ppc_shared_rel          gcc4-shared-qt3
-%define        ppc_static_rel          gcc295-static-qt3
-%define x86_64_static_rel       unknown
-
-%if %{with qt4}
-%define x86_64_shared_rel       gcc4-qt4
-%define x86_shared_rel          gcc4-qt4
-%else
-%define x86_64_shared_rel       gcc4-shared-qt3
-%define x86_shared_rel          gcc4-shared-qt3
-%endif
-
-%if %{with shared}
-
-%define        type            shared
-
-# Defined to be able to build src.rpm also on not supported archs
-%define        rawrel          %{x86_shared_rel}
-
-%ifarch sparc sparcv9
-%define        rawrel          %{sparc_shared_rel}
-%endif
-
-%ifarch ppc
-%define        rawrel          %{ppc_shared_rel}
-%endif
 
-%ifarch %{x8664}
-%define rawrel         %{x86_64_shared_rel}
-%endif
-
-%else # [with shared]
-
-%define        type            static
-
-# Defined to be able to build src.rpm also on not supported archs
-%define        rawrel          %{x86_static_rel}
-
-%ifarch sparc sparcv9
-%define        rawrel          %{sparc_static_rel}
-%endif
-
-%ifarch ppc
-%define        rawrel          %{ppc_static_rel}
-%endif
-
-%ifarch %{x8664}
-%define rawrel             %{x86_64_static_rel}
-%endif
-
-%endif # [with shared]
-
-%define        rel     %(echo %{rawrel} | tr - _)
-
-%define                _rel    1
+%define                subver  6325
+%define                rel             1
 Summary:       World fastest web browser
 Summary(pl.UTF-8):     Najszybsza przeglądarka WWW na świecie
 Name:          opera
-Version:       %{ver}
-Release:       0.%{?magicstr:%{magicstr}.}%{rel}.%{_rel}.%{sreltype}
+Version:       10.52
+Release:       0.%{subver}.%{rel}
 Epoch:         2
 License:       Distributable
 Group:         X11/Applications/Networking
-
-Source0:       http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/intel-linux/%{name}-%{sver}-%{magicstr}.%{x86_shared_rel}.i386.tar.bz2
-# Source0-md5: 4b61eeae9a4e7c10faf7dd2d6468278c
+Source0:       http://snapshot.opera.com/unix/snapshot-%{subver}/%{name}-%{version}-%{subver}.i386.linux.tar.bz2
+# Source0-md5: a1336047fefdf649fc072fb85119202e
 %{!?with_distributable:NoSource:       0}
-
-#Source1:      http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/sparc-linux/%{name}-%{sver}-%{magicstr}.%{sparc_shared_rel}-shared-qt.sparc.tar.bz2
-## Source1-md5:        913ccb28106f9f5acd3d94c8dc71ae1
-#%{!?with_distributable:NoSource:      1}
-
-#Source2:      http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/ppc-linux/%{name}-%{sver}-%{magicstr}.%{ppc_shared_rel}.ppc.tar.bz2
-## Source2-md5:        d8e072e6aad39ea3432658f68a455bc3
-#%{!?with_distributable:NoSource:      2}
-
-Source3:       http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/x86_64-linux/%{name}-%{sver}-%{magicstr}.%{x86_64_shared_rel}.x86_64.tar.bz2
-# Source3-md5: e373e06a7f08b3d142e5cd0e27812bac
-%{!?with_distributable:NoSource:        3}
-
-#Source10:     http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/intel-linux/%{name}-%{sver}-%{magicstr}.%{x86_static_rel}.i386.tar.bz2
-# Source10-md5:        9dae78bcbf2b315cd57b0ea3dc9a24df
-#%{!?with_distributable:NoSource:      10}
-
-#Source11:     http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/sparc-linux/%{name}-%{sver}-%{magicstr}.%{sparc_static_rel}.sparc.tar.bz2
-## Source11-md5:       e190021f5530de3f711006cd9f6bb339
-#%{!?with_distributable:NoSource:      11}
-
-#Source12:     http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/ppc-linux/%{name}-%{sver}-%{magicstr}.%{ppc_static_rel}.ppc.tar.bz2
-## Source12-md5:       59c2f6f710c2efabeac9e153fa934743
-#%{!?with_distributable:NoSource:      12}
-
-#Source13:     http://snapshot.opera.com/unix/%{sreltype}-%{smagicstr}/x86_64-linux/%{name}-%{sver}-%{magicstr}.%{x86_64_static_rel}.x86_64.tar.bz2
-## Source13-md5:       40b850632dbb729a0bb16a1c450d97e5
-#%{!?with_distributable:NoSource:      13}
-
-Source4:       %{name}.desktop
+Source1:       http://snapshot.opera.com/unix/snapshot-%{subver}/%{name}-%{version}-%{subver}.x86_64.linux.tar.bz2
+# Source1-md5: e6c84e019359e0b34ba614b9e8e90aee
+%{!?with_distributable:NoSource:       1}
 Patch0:                %{name}-wrapper.patch
+Patch1:                %{name}-desktop.patch
+Patch2:                %{name}-pluginpath.patch
 URL:           http://www.opera.com/
 BuildRequires: rpmbuild(macros) >= 1.356
 BuildRequires: sed >= 4.0
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk+2
+Requires(post,postun): hicolor-icon-theme
+Requires(post,postun): shared-mime-info
 Requires:      browser-plugins >= 2.0
 Requires:      freetype >= 2
+Suggests:      gstreamer-theora
+Suggests:      gstreamer-vorbis
 Provides:      wwwbrowser
 Obsoletes:     opera-i18n
-ExclusiveArch: %{ix86} %{x8664} ppc sparc sparcv9
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/opera/plugins
-%define                _operadocdir    %{_docdir}/%{name}-%{ver}
+%define                _enable_debug_packages  0
+
+%define                _plugindir              %{_libdir}/opera/plugins
+%define                _operadocdir    %{_docdir}/%{name}-%{version}
 
 %description
 Opera is world fastest web browser. It supports most of nowaday
-extensions of HTML. And it is quite stable. This version is
-%{?with_shared:shared}%{!?with_shared:statically} linked with Qt.
+extensions of HTML. And it is quite stable.
 
 %description -l pl.UTF-8
 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
-dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
-wersja jest skonsolidowana
-%{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
+dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna.
 
 %package plugin32
 Summary:       Opera 32-bit plugins support
@@ -159,26 +66,40 @@ Obsługa 32-bitowych wtyczek Opery.
 
 %prep
 %ifarch %{ix86}
-%setup -q -T -b %{!?with_shared:1}0 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.i386
-%endif
-
-%ifarch sparc sparcv9
-%setup -q -T -b %{!?with_shared:1}1 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.sparc
+%setup -q -T -b0 -n %{name}-%{version}-%{subver}.i386.linux
 %endif
+%ifarch %{x8664}
+%setup -q -T -b1 -n %{name}-%{version}-%{subver}.x86_64.linux
 
-%ifarch ppc
-%setup -q -T -b %{!?with_shared:1}2 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.ppc
 %endif
+sed -i -e '
+       s,@@{PREFIX},%{_prefix},g
+       s,@@{SUFFIX},,
+       s,@@{_SUFFIX},,
+' share/{applications/*.desktop,mime/packages/*.xml}
 
-%ifarch %{x8664}
-%setup -q -T -b %{!?with_shared:1}3 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.x86_64
-%endif
+sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
 
 %patch0 -p1
+%patch1 -p1
+
+# remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
+%{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
+%patch2 -p1
+
+mv lib/opera/plugins/README README.plugins
+mv share/opera/defaults/license.txt .
+mv share/doc/opera/* .
+
+# nobody wants scalable huge icons
+rm -rf share/icons/hicolor/scalable
+
+# opera packaging tools we don't need runtime
+mv share/opera/package .
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
 
 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
 # opera does not use for .xpt files
@@ -186,31 +107,28 @@ install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
 
 # use mplayerplug-in-opera instead
 mplayerplug-in*
-
-# opera uses libjava.so to run java
-libjavaplugin_oji.so
 EOF
 
-sh install.sh \
-       DESTDIR=$RPM_BUILD_ROOT \
-       --prefix=%{_prefix} \
-       --exec_prefix=%{_libdir}/%{name}/bin \
-       --plugindir=%{_libdir}/%{name}/plugins \
-       --docdir=%{_operadocdir}
-
-# install in kde etc.
-install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
+install -p opera* $RPM_BUILD_ROOT%{_bindir}
+cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
+cp -a share/* $RPM_BUILD_ROOT%{_datadir}
+#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
 
-install etc/* $RPM_BUILD_ROOT%{_sysconfdir}
-install usr/share/pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
+sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
+%update_mime_database
+%update_icon_cache hicolor
+%update_desktop_database_post
 %update_browser_plugins
 
 %postun
+%update_mime_database
+%update_icon_cache hicolor
+%update_desktop_database_postun
 if [ "$1" = 0 ]; then
        %update_browser_plugins
 fi
@@ -218,27 +136,28 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc LICENSE
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
+#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
 
 # browser plugins v2
 %{_browserpluginsconfdir}/browsers.d/%{name}.*
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
 
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/opera
+%attr(755,root,root) %{_bindir}/opera-widget-manager
 %dir %{_libdir}/opera
-%dir %{_libdir}/opera/bin
-%attr(755,root,root) %{_libdir}/opera/bin/*
 %ifarch %{x8664}
-%exclude %{_libdir}/opera/bin/*-ia32-*
+%exclude %{_libdir}/opera/*-ia32-*
 %endif
+%attr(755,root,root) %{_libdir}/opera/*.so
+%attr(755,root,root) %{_libdir}/opera/opera*
+#%attr(755,root,root) %{_libdir}/opera/works
 %dir %{_plugindir}
 %dir %{_datadir}/opera
 %{_datadir}/opera/*.*
 %{_datadir}/opera/defaults
 %{_datadir}/opera/extra
-%{_datadir}/opera/java
 %{_datadir}/opera/skin
-%{_datadir}/opera/scripts
+#%{_datadir}/opera/scripts
 %{_datadir}/opera/styles
 %{_datadir}/opera/ui
 %{_datadir}/opera/unite
@@ -283,15 +202,19 @@ fi
 %lang(te) %{_datadir}/opera/locale/te
 %lang(tr) %{_datadir}/opera/locale/tr
 %lang(uk) %{_datadir}/opera/locale/uk
+%lang(vi) %{_datadir}/opera/locale/vi
 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
+%{_datadir}/mime/packages/opera-widget.xml
 %{_desktopdir}/*.desktop
 %{_mandir}/man1/opera.1*
-%{_pixmapsdir}/opera.xpm
+%{_mandir}/man1/opera-widget-manager.1*
+#%{_pixmapsdir}/opera.xpm
+%{_iconsdir}/hicolor/*/*/*.png
 
 %ifarch %{x8664}
 %files plugin32
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/opera/bin/*-ia32-*
+%attr(755,root,root) %{_libdir}/opera/*-ia32-*
 %endif
This page took 0.164266 seconds and 4 git commands to generate.