]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
- weekly needs different numbers dear charles, otherwise no md5 can be updated
[packages/opera.git] / opera.spec
index e34db9c0963c21af13eea63c151c0e91a2bcee81..84a65fcc3096cb6e5c203731c49f54d6dea6a7aa 100644 (file)
@@ -5,11 +5,20 @@
 %bcond_without distributable   # distributable or not
 %bcond_without incall          # include all tarballs into src.rpm (but splitted into shared/static)
 %bcond_with    snap            # snap version
+%bcond_with    weekly          # weekly snapshot version
 
 %ifarch sparc64 sparc
 %undefine with_shared
 %endif
 
+%if %{with weekly}
+%define        ver             9.0
+%define        sver            %{ver}
+%define        fix             %{nil}
+%define        dirrel          20060224
+%define        magicstr        1670
+%define with_snap      1
+%else
 %if %{with snap}
 %define        ver             9.0
 %define        sver            %{ver}
 %define        reltype         Preview-2
 %define        magicstr        %{nil}
 %else
-%define        ver             8.51
-%define        sver            8.51
+%define        ver             8.52
+%define        sver            8.52
 %define        fix             %{nil}
-%define        dirrel          20051114
+%define        dirrel          20060201
 %define        reltype         final
 %endif
+%endif
 
 %define        shver           %(echo %{ver} | tr -d .)%{fix}
 %define        x86_shared_rel          %{dirrel}.5
@@ -82,7 +92,7 @@
 %else
 #                      with shared:    [else]
 %define        need_ix86_static_snap   1
-%define        need_sparc_static_snap  0
+%define        need_sparc_static_snap  1
 %define        need_ppc_static_snap    1
 %endif
 #                      with shared;    [endif]
@@ -197,19 +207,23 @@ License:  Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/
 Group:         X11/Applications/Networking
 
 %if %{need_ix86_static}
-Source0:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
-# Source0-md5: bd6bd9cfaf13b6509c8531d02a4c51a2
+Source0:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
+# Source0-md5: e051ee0f78dbf7fac407fad147e02d8b
 %{!?with_distributable:NoSource:       0}
 %endif
 
 %if %{need_ix86_static_snap}
+%if %{with weekly}
+Source30100:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
+%else
 Source100:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
+%endif
 %{!?with_distributable:NoSource:       100}
 %endif
 
 %if %{need_sparc_static}
-Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
-# Source1-md5: ff5976406678e864116b1ff093a177b4
+Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
+# Source1-md5: 2dec5155b24752517fbf1143d861f8f1
 %{!?with_distributable:NoSource:       1}
 %endif
 
@@ -220,30 +234,39 @@ Source101:        http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-li
 %endif
 
 %if %{need_ppc_static}
-Source2:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
-# Source2-md5: 78c3b7d568b3e35a0f7cf3b55d2a6238
+Source2:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
+# Source2-md5: 42a515f683a31522484c3770618cd2dd
 %{!?with_distributable:NoSource:       2}
 %endif
 
 %if %{need_ppc_static_snap}
+%if %{with weekly}
+Source30102:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en-%{magicstr}.tar.bz2
+%else
 Source102:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
+%endif
 %{!?with_distributable:NoSource:       102}
 %endif
 
 %if %{need_ix86_shared}
-Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source20-md5:        c9aa6c640406548fcc655a18227d9037
+Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
+# Source20-md5:        a1847d8693025a16188bc3c165eff71a
 %{!?with_distributable:NoSource:       20}
 %endif
 
 %if %{need_ix86_shared_snap}
+%if %{with weekly}
+Source301020:  http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en-%{magicstr}.tar.bz2
+# Source301020-md5:    4333fb88472e23136d107ea7393f6a97
+%else
 Source1020:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
 # Source1020-md5:      6f296be6b9fc3001588d4509016062bd
+%endif
 %{!?with_distributable:NoSource:       1020}
 %endif
 
 %if %{need_sparc_shared}
-Source21:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
+Source21:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
 # Source21-md5:        883df8058672cf52678a07d714dcfce
 %{!?with_distributable:NoSource:       21}
 %endif
@@ -255,14 +278,18 @@ Source1021:       http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-l
 %endif
 
 %if %{need_ppc_shared}
-Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source22-md5:        36f9398664c70b14c748db736a25aa2a
+Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
+# Source22-md5:        670e9fbc029a374187438e92a8c8602f
 %{!?with_distributable:NoSource:       22}
 %endif
 
 %if %{need_ppc_shared_snap}
+%if %{with weekly}
+Source301022:  http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en-%{magicstr}.tar.bz2
+%else
 Source1022:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
 # Source1022-md5:      74985fa6da49b2e54c9d03dab1119325
+%endif
 %{!?with_distributable:NoSource:       1022}
 %endif
 
@@ -271,7 +298,7 @@ Source4:    %{name}.desktop
 URL:           http://www.opera.com/
 BuildRequires: sed >= 4.0
 Requires:      freetype >= 2
-Requires:      openmotif >= 2
+%{!?with_snap:Requires:        openmotif >= 2}
 Provides:      wwwbrowser
 ExclusiveArch: %{ix86} ppc sparc sparc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -292,13 +319,13 @@ wersja jest skonsolidowana %{?with_shared:dynamicznie}%{!?with_shared:statycznie
 
 %prep
 %ifarch %{ix86}
-%setup -q -T -b %{?with_snap:10}%{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en
+%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en%{?with_weekly:-%{magicstr}}
 %endif
 %ifarch sparc sparc64
-%setup -q -T -b %{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en
+%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en
 %endif
 %ifarch ppc
-%setup -q -T -b %{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en
+%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en%{?with_weekly:-%{magicstr}}
 %endif
 
 %install
@@ -307,7 +334,8 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc,%{_libdir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
 ln -s $RPM_BUILD_ROOT/etc  $RPM_BUILD_ROOT%{_prefix}/etc
 
-sed -i -e 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' install.sh
+sed -i -e 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' \
+       -e 's|OPERA_SCRIPT_PATH=$0|OPERA_SCRIPT_PATH=|' install.sh
 
 echo y |\
 sh install.sh \
This page took 0.418333 seconds and 4 git commands to generate.