]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
- fix build for sparc, rel 2
[packages/opera.git] / opera.spec
index 3286656960acec541882a4088d0a64f5d3c3a5a4..7cce94bba45c2b3f78136acabbb69210d541e1d3 100644 (file)
@@ -5,25 +5,36 @@
 %bcond_without distributable   # distributable or not
 %bcond_without incall          # include all tarballs into src.rpm (but splitted into shared/static)
 %bcond_with    snap            # snap version
+%bcond_with    weekly          # weekly snapshot version
 
 %ifarch sparc64 sparc
 %undefine with_shared
 %endif
 
+%if %{with weekly}
+%define        ver             9.01
+%define        sver            %{ver}
+%define        fix             %{nil}
+%define        dirrel          20060629
+%define        magicstr        379
+%define with_snap      1
+%else
 %if %{with snap}
 %define        ver             9.0
 %define        sver            %{ver}
 %define        fix             %{nil}
-%define        dirrel          20051020
-%define        reltype         Preview-1
+%define        dirrel          20060206
+%define        reltype         Preview-2
 %define        magicstr        %{nil}
 %else
-%define        ver             8.51
-%define        sver            8.51
+%define        ver             9.00
+%define        sver            9.0
+%define        magicstr        344
 %define        fix             %{nil}
-%define        dirrel          20051114
+%define        dirrel          20060616
 %define        reltype         final
 %endif
+%endif
 
 %define        shver           %(echo %{ver} | tr -d .)%{fix}
 %define        x86_shared_rel          %{dirrel}.5
@@ -82,7 +93,7 @@
 %else
 #                      with shared:    [else]
 %define        need_ix86_static_snap   1
-%define        need_sparc_static_snap  0
+%define        need_sparc_static_snap  1
 %define        need_ppc_static_snap    1
 %endif
 #                      with shared;    [endif]
@@ -191,25 +202,29 @@ Summary:  World fastest web browser
 Summary(pl):   Najszybsza przegl±darka WWW na Â¶wiecie
 Name:          opera
 Version:       %{ver}%{fix}
-Release:       %{?with_snap:0.%{rel}.}1
+Release:       %{?with_snap:1.%{rel}.}2
 Epoch:         2
 License:       Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
 Group:         X11/Applications/Networking
 
 %if %{need_ix86_static}
-Source0:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
-# Source0-md5: bd6bd9cfaf13b6509c8531d02a4c51a2
+Source0:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
+# Source0-md5: 54a29d830506e6c9381a305e0353055c
 %{!?with_distributable:NoSource:       0}
 %endif
 
 %if %{need_ix86_static_snap}
-Source100:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
+%if %{with weekly}
+Source30100:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
+%else
+Source100:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
+%endif
 %{!?with_distributable:NoSource:       100}
 %endif
 
 %if %{need_sparc_static}
-Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
-# Source1-md5: ff5976406678e864116b1ff093a177b4
+Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en-%{magicstr}.tar.bz2
+# Source1-md5: 69111e768dbb3a0e7b84e1d982655db5
 %{!?with_distributable:NoSource:       1}
 %endif
 
@@ -220,30 +235,39 @@ Source101:        http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-li
 %endif
 
 %if %{need_ppc_static}
-Source2:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
-# Source2-md5: 78c3b7d568b3e35a0f7cf3b55d2a6238
+Source2:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en-%{magicstr}.tar.bz2
+# Source2-md5: b86bbd1b1ca2e146c30bfedcbe4403d0
 %{!?with_distributable:NoSource:       2}
 %endif
 
 %if %{need_ppc_static_snap}
+%if %{with weekly}
+Source30102:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en-%{magicstr}.tar.bz2
+%else
 Source102:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
+%endif
 %{!?with_distributable:NoSource:       102}
 %endif
 
 %if %{need_ix86_shared}
-Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source20-md5:        c9aa6c640406548fcc655a18227d9037
+Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en-%{magicstr}.tar.bz2
+# Source20-md5:        e1fec5d7a0ab7445856a17ac534e45ce
 %{!?with_distributable:NoSource:       20}
 %endif
 
 %if %{need_ix86_shared_snap}
+%if %{with weekly}
+Source301020:  http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en-%{magicstr}.tar.bz2
+# Source301020-md5:    e1fec5d7a0ab7445856a17ac534e45ce
+%else
 Source1020:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source1020-md5:      2ee14fa46152665c42f0ef41436e43d0
+# Source1020-md5:      6f296be6b9fc3001588d4509016062bd
 %{!?with_distributable:NoSource:       1020}
 %endif
+%endif
 
 %if %{need_sparc_shared}
-Source21:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
+Source21:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en-%{magicstr}.tar.bz2
 # Source21-md5:        883df8058672cf52678a07d714dcfce
 %{!?with_distributable:NoSource:       21}
 %endif
@@ -255,30 +279,33 @@ Source1021:       http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-l
 %endif
 
 %if %{need_ppc_shared}
-Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source22-md5:        36f9398664c70b14c748db736a25aa2a
+Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en-%{magicstr}.tar.bz2
+# Source22-md5:        65293d788e18d0c23cccac71b9fe567c
 %{!?with_distributable:NoSource:       22}
 %endif
 
 %if %{need_ppc_shared_snap}
+%if %{with weekly}
+Source301022:  http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en-%{magicstr}.tar.bz2
+# Source301022-md5:    65293d788e18d0c23cccac71b9fe567c
+%else
 Source1022:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source1022-md5:      bb130afce8f1b2252f7f7b641942b48b
+# Source1022-md5:      74985fa6da49b2e54c9d03dab1119325
 %{!?with_distributable:NoSource:       1022}
 %endif
+%endif
 
 Source4:       %{name}.desktop
 
 URL:           http://www.opera.com/
 BuildRequires: sed >= 4.0
 Requires:      freetype >= 2
-Requires:      openmotif >= 2
 Provides:      wwwbrowser
 ExclusiveArch: %{ix86} ppc sparc sparc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _plugindir      %{_libdir}/opera/plugins
-%define                _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
-%define                configfile      %{_datadir}/opera/config/opera6rc
+%define                _operadocdir    %{_docdir}/%{name}-%{ver}
 
 %description
 Opera is world fastest web browser. It supports most of nowaday
@@ -292,67 +319,40 @@ wersja jest skonsolidowana %{?with_shared:dynamicznie}%{!?with_shared:statycznie
 
 %prep
 %ifarch %{ix86}
-%setup -q -T -b %{?with_snap:10}%{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en
+%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en-%{magicstr}
 %endif
 %ifarch sparc sparc64
-%setup -q -T -b %{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en
+%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en-%{magicstr}
 %endif
 %ifarch ppc
-%setup -q -T -b %{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en
+%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en-%{magicstr}
 %endif
 
+%{__sed} -i -e 's|OPERA_SCRIPT_PATH=$0|OPERA_SCRIPT_PATH=|' install.sh
+
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
 
-install -d $RPM_BUILD_ROOT{/etc,%{_libdir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
-ln -s $RPM_BUILD_ROOT/etc  $RPM_BUILD_ROOT%{_prefix}/etc
-
-sed -i -e 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' install.sh
-
-echo y |\
 sh install.sh \
-       --prefix=$RPM_BUILD_ROOT%{_prefix} \
-       --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
-       --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
-       --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
-       --exec_prefix=$RPM_BUILD_ROOT%{_libdir}/opera/bin \
-       --plugindir=$RPM_BUILD_ROOT%{_plugindir}
-
-# man install
-install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
-
-# wrapper correction
-sed -i -e "s#$RPM_BUILD_ROOT##" $RPM_BUILD_ROOT%{_bindir}/opera
+       DESTDIR=$RPM_BUILD_ROOT \
+       --prefix=%{_prefix} \
+       --exec_prefix=%{_libdir}/opera/bin \
+       --docdir=%{_operadocdir}
 
 # install in kde etc.
 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
-
 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
 
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_datadir}/opera/java/*.policy
-
-# always use latest possible wrapper
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper
-if [ -f "$RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-3" ]; then
-       ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-1
-       ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-2
-elif [ -f "$RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-2" ]; then
-       ln -sf operamotifwrapper-2 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-1
-       ln -sf operamotifwrapper-2 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-3
-elif [ -f "$RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-1" ]; then
-       ln -sf operamotifwrapper-1 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-2
-       ln -sf operamotifwrapper-1 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-3
-fi
-
-# clean unneeded files
-rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/config
+mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/config $RPM_BUILD_ROOT/etc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE bugreport
+%doc LICENSE
+%config(noreplace) %verify(not md5 mtime size) /etc/opera*rc*
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/opera
 %dir %{_libdir}/opera/bin
@@ -369,9 +369,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/opera/locale
 %{_datadir}/opera/locale/en
 %{_datadir}/opera/locale/english.lng
-%{_pixmapsdir}/opera.xpm
 %{_desktopdir}/*.desktop
-
 %{_mandir}/man1/opera.1*
-
-%config(noreplace) %verify(not md5 mtime size) /etc/opera*rc*
+%{_pixmapsdir}/opera.xpm
This page took 0.09743 seconds and 4 git commands to generate.