]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
- include snapshot version in release, to be able to upgrade from snapshots
[packages/opera.git] / opera.spec
index 71366f47a5d8cccc72e66a869c31fffff61594d1..6e72f65fb7c187ebe68a1d3b5a2e77d1f4f27c0f 100644 (file)
@@ -6,17 +6,21 @@
 %bcond_without incall          # include all tarballs into src.rpm (but splitted into shared/static)
 %bcond_with    snap            # snap version
 
+%ifarch sparc64 sparc
+%undefine with_shared
+%endif
+
 %if %{with snap}
-%define        ver             7.60
+%define        ver             8.01
 %define        sver            %{ver}
 %define        fix             %{nil}
-%define        dirrel          20041203
-%define        reltype         Preview-4
+%define        dirrel          20050509
+%define        reltype         Preview-1
 %else
-%define        ver             8.00
-%define        sver            8.0
+%define        ver             8.01
+%define        sver            8.01
 %define        fix             %{nil}
-%define        dirrel          20050415
+%define        dirrel          20050602
 %define        reltype         final
 %endif
 
@@ -32,7 +36,8 @@
 # We should be able to build src.rpm also on not supported archs
 %define        rel             %{x86_shared_rel}
 %ifarch sparc64 sparc
-%define        rel             %{sparc_shared_rel}
+#%%define      rel             %{sparc_shared_rel}
+%define        rel             %{sparc_static_rel}
 %endif
 %ifarch ppc
 %define        rel             %{ppc_shared_rel}
@@ -85,7 +90,8 @@
 %if %{with shared}
 #                      with shared?    [if]
 %define        need_ix86_shared        1
-%define        need_sparc_shared       1
+#%%define      need_sparc_shared       1
+%define        need_sparc_static       1
 %define        need_ppc_shared 1
 %else
 #                      with shared:    [else]
 #                      with snap:      [else]
 %if    %{with shared}
 #                              with shared?    [if]
-%define        need_sparc_shared       1
+#%%define      need_sparc_shared       1
+%define        need_sparc_static       1
 %else
 #                              with shared:    [else]
 %define        need_sparc_static       1
 Summary:       World fastest web browser
 Summary(pl):   Najszybsza przegl±darka WWW na Â¶wiecie
 Name:          opera
-Version:       %{ver}%{fix}%{?with_snap:.%{rel}}
-Release:       2
+Version:       %{ver}%{fix}
+Release:       %{?with_snap:0.%{rel}.}1
 Epoch:         2
 License:       Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
 Group:         X11/Applications/Networking
@@ -200,14 +207,14 @@ Source100:        http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{nam
 %endif
 
 %if %{need_sparc_static}
-Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
-# Source1-md5: da6f20e3e881ca3c92024758dbe473d2
+Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/en/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
+# Source1-md5: a2a0eab9c4e45d55f2b93c87c80448be
 %{!?with_distributable:NoSource:       1}
 %endif
 
 %if %{need_sparc_static_snap}
 Source101:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
-# Source101-md5:       793af778c64d49299cbfe0f8e07ff7c4
+# Source101-md5:       913ccb28106f9f5acd3d9e4c8dc71ae1
 %{!?with_distributable:NoSource:       101}
 %endif
 
@@ -223,14 +230,14 @@ Source102:        http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}
 %endif
 
 %if %{need_ix86_shared}
-Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/gcc-3.2/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source20-md5:        d48b48ffbdae4a452e626c56078b7ca8
+Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
+# Source20-md5:        1cf47863f9fd9d5838b704481beb7c1a
 %{!?with_distributable:NoSource:       20}
 %endif
 
 %if %{need_ix86_shared_snap}
 Source1020:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source1020-md5:      827f62ae5781e4f66c0d30c39723dae9
+# Source1020-md5:      e3602032ae454a86cc2854685043c1aa
 %{!?with_distributable:NoSource:       1020}
 %endif
 
@@ -240,30 +247,26 @@ Source21: ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/share
 %{!?with_distributable:NoSource:       21}
 %endif
 
-%if %{need_ix86_shared_snap}
+%if %{need_sparc_shared_snap}
 Source1021:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
-# Source1021-md5:      16c77233c49ac600bed54c61898c15b7
+# Source1021-md5:      e98aeabb57962b6577a10d43c7b3efa0
 %{!?with_distributable:NoSource:       1021}
 %endif
 
 %if %{need_ppc_shared}
-Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source22-md5:        eae16c9b27e39376a89fe87eeddbe7bc
+Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
+# Source22-md5:        b005627dadd4664e6b2ff06b860d1e33
 %{!?with_distributable:NoSource:       22}
 %endif
 
 %if %{need_ppc_shared_snap}
 Source1022:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source1022-md5:      dfa0173345f3807cc5425a7903e24cb1
+# Source1022-md5:      50836edd6eae80c202edea641229a902
 %{!?with_distributable:NoSource:       1022}
 %endif
 
-Source3:       http://starzaki.eu.org/~hclan/operapl/download/ou800_1095pl.tar.gz
-# Source3-md5: 3d377634dc271d16d9041ed583077c44
-
 Source4:       %{name}.desktop
 
-
 URL:           http://www.opera.com/
 ExclusiveArch: %{ix86} ppc sparc sparc64
 Requires:      freetype >= 2
@@ -297,12 +300,12 @@ statycznie skonsolidowana z qt.
 %ifarch ppc
 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en
 %endif
-tar -xzf %{SOURCE3} -C locale
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT{/etc,%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
+install -d $RPM_BUILD_ROOT{/etc,%{_libdir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
+ln -s $RPM_BUILD_ROOT/etc  $RPM_BUILD_ROOT%{_prefix}/etc
 
 sed -i -e 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' install.sh
 
@@ -366,7 +369,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/opera/locale
 %{_datadir}/opera/locale/en
 %{_datadir}/opera/locale/english.lng
-%lang(pl) %{_datadir}/opera/locale/pl.lng
 %{_pixmapsdir}/opera.xpm
 %{_desktopdir}/*.desktop
 
This page took 0.453269 seconds and 4 git commands to generate.