]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
- rel 2; build/install from DEVEL
[packages/opera.git] / opera.spec
index 2f08b9c29ffc8e71a52dd235ef6e98cb9e7215be..676902a4223c858718a165ab6025c1717abe8b58 100644 (file)
 # BRANCHES:
 # - HEAD - stable version
 # - DEVEL - development version
-# - WEEKLY - weekly development version (sometimes it's on DEVEL)
+# - WEEKLY - weekly development version
+#
+# NOTE: to avoid creating unreadable/unmaintainable spec:
+# - don't put static version here, create STATIC branch for that for example
+# - don't create useless bconds that for example limit SourceX: to current arch only
+#
 
-%bcond_without shared          # static or shared version
-%bcond_without distributable   # distributable or not
-%bcond_with    snap            # snap version
-%bcond_with    weekly          # weekly snapshot version
+%define                ver     10.60
+%define                shver   %(echo %{ver} | tr -d .)
+%define                buildid 6386
 
-%define        ver             9.51
-%define        reltype         snapshot
-%define        magicstr        2050
-
-%define sver            %{ver}
-%define        shver           %(echo %{ver} | tr -d .)
-%define        sreltype        %(echo %{reltype} | tr - _)
-
-# http://my.opera.com/csant/blog/2007/09/06/which-is-which
-# http://my.opera.com/csant/blog/2008/05/20/which-is-which-part-two
-%define        x86_shared_rel          gcc4-shared-qt3
-%define        x86_static_rel          gcc4-qt4
-%define        sparc_shared_rel        unknown
-%define        sparc_static_rel        unknown
-%define        ppc_shared_rel          gcc4-shared-qt3
-%define        ppc_static_rel          gcc295-static-qt3
-%define x86_64_shared_rel       gcc4-shared-qt3
-%define x86_64_static_rel       unknown
-
-%if %{with shared}
-
-%define        type            shared
-
-# Defined to be able to build src.rpm also on not supported archs
-%define        rawrel          %{x86_shared_rel}
-
-%ifarch sparc sparcv9
-%define        rawrel          %{sparc_shared_rel}
-%endif
-
-%ifarch ppc
-%define        rawrel          %{ppc_shared_rel}
-%endif
-
-%ifarch %{x8664}
-%define rawrel         %{x86_64_shared_rel}
-%endif
-
-%else # [with shared]
-
-%define        type            static
-
-# Defined to be able to build src.rpm also on not supported archs
-%define        rawrel          %{x86_static_rel}
-
-%ifarch sparc sparcv9
-%define        rawrel          %{sparc_static_rel}
-%endif
-
-%ifarch ppc
-%define        rawrel          %{ppc_static_rel}
-%endif
-
-%ifarch %{x8664}
-%define rawrel             %{x86_64_static_rel}
-%endif
-
-%endif # [with shared]
-
-%define        rel     %(echo %{rawrel} | tr - _)
-
-%define                _rel    1
 Summary:       World fastest web browser
+Summary(hu.UTF-8):     A világ leggyorsabb webböngészője
 Summary(pl.UTF-8):     Najszybsza przeglądarka WWW na świecie
 Name:          opera
 Version:       %{ver}
-Release:       0.%{?magicstr:%{magicstr}.}%{rel}.%{_rel}.%{sreltype}
+Release:       2
 Epoch:         2
 License:       Distributable
 Group:         X11/Applications/Networking
-
-Source0:       http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/intel-linux/%{name}-%{sver}-%{magicstr}.%{x86_shared_rel}.i386.tar.bz2
-# Source0-md5: 6bd26d0d6aa28dde514ea5469ca5734e
-%{!?with_distributable:NoSource:       0}
-
-#Source1:      http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/sparc-linux/%{name}-%{sver}-%{magicstr}.%{sparc_shared_rel}-shared-qt.sparc.tar.bz2
-## Source1-md5:        913ccb28106f9f5acd3d94c8dc71ae1
-#%{!?with_distributable:NoSource:      1}
-
-Source2:       http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/ppc-linux/%{name}-%{sver}-%{magicstr}.%{ppc_shared_rel}.ppc.tar.bz2
-# Source2-md5: e105411f31fc38d92f5894b366c652ae
-%{!?with_distributable:NoSource:       2}
-
-#Source3:      http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/x86_64-linux/%{name}-%{sver}-%{magicstr}.%{x86_64_shared_rel}.x86_64.tar.bz2
-# Source3-md5: a13778ebd81beab3503fb4a539140581
-#%{!?with_distributable:NoSource:        3}
-
-Source10:      http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/intel-linux/%{name}-%{sver}-%{magicstr}.%{x86_static_rel}.i386.tar.bz2
-# Source10-md5:        dd13f3f1854ad1f6c8af627203241ff6
-%{!?with_distributable:NoSource:       10}
-
-#Source11:     http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/sparc-linux/%{name}-%{sver}-%{magicstr}.%{sparc_static_rel}.sparc.tar.bz2
-## Source11-md5:       e190021f5530de3f711006cd9f6bb339
-#%{!?with_distributable:NoSource:      11}
-
-#Source12:     http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/ppc-linux/%{name}-%{sver}-%{magicstr}.%{ppc_static_rel}.ppc.tar.bz2
-## Source12-md5:       59c2f6f710c2efabeac9e153fa934743
-#%{!?with_distributable:NoSource:      12}
-
-#Source13:     http://snapshot.opera.com/unix/%{sreltype}-%{magicstr}/x86_64-linux/%{name}-%{sver}-%{magicstr}.%{x86_64_static_rel}.x86_64.tar.bz2
-## Source13-md5:       40b850632dbb729a0bb16a1c450d97e5
-#%{!?with_distributable:NoSource:      13}
-
-Source4:       %{name}.desktop
+Source10:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
+# Source10-md5:        e86d604b2f9397a618e8ecf357748f55
+Source11:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
+# Source11-md5:        6415f21430bade3193d0d6c174e3bfb1
+Source12:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
+# Source12-md5:        4cd09b64a0d1c3826b3e7038326c14dc
+Source0:       %{name}.desktop
 Patch0:                %{name}-wrapper.patch
+Patch1:                %{name}-desktop.patch
+Patch2:                %{name}-pluginpath.patch
 URL:           http://www.opera.com/
+BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.356
 BuildRequires: sed >= 4.0
 Requires:      browser-plugins >= 2.0
 Requires:      freetype >= 2
 Provides:      wwwbrowser
 Obsoletes:     opera-i18n
-ExclusiveArch: %{ix86} %{x8664} ppc sparc sparcv9
+ExclusiveArch: %{ix86} %{x8664} ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _enable_debug_packages  0
+
 %define                _plugindir      %{_libdir}/opera/plugins
 %define                _operadocdir    %{_docdir}/%{name}-%{ver}
+# alternative arch for plugin32
+%define                alt_arch        i386
 
 %description
 Opera is world fastest web browser. It supports most of nowaday
-extensions of HTML. And it is quite stable. This version is
-%{?with_shared:shared}%{!?with_shared:statically} linked with Qt.
+extensions of HTML. And it is quite stable. This version is linked
+with shared version of Qt.
+
+%description -l hu.UTF-8
+Opera a világ leggyorsabb webböngészője. A manapság elterjedt
+HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
+Ez a verzió a Qt megosztott verziójához linkelődik.
 
 %description -l pl.UTF-8
 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
-wersja jest skonsolidowana
-%{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
+wersja jest skonsolidowana dynamicznie z Qt.
 
 %package plugin32
 Summary:       Opera 32-bit plugins support
+Summary(hu.UTF-8):     Opera 32-bites plugin támogatás
 Summary(pl.UTF-8):     Obsługa 32-bitowych wtyczek Opery
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      browser-plugins >= 2.0
 
 %description plugin32
 Opera 32-bit plugins support.
 
+%description plugin32 -l hu.UTF-8
+Opera 32-bites plugin támogatás.
+
 %description plugin32 -l pl.UTF-8
 Obsługa 32-bitowych wtyczek Opery.
 
 %prep
 %ifarch %{ix86}
-%setup -q -T -b %{!?with_shared:1}0 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.i386
+%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
 %endif
 
-%ifarch sparc sparcv9
-%setup -q -T -b %{!?with_shared:1}1 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.sparc
+%ifarch %{x8664}
+%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
 %endif
 
 %ifarch ppc
-%setup -q -T -b %{!?with_shared:1}2 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.ppc
+%setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
 %endif
 
-%ifarch %{x8664}
-%setup -q -T -b %{!?with_shared:1}3 -n %{name}-%{sver}-%{?magicstr:%{magicstr}.}%{rawrel}.x86_64
-%endif
+sed -i -e '
+       s,@@{PREFIX},%{_prefix},g
+       s,@@{SUFFIX},,
+       s,@@{_SUFFIX},,
+' share/{applications/*.desktop,mime/packages/*.xml}
+
+sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
 
 %patch0 -p1
+%patch1 -p1
+
+# remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
+%{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
+%patch2 -p1
+
+mv lib/opera/plugins/README README.plugins
+mv share/opera/defaults/license.txt .
+mv share/doc/opera/* .
+
+# nobody wants scalable huge icons
+rm -rf share/icons/hicolor/scalable
+
+# opera packaging tools we don't need runtime
+mv share/opera/package .
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
 
 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
 # opera does not use for .xpt files
@@ -178,31 +129,51 @@ install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
 
 # use mplayerplug-in-opera instead
 mplayerplug-in*
-
-# opera uses libjava.so to run java
-libjavaplugin_oji.so
 EOF
 
-sh install.sh \
-       DESTDIR=$RPM_BUILD_ROOT \
-       --prefix=%{_prefix} \
-       --exec_prefix=%{_libdir}/%{name}/bin \
-       --plugindir=%{_libdir}/%{name}/plugins \
-       --docdir=%{_operadocdir}
+install -p opera* $RPM_BUILD_ROOT%{_bindir}
+cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
+cp -a share/* $RPM_BUILD_ROOT%{_datadir}
+#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
 
-# install in kde etc.
-install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
+sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
 
-install etc/* $RPM_BUILD_ROOT%{_sysconfdir}
-install usr/share/pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
+cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
+[ISP]
+Id="DISTRO"
+EOF
+
+%if "%{pld_release}" == "ti"
+sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
+%else
+%if "%{pld_release}" == "ac"
+sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
+%else
+sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
+%endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
+%update_mime_database
+%update_icon_cache hicolor
+%update_desktop_database_post
 %update_browser_plugins
 
 %postun
+%update_mime_database
+%update_icon_cache hicolor
+%update_desktop_database_postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
+fi
+
+%post plugin32
+%update_browser_plugins
+
+%postun plugin32
 if [ "$1" = 0 ]; then
        %update_browser_plugins
 fi
@@ -210,29 +181,35 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc LICENSE
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
+#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
 
 # browser plugins v2
 %{_browserpluginsconfdir}/browsers.d/%{name}.*
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
-
-%attr(755,root,root) %{_bindir}/*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
+%attr(755,root,root) %{_bindir}/opera
+%attr(755,root,root) %{_bindir}/opera-widget-manager
 %dir %{_libdir}/opera
-%dir %{_libdir}/opera/bin
-%attr(755,root,root) %{_libdir}/opera/bin/*
 %ifarch %{x8664}
-%exclude %{_libdir}/opera/bin/*-ia32-*
+%exclude %{_libdir}/opera/*-ia32-*
 %endif
+%attr(755,root,root) %{_libdir}/opera/*.so
+%attr(755,root,root) %{_libdir}/opera/opera*
 %dir %{_plugindir}
+%dir %{_libdir}/opera/gstreamer
+%dir %{_libdir}/opera/gstreamer/plugins
+%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
+%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
 %dir %{_datadir}/opera
 %{_datadir}/opera/*.*
-%{_datadir}/opera/ini
-%{_datadir}/opera/java
+%{_datadir}/opera/defaults
+%{_datadir}/opera/extra
 %{_datadir}/opera/skin
 %{_datadir}/opera/styles
+%{_datadir}/opera/ui
+%{_datadir}/opera/unite
 %dir %{_datadir}/opera/locale
 %{_datadir}/opera/locale/en
-%{_datadir}/opera/locale/english.lng
 %lang(be) %{_datadir}/opera/locale/be
 %lang(bg) %{_datadir}/opera/locale/bg
 %lang(cs) %{_datadir}/opera/locale/cs
@@ -242,6 +219,7 @@ fi
 %lang(en_GB) %{_datadir}/opera/locale/en-GB
 %lang(es_ES) %{_datadir}/opera/locale/es-ES
 %lang(es_LA) %{_datadir}/opera/locale/es-LA
+%lang(et) %{_datadir}/opera/locale/et
 %lang(fi) %{_datadir}/opera/locale/fi
 %lang(fr) %{_datadir}/opera/locale/fr
 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
@@ -249,6 +227,7 @@ fi
 %lang(hi) %{_datadir}/opera/locale/hi
 %lang(hr) %{_datadir}/opera/locale/hr
 %lang(hu) %{_datadir}/opera/locale/hu
+%lang(id) %{_datadir}/opera/locale/id
 %lang(it) %{_datadir}/opera/locale/it
 %lang(ja) %{_datadir}/opera/locale/ja
 %lang(ka) %{_datadir}/opera/locale/ka
@@ -261,17 +240,28 @@ fi
 %lang(pl) %{_datadir}/opera/locale/pl
 %lang(pt) %{_datadir}/opera/locale/pt
 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
+%lang(ro) %{_datadir}/opera/locale/ro
 %lang(ru) %{_datadir}/opera/locale/ru
+%lang(sk) %{_datadir}/opera/locale/sk
+%lang(sr) %{_datadir}/opera/locale/sr
 %lang(sv) %{_datadir}/opera/locale/sv
+%lang(ta) %{_datadir}/opera/locale/ta
+%lang(te) %{_datadir}/opera/locale/te
 %lang(tr) %{_datadir}/opera/locale/tr
+%lang(uk) %{_datadir}/opera/locale/uk
+%lang(vi) %{_datadir}/opera/locale/vi
 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
+%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
+%{_datadir}/mime/packages/opera-widget.xml
+%{_datadir}/mime/packages/opera-unite-application.xml
 %{_desktopdir}/*.desktop
 %{_mandir}/man1/opera.1*
-%{_pixmapsdir}/opera.xpm
+%{_mandir}/man1/opera-widget-manager.1*
+%{_iconsdir}/hicolor/*/*/*.png
 
 %ifarch %{x8664}
 %files plugin32
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/opera/bin/*-ia32-*
+%attr(755,root,root) %{_libdir}/opera/*-ia32-*
 %endif
This page took 0.048044 seconds and 4 git commands to generate.