]> git.pld-linux.org Git - packages/openssh.git/blobdiff - openssh.spec
- fixed double "c" addition
[packages/openssh.git] / openssh.spec
index c3f2af2b6e7a5d678358c2566e46c374fb294f58..b04af47874bda5695fc49a632736f3afff52d862 100644 (file)
@@ -3,11 +3,11 @@
 # _without_gnome       - without gnome-askpass utility
 # _without_gtk         - without gtk (2.x)
 # _with_ldap           - with ldap support
-# _with_kerberos5              - with kerberos5 support
+# _with_kerberos5      - with kerberos5 support
 #
 # default to gtk2-based gnome-askpass
 
-%define                orig_ver        3.6.1p2
+%define                orig_ver        3.7.1p2
 
 %{!?_without_gtk:%define _without_gnome 1}
 Summary:       OpenSSH free Secure Shell (SSH) implementation
@@ -21,13 +21,13 @@ Summary(pt_BR):     Implementa
 Summary(ru):   OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
 Summary(uk):   OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
 Name:          openssh
-Version:       3.6.1p2%{?_with_ldap:ldap}
-Release:       3.2
+Version:       3.7.1p2
+Release:       3
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{orig_ver}.tar.gz
-# Source0-md5: f3879270bffe479e1bd057aa36258696
+# Source0-md5: 61cf5b059938718308836d00f6764a94
 Source1:       %{name}d.conf
 Source2:       %{name}.conf
 Source3:       %{name}d.init
@@ -36,28 +36,33 @@ Source5:    %{name}.sysconfig
 Source6:       passwd.pamd
 Source7:       %{name}-askpass.sh
 Source8:       %{name}-askpass.csh
+Source9:       http://www.imasy.or.jp/~gotoh/ssh/connect.c
+# NoSource9-md5:       c78de727e1208799072be78c05d64398
+Source10:      http://www.imasy.or.jp/~gotoh/ssh/connect.html
+# NoSource10-md5:      f14cb61fafd067a3f5ce4eaa9643bf05
 Patch0:                %{name}-no_libnsl.patch
 Patch2:                %{name}-linux-ipv6.patch
 Patch3:                %{name}-pam_misc.patch
 Patch4:                %{name}-sigpipe.patch
 # http://ldappubkey.gcu-squad.org/
 Patch5:                ldappubkey-ossh3.6-v2.patch
-Patch6:                openssh-heimdal.patch
+Patch6:                %{name}-heimdal.patch
+Patch7:                %{name}-pam-conv.patch
 URL:           http://www.openssh.com/
 BuildRequires: autoconf
 BuildRequires: automake
 %{!?_without_gnome:BuildRequires: gnome-libs-devel}
 %{!?_without_gtk:BuildRequires:        gtk+2-devel}
 BuildRequires: libwrap-devel
-BuildRequires: openssl-devel >= 0.9.7b
+BuildRequires: openssl-devel >= 0.9.7c
 %{?_with_ldap:BuildRequires:   openldap-devel}
 %{?_with_kerberos5:BuildRequires:      heimdal-devel}
 BuildRequires: pam-devel
 BuildRequires: %{__perl}
 %{!?_without_gtk:BuildRequires:        pkgconfig}
 BuildRequires: zlib-devel
-PreReq:                openssl >= 0.9.7
 PreReq:                FHS >= 2.1-24
+PreReq:                openssl >= 0.9.7c
 Obsoletes:     ssh
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -191,6 +196,7 @@ Summary(pt_BR):     Clientes do OpenSSH
 Summary(ru):   OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
 Summary(uk):   OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
 Group:         Applications/Networking
+Provides:      ssh-clients
 Requires:      %{name} = %{epoch}:%{version}
 Obsoletes:     ssh-clients
 
@@ -251,16 +257,17 @@ Summary(ru):      OpenSSH - 
 Summary(uk):   OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
 Group:         Networking/Daemons
 PreReq:                %{name} = %{epoch}:%{version}
-PreReq:                rc-scripts >= 0.3.1-3
+PreReq:                rc-scripts >= 0.3.1-15
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/useradd
-Requires(post):        /sbin/chkconfig
+Requires(post,preun):  /sbin/chkconfig
 Requires(post):        chkconfig >= 0.9
 Requires(post):        grep
 Requires(postun):      /usr/sbin/userdel
 Requires:      /bin/login
 Requires:      util-linux
-Obsoletes:     ssh-server
+Requires:      pam >= 0.77.3
+Provides:      ssh-server
 
 %description server
 Ssh (Secure Shell) a program for logging into a remote machine and for
@@ -392,6 +399,7 @@ GNOME.
 #%patch4 -p1
 %{?_with_ldap:%patch5 -p1}
 %{?_with_kerberos5:%patch6 -p1}
+%patch7 -p1
 
 %build
 %{__aclocal}
@@ -417,6 +425,10 @@ echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
 
 %{__make}
 
+cp -f %{SOURCE9} .
+cp -f %{SOURCE10} .
+%{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
+
 cd contrib
 %if 0%{!?_without_gnome:1}
 %{__make} gnome-ssh-askpass1 \
@@ -429,10 +441,13 @@ cd contrib
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,profile.d}}
-
-%{__make} install DESTDIR="$RPM_BUILD_ROOT"
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,profile.d}} \
+       $RPM_BUILD_ROOT%{_libexecdir}/ssh
 
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+       
+install connect    $RPM_BUILD_ROOT%{_bindir}
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
@@ -440,7 +455,6 @@ install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
 
-install -d $RPM_BUILD_ROOT%{_libexecdir}/ssh
 %if 0%{!?_without_gnome:1}
 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
 %endif
@@ -468,7 +482,7 @@ if [ -n "`id -u sshd 2>/dev/null`" ]; then
 else
        /usr/sbin/useradd -u 40 -d %{_privsepdir} -s /bin/false -M -r -c "OpenSSH PrivSep User" -g nobody sshd 1>&2
 fi
-       
+
 %post server
 /sbin/chkconfig --add sshd
 if [ -f /var/lock/subsys/sshd ]; then
@@ -503,6 +517,8 @@ fi
 
 %files clients
 %defattr(644,root,root,755)
+%doc connect.html
+%attr(0755,root,root) %{_bindir}/connect
 %attr(0755,root,root) %{_bindir}/ssh
 %attr(0755,root,root) %{_bindir}/slogin
 %attr(0755,root,root) %{_bindir}/sftp
This page took 0.067739 seconds and 4 git commands to generate.