]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
Release 10 (by relup.sh)
[packages/opencv.git] / opencv.spec
index 081a005c8046e99cb86a8b25bd5e4a24e4f429cc..99020af22643f4859e8df3542ae2b0d7379f2f11 100644 (file)
@@ -60,7 +60,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       4.5.1
-Release:       1
+Release:       10
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -104,12 +104,19 @@ Source40: https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
 # Source40-md5:        b624b995ec9c439cbc2e9e6ee940d3a2
 Patch0:                %{name}-ximea.patch
 Patch1:                python-install.patch
+Patch2:                pkgconfig-paths.patch
+Patch3:                no-cxx-in-c-header.patch
+Patch4:                gcc11.patch
+Patch5:                ogre2.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
 BuildRequires: OpenEXR-devel
 %{?with_opengl:BuildRequires:  OpenGL-GLU-devel}
-%{?with_opengl:BuildRequires:  OpenGL-devel}
+%if %{with opengl}
+BuildRequires: OpenGL-devel
+BuildRequires: libglvnd-libGL-devel
+%endif
 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
 %{?with_openni:BuildRequires:  OpenNI-devel}
 %{?with_ximea:BuildRequires:   XIMEA-devel >= 4}
@@ -130,7 +137,11 @@ BuildRequires:     gstreamer-devel >= 1.0
 BuildRequires: gstreamer-plugins-base-devel >= 1.0
 %endif
 BuildRequires: jasper-devel
-%{?with_java:BuildRequires:    jdk}
+%if %{with java}
+BuildRequires: jdk
+BuildRequires: java-xerces
+%endif
+BuildRequires: khrplatform-devel
 BuildRequires: libdc1394-devel >= 2
 %{?with_openmp:BuildRequires:  libgomp-devel}
 BuildRequires: libjpeg-devel
@@ -144,7 +155,9 @@ BuildRequires:      libucil-devel
 BuildRequires: libunicap-devel
 %endif
 BuildRequires: libv4l-devel
+BuildRequires: ogre-devel
 BuildRequires: pkgconfig
+BuildRequires: hdf5-devel
 BuildRequires: protobuf-devel
 BuildRequires: python >= 2.0
 BuildRequires: python-devel >= 2.0
@@ -326,6 +339,9 @@ Wiązania Pythona 3 do OpenCV.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 cache_file() {
        f="$1"
@@ -333,7 +349,7 @@ cache_file() {
        md5="$(md5sum "$f" | awk '{print $1}')"
        file="$(basename "$f")"
        mkdir -p ".cache/$d"
-       install "$f" ".cache/$d/$md5-$file"
+       ln -s --relative "$f" ".cache/$d/$md5-$file"
 }
 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
        cache_file $f xfeatures2d/boostdesc
@@ -344,6 +360,9 @@ done
 cache_file %{SOURCE30} data
 cache_file %{SOURCE40} ade
 
+cd opencv_contrib-%{version}
+%patch5 -p1
+
 %build
 mkdir -p build
 cd build
@@ -361,6 +380,7 @@ fi
 
 %cmake .. \
        $ccache \
+       -DOpenGL_GL_PREFERENCE=GLVND \
        -DENABLE_PRECOMPILED_HEADERS=OFF \
        -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
        -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
@@ -642,6 +662,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libopencv_viz.so
 %endif
 %{_includedir}/opencv4
+%dir %{_libdir}/cmake/opencv4
 %{_libdir}/cmake/opencv4/OpenCV*.cmake
 %{_pkgconfigdir}/opencv4.pc
 
This page took 0.054643 seconds and 4 git commands to generate.