]> git.pld-linux.org Git - packages/ocaml-net.git/blobdiff - ocaml-net.spec
- add ocaml_opt bcond
[packages/ocaml-net.git] / ocaml-net.spec
index a01a39cae1bb4259f3f01190fa61b82a5f4a0e71..74992f3fb6ca16c671879fb927e5aa74b671c3d7 100644 (file)
@@ -1,18 +1,26 @@
+#
+# Conditional build:
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+
+# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
+%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
+%endif
+
 %define                apxs    /usr/sbin/apxs
 %define                apache  /usr/sbin/httpd
 Summary:       Modules for Internet programming in OCaml
 Summary(pl.UTF-8):     Moduły ułatwiające pisanie programów internetowych w OCamlu
 Name:          ocaml-net
-Version:       3.6
-Release:       4
+Version:       3.7.7
+Release:       2
 License:       GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
 Group:         Libraries
 Source0:       http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
-# Source0-md5: c6a42744c456b3b336c7613f5481650a
+# Source0-md5: e15e0961d09057f0bbe4f69d6055506c
 Patch0:                %{name}-buildfix.patch
 Patch1:                %{name}-lablgtk2.patch
-Patch2:                %{name}-zip.patch
-Patch3:                %{name}-apache-link.patch
+Patch2:                %{name}-apache-link.patch
 URL:           http://projects.camlcity.org/projects/ocamlnet.html
 BuildRequires: %{apache}
 BuildRequires: %{apxs}
@@ -24,7 +32,6 @@ BuildRequires:        ocaml-cryptgps-devel
 BuildRequires: ocaml-cryptokit-devel
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-findlib-devel
-BuildRequires: ocaml-lablgtk-devel
 BuildRequires: ocaml-lablgtk2-devel >= 2.14.2
 BuildRequires: ocaml-labltk-devel
 BuildRequires: ocaml-pcre-devel
@@ -107,29 +114,6 @@ modułu obsługi zdarzeń na deskryptorach plików.
 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
 biblioteki equeue.
 
-%package equeue-gtk-devel
-Summary:       GTK event queue library for OCaml
-Summary(pl.UTF-8):     Biblioteka obsługująca kolejkę zdarzeń GTK dla OCamla
-License:       BSD-like
-Group:         Development/Libraries
-Requires:      %{name}-equeue-devel = %{version}-%{release}
-Requires:      ocaml-lablgtk-devel
-%requires_eq   ocaml
-
-%description equeue-gtk-devel
-Equeue provides a generic event queue module, and a specific module
-for file descriptor events.
-
-This package contains files needed to develop OCaml programs using GTK
-equeue library.
-
-%description equeue-gtk-devel -l pl.UTF-8
-Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
-modułu obsługi zdarzeń na deskryptorach plików.
-
-Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
-biblioteki equeue GTK.
-
 %package equeue-gtk2-devel
 Summary:       GTK2 event queue library for OCaml
 Summary(pl.UTF-8):     Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
@@ -616,12 +600,11 @@ Interfejs dla protokołu SMTP opisanego w RFC 2821.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
 # no %%configure, please
 ./configure \
-       -enable-gtk \
+       -disable-gtk \
        -enable-gtk2 \
        -enable-ssl \
        -enable-zip \
@@ -634,7 +617,7 @@ Interfejs dla protokołu SMTP opisanego w RFC 2821.
        -apxs %{apxs} \
        -apache %{apache}
 
-%{__make} -j1 all opt
+%{__make} -j1 all %{?with_ocaml_opt:opt}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -655,8 +638,7 @@ for f in e* n* p* r* shell smtp ; do
 done
 cd ..
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/500netcgi_apache.info
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/META
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi2-apache/500netcgi_apache.info
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
 
 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
@@ -725,13 +707,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/ocaml/site-lib/equeue
 %{_examplesdir}/%{name}-equeue-%{version}
 
-%files equeue-gtk-devel
-%defattr(644,root,root,755)
-%dir %{_libdir}/ocaml/equeue-gtk1
-%{_libdir}/ocaml/equeue-gtk1/*.cm[ixao]*
-%{_libdir}/ocaml/equeue-gtk1/*.a
-%{_libdir}/ocaml/site-lib/equeue-gtk1
-
 %files equeue-gtk2-devel
 %defattr(644,root,root,755)
 %dir %{_libdir}/ocaml/equeue-gtk2
@@ -854,6 +829,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/ocaml/netsys/*.cm[ixao]*
 %{_libdir}/ocaml/netsys/*.a
+%{_libdir}/ocaml/netsys/netsys_c_event.h
 %{_libdir}/ocaml/site-lib/netsys
 
 %files netzip-devel
This page took 0.042405 seconds and 4 git commands to generate.