]> git.pld-linux.org Git - packages/nvidiabl.git/blobdiff - nvidiabl.spec
- disable dkms bcond, whoever wants it wrap it with userspace bcond
[packages/nvidiabl.git] / nvidiabl.spec
index 47070b1fd9babd952c2ecad141cc9e1e7397b9e1..f69953b8893b8d0d7f28f1f9a0976d01096af14f 100644 (file)
@@ -1,43 +1,29 @@
 #
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
-%bcond_with    verbose         # verbose build (V=1)
-%bcond_with    dkms    # build dkms package
-
-%if "%{_alt_kernel}" != "%{nil}"
-%if 0%{?build_kernels:1}
-%{error:alt_kernel and build_kernels are mutually exclusive}
-exit 1
-%endif
-%global                _build_kernels          %{alt_kernel}
-%else
-%global                _build_kernels          %{?build_kernels:,%{?build_kernels}}
-%endif
+%bcond_without verbose         # verbose build (V=1)
+%bcond_with    dkms            # build dkms package
 
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
 %define                _duplicate_files_terminate_build        0
 
-%define                kbrs    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
-%define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
-%define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
-
-%define                rel     29
+%define                rel     3
 %define                pname   nvidiabl
 Summary:       Linux driver for nVidia display back-lights
+Summary(pl.UTF-8):     Sterownik dla Linuksa do podświetlania wyświetlacza dla kart firmy nVidia
 Name:          %{pname}%{_alt_kernel}
-Version:       0.81
+Version:       0.87
 Release:       %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL v2+
-URL:           https://github.com/guillaumezin/nvidiabl
+Group:         Base/Kernel
 Source0:       https://github.com/guillaumezin/nvidiabl/archive/v%{version}.tar.gz?/%{pname}-%{version}.tgz
-# Source0-md5: f72d90c0fe34b36a0ff3b6d7034e99c4
 Source1:       modprobe.conf
 Patch0:                nvidiabl-dkmsconf.patch
-Group:         Base/Kernel
-BuildRequires: rpmbuild(macros) >= 1.678
-%{?with_dist_kernel:%{expand:%kbrs}}
+# Source0-md5: e9418d3e500172d79680e44ad0f85743
+URL:           https://github.com/guillaumezin/nvidiabl
+BuildRequires: rpmbuild(macros) >= 1.701
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -49,18 +35,28 @@ adjust the display backlight.
 On Apple machines this driver allows more fine-grained brightness
 adjustment than the (mbp_nvidia_bl) driver and is generally preferred.
 
+%description -l pl.UTF-8
+Ten sterownik steruje rejestrem "smartdimmer" obecnym we współczesnych
+mobilnych kartach graficznych firmy nVidia (takich jak architektury
+NV40, NV41, NV43, NV44, NV46, NV47, NV49, NV4B, C51, G84, G86, G92,
+G94, G96, GT200), służącym do regulacji podświetlenia wyświetlacza.
+
+Na komputerach firmy Apple ten sterownik pozwala na dokładniejsze
+ustawianie jasności niż sterownik mbp_nvidia_bl i ogólnie jest
+zalecany.
+
 %package -n dkms-%{pname}
 Summary:       DKMS-ready driver for nVidia display back-lights
+Summary(pl.UTF-8):     Sterownik zgodny z DKMS do podświetlania wyświetlacza dla kart firmy nVidia
 License:       GPL v2+
 Group:         Base/Kernel
-Requires(pre): dkms
-Requires(post):        dkms
+Requires(pre,post):    dkms
 %if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
 %endif
 
 %description -n dkms-%{pname}
-This package contains a DKMS-ready driver for nvidia laptop display
+This package contains a DKMS-ready driver for nVidia laptop display
 back-lights.
 
 This driver drives the smartdimmer register found on modern mobile
@@ -72,17 +68,28 @@ On Apple machines this driver allows more fine-grained brightness
 adjustment than the mbp-nvidia-bl-dkms (mbp_nvidia_bl) driver and is
 generally preferred.
 
+%description -n dkms-%{pname} -l pl.UTF-8
+Ten pakiet zawiera zgodny z DKMS sterownik do podświetlania
+wyświetlacza laptopów z kartą graficzną firmy nVidia.
+
+Ten sterownik steruje rejestrem "smartdimmer" obecnym we współczesnych
+mobilnych kartach graficznych firmy nVidia (takich jak architektury
+NV40, NV41, NV43, NV44, NV46, NV47, NV49, NV4B, C51, G84, G86, G92,
+G94, G96, GT200), służącym do regulacji podświetlenia wyświetlacza.
+
+Na komputerach firmy Apple ten sterownik pozwala na dokładniejsze
+ustawianie jasności niż sterownik mbp_nvidia_bl i ogólnie jest
+zalecany.
+
 %define        kernel_pkg()\
 %package -n kernel%{_alt_kernel}-video-nvidiabl\
 Summary:       Linux driver for nVidia display back-lights\
-Summary(pl.UTF-8):     Sterownik dla Linuksa do nvidiabl\
+Summary(pl.UTF-8):     Sterownik dla Linuksa do podświetlania wyświetlacza dla kart firmy nVidia\
 Release:       %{rel}@%{_kernel_ver_str}\
 Group:         Base/Kernel\
 Requires(post,postun): /sbin/depmod\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires(postun):      %releq_kernel\
-%endif\
 \
 %description -n kernel%{_alt_kernel}-video-nvidiabl\
 This driver drives the smartdimmer register found on modern mobile\
@@ -94,9 +101,14 @@ On Apple machines this driver allows more fine-grained brightness\
 adjustment than the (mbp_nvidia_bl) driver and is generally preferred.\
 \
 %description -n kernel%{_alt_kernel}-video-nvidiabl -l pl.UTF-8\
-Sterownik dla Linuksa do nvidiabl.\
+Ten sterownik steruje rejestrem "smartdimmer" obecnym we współczesnych\
+mobilnych kartach graficznych firmy nVidia (takich jak architektury\
+NV40, NV41, NV43, NV44, NV46, NV47, NV49, NV4B, C51, G84, G86, G92,\
+G94, G96, GT200), służącym do regulacji podświetlenia wyświetlacza.\
 \
-Ten pakiet zawiera moduł jądra Linuksa.\
+Na komputerach firmy Apple ten sterownik pozwala na dokładniejsze\
+ustawianie jasności niż sterownik mbp_nvidia_bl i ogólnie jest\
+zalecany.\
 \
 %files -n kernel%{_alt_kernel}-video-nvidiabl\
 %defattr(644,root,root,755)\
@@ -115,14 +127,14 @@ Ten pakiet zawiera moduł jądra Linuksa.\
 %install_kernel_modules -D installed -m nvidiabl -d misc\
 %{nil}
 
-%{expand:%kpkg}
+%{expand:%create_kernel_packages}
 
 %prep
 %setup -qn %{pname}-%{version}
 %patch0 -p1
 
 %build
-%{expand:%bkpkg}
+%{expand:%build_kernel_packages}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.184115 seconds and 4 git commands to generate.