]> git.pld-linux.org Git - packages/ntop.git/blobdiff - ntop.spec
- converted to UTF-8
[packages/ntop.git] / ntop.spec
index b642929bba2901d85a1578a1afd74cc72b9b5414..7df70fbdd6b532f4ab414f9e792eccb136962322 100644 (file)
--- a/ntop.spec
+++ b/ntop.spec
-# TODO:
-#  - duplicate configure. remove or write down reason.
-#  - configure appears to need gawk
-#  - service ntop init steals terminal (it doesnt finish nor background)
-#  - paths wrong somewhere /var/lib/ntop/ntop is expected (should be without last path component)
-#  - /var/lib/ntop/* should be %ghost
-#  - .la files should be in -devel
-#  - ntop apperars to be daemon, so it should be in _sbindir not in _bindir
-#
 Summary:       Network monitoring tool
-Summary(pl):   Narzêdzie do monitorowania sieci
+Summary(pl.UTF-8):   Narzędzie do monitorowania sieci
 Name:          ntop
-Version:       3.1
-Release:       0.2
+Version:       3.2
+Release:       2
 License:       GPL
 Group:         Networking
 Source0:       http://dl.sourceforge.net/ntop/%{name}-%{version}.tgz
-# Source0-md5: 1c9b4097c2e464b84f2fe8f6626d2b06
+# Source0-md5: cd29a876b34a7dd76555e9acd8f160bb
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
-Patch1:                %{name}-plugins_makefile.patch
-Patch2:                %{name}-conf.patch
-Patch3:                %{name}-DESTDIR.patch
+Patch0:                %{name}-plugins_makefile.patch
+Patch1:                %{name}-conf.patch
+Patch2:                %{name}-nolibs.patch
+Patch3:                %{name}-config.patch
+Patch4:                %{name}-am.patch
 URL:           http://www.ntop.org/
 BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: automake >= 1.6
+BuildRequires: gawk
 BuildRequires: gd-devel >= 2.0.1
 BuildRequires: gdbm-devel >= 1.8.3
+BuildRequires: gdome2-devel
+BuildRequires: glib2-devel
 BuildRequires: libpcap-devel
 BuildRequires: libpng-devel
 BuildRequires: libtiff-devel
-BuildRequires: libwrap-devel
 BuildRequires: libtool
+BuildRequires: libwrap-devel
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.202
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rrdtool-devel >= 1.1.0
 BuildRequires: zlib-devel
-PreReq:                rc-scripts
+Requires(post,postun): /sbin/ldconfig
+Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires(post,preun):  /sbin/chkconfig
-Requires(post,postun): /sbin/ldconfig
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
+Requires:      rc-scripts
 Provides:      group(ntop)
 Provides:      user(ntop)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _localstatedir          /var/lib
+
 %description
 ntop is a tool that shows the network usage, similar to what the
 popular top Unix command does.
 
-%description -l pl
-ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
+%description -l pl.UTF-8
+ntop to narzędzie, które pokazuje użycie sieci w podobny sposób jak
 robi to popularna uniksowa komenda top.
 
 %prep
-%setup -q -n %{name}
+%setup -q
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+
+# kill libtool.m4 copy
+cp -f acinclude.m4.ntop acinclude.m4
 
 %build
-#mv -f acinclude.m4.in acinclude.m4
-#rm -f missing
-#%%{__libtoolize}
+%{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
+# "verified.awk -u" calls require gawk
 %configure \
-       --with-ossl-root=%{_prefix} \
-       --with-gdchart-root=`pwd`/../gdchart0.94c \
-       --enable-tcpwrap \
-       --with-gnu-ld \
+       AWK=gawk \
+       --disable-static \
        --enable-i18n \
-       --enable-showoses \
-       --localstatedir=%{_var}/lib/%{name} || true
-
-%configure \
-       --with-ossl-root=%{_prefix} \
-       --with-gdchart-root=`pwd`/../gdchart0.94c \
-       --enable-tcpwrap \
        --with-gnu-ld \
-       --localstatedir=%{_var}/lib/%{name}
-
+       --with-ossl-root=%{_prefix} \
+       --with-tcpwrap
 
-%{__make}
-cd plugins
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d     $RPM_BUILD_ROOT{%{_var}/lib/%{name},/etc/{rc.d/init.d,sysconfig}}
+install -d $RPM_BUILD_ROOT{%{_localstatedir}/ntop/rrd,/etc/{rc.d/init.d,sysconfig},%{_sbindir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ntop
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ntop
-install packages/RedHat/ntop.conf.sample $RPM_BUILD_ROOT/etc/ntop.conf
+install packages/RedHat/ntop.conf.sample $RPM_BUILD_ROOT%{_sysconfdir}/ntop.conf
 
-mv $RPM_BUILD_ROOT%{_libdir}/lib*Plugin*.so $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
-rm $RPM_BUILD_ROOT%{_libdir}/*.a
+# no -devel
+rm -f $RPM_BUILD_ROOT%{_libdir}{,/ntop/plugins}/*.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
 %groupadd -g 120 ntop
-%useradd -u 120 -d /var/lib/ntop -s /bin/false -c "ntop User" -g ntop ntop
+%useradd -u 120 -d %{_localstatedir}/ntop -s /bin/false -c "ntop User" -g ntop ntop
 
 %post
 /sbin/ldconfig
 /sbin/chkconfig --add ntop
-if [ -f /var/lock/subsys/ntop ]; then
-       /etc/rc.d/init.d/ntop restart >&2
-else
-       echo "Run \"/etc/rc.d/init.d/ntop start\" to start ntop daemon." >&2
-fi
+%service ntop restart "ntop daemon"
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/ntop ]; then
-               /etc/rc.d/init.d/ntop stop 1>&2
-       fi
+       %service ntop stop
        /sbin/chkconfig --del ntop
 fi
 
@@ -138,16 +125,17 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README THANKS
-%attr(770,root,ntop) %dir %{_var}/lib/%{name}
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*
+%doc AUTHORS ChangeLog NEWS README THANKS docs/{1STRUN.txt,FAQ}
+%attr(770,root,ntop) %dir %{_localstatedir}/ntop
+%attr(770,root,ntop) %dir %{_localstatedir}/ntop/rrd
+%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_libdir}/lib*.so
 %attr(755,root,root) %{_datadir}/%{name}
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/plugins
 %{_mandir}/man*/*
 %attr(754,root,root) /etc/rc.d/init.d/ntop
-%attr(640,root,root) /etc/sysconfig/ntop
-%attr(750,root,ntop) %dir /etc/ntop
-%attr(640,root,ntop) %config(noreplace) %verify(not size mtime md5) /etc/ntop/*
-%attr(644,root,ntop) %config(noreplace) %verify(not size mtime md5) /etc/ntop.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ntop
+%attr(750,root,ntop) %dir %{_sysconfdir}/ntop
+%attr(640,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop/*
+%attr(660,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop.conf
This page took 0.039122 seconds and 4 git commands to generate.