]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- rel 2
[packages/nginx.git] / nginx.spec
index fc12741172f7d73455cd652694f831e3bc48a83a..f2eb6be7bd62a2915bca3136a30fbb78120c9302 100644 (file)
@@ -29,6 +29,7 @@
 %bcond_with    modsecurity     # modsecurity module
 %bcond_with    rtmp            # rtmp support
 %bcond_without vts             # virtual host traffic status module
+%bcond_without headers_more    # headers more module
 
 %ifarch x32
 %undefine      with_rtsig
 %define                ssl_version     1.0.2
 %define                rtmp_version    1.2.1
 %define                vts_version     0.1.18
-%define                modsecurity_version     2.9.3
+%define                headers_more_version    0.33
+%define                modsecurity_version     3.0.4
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
 # nginx lines:
 # - stable: production quality with stable API
 # - mainline: production quality but API can change
+# http://nginx.org/en/download.html
 Name:          nginx
-Version:       1.16.1
-Release:       3
+Version:       1.20.0
+Release:       2
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: 45a80f75336c980d240987badc3dcf60
+# Source0-md5: d3d7985527d535ebcda9fc3fdbd3a974
 Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
@@ -60,12 +63,14 @@ Source7:    %{name}.init
 Source14:      %{name}.conf
 Source17:      %{name}-mime.types.sh
 Source18:      %{name}.service
-Source22:      http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
-# Source22-md5:        215a96d679a5b0fadcf13b5d09b35422
+Source33:      https://github.com/SpiderLabs/ModSecurity/releases/download/v%{modsecurity_version}/modsecurity-v%{modsecurity_version}.tar.gz
+# Source33-md5:        42c9860e0c073ca32a4a015ead970774
 Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
 # Source101-md5:       639ac2b78103adaccbcfe484a92acf44
 Source102:     https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
 # Source102-md5:       409a10dbd85e0b807cc77eecec29a3b5
+Source103:     https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
+# Source103-md5:       95e15a2331c2d4db3691a56268df5f47
 Patch0:                %{name}-no-Werror.patch
 Patch1:                %{name}-modsecurity-xheaders.patch
 URL:           http://nginx.org/
@@ -185,6 +190,14 @@ opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
 prostej konfiguracji oraz małej "zasobożerności".
 
+%package mod_headers_more
+Summary:       Nginx HTTP headers more module
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_headers_more
+Set and clear input and output headers...more than "add".
+
 %package mod_http_geoip
 Summary:       Nginx HTTP geoip module
 Group:         Daemons
@@ -266,7 +279,7 @@ monitrc file for monitoring nginx webserver.
 Plik monitrc do monitorowania serwera WWW nginx.
 
 %prep
-%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102}
+%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102} %{?with_headers_more:-a103}
 %patch0 -p0
 %{?with_modsecurity:%patch1 -p0}
 
@@ -278,6 +291,10 @@ mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
 mv nginx-module-vts-%{vts_version} nginx-vts-module
 %endif
 
+%if %{with headers_more}
+mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
+%endif
+
 # build mime.types.conf
 #sh %{SOURCE17} /etc/mime.types
 
@@ -329,6 +346,7 @@ cp -f configure auto/
        %{?with_stub_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
+       %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
        %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
@@ -409,6 +427,7 @@ load_module http_xslt_filter
 load_module mail
 %endif
 %{?with_vts:load_module http_vhost_traffic_status}
+%{?with_headers_more:load_module http_headers_more_filter}
 %if %{with stream}
 load_module stream
 %endif
@@ -456,6 +475,7 @@ fi
 %module_scripts mod_http_xslt_filter
 %module_scripts mod_mail
 %module_scripts mod_vts
+%module_scripts mod_headers_more
 %module_scripts mod_stream
 %module_scripts mod_stream_geoip
 
@@ -541,6 +561,13 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
 %endif
 
+%if %{with headers_more}
+%files mod_headers_more
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
+%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
+%endif
+
 %if %{with vts}
 %files mod_vts
 %defattr(644,root,root,755)
This page took 0.03049 seconds and 4 git commands to generate.