]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- rel 2
[packages/nginx.git] / nginx.spec
index c1883b4d810239454ae527da8cdfc116bda06973..f2eb6be7bd62a2915bca3136a30fbb78120c9302 100644 (file)
@@ -1,6 +1,7 @@
 # TODO
 # - /etc/sysconfig/nginx file
 # - missing perl build/install requires
+# - add njs: https://nginx.org/en/docs/njs/
 #
 # Conditional build for nginx:
 # Features
 %bcond_with    http_browser    # http browser module (header "User-agent" parser)
 %bcond_with    modsecurity     # modsecurity module
 %bcond_with    rtmp            # rtmp support
+%bcond_without vts             # virtual host traffic status module
+%bcond_without headers_more    # headers more module
 
 %ifarch x32
 %undefine      with_rtsig
 %endif
 
 %define                ssl_version     1.0.2
-%define                rtmp_version    1.1.11
-%define                modsecurity_version     2.9.1
+%define                rtmp_version    1.2.1
+%define                vts_version     0.1.18
+%define                headers_more_version    0.33
+%define                modsecurity_version     3.0.4
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
 # nginx lines:
 # - stable: production quality with stable API
 # - mainline: production quality but API can change
+# http://nginx.org/en/download.html
 Name:          nginx
-Version:       1.12.0
-Release:       4
+Version:       1.20.0
+Release:       2
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: 995eb0a140455cf0cfc497e5bd7f94b3
+# Source0-md5: d3d7985527d535ebcda9fc3fdbd3a974
 Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
@@ -57,13 +63,17 @@ Source7:    %{name}.init
 Source14:      %{name}.conf
 Source17:      %{name}-mime.types.sh
 Source18:      %{name}.service
-Source22:      http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
-# Source22-md5:        0fa92b852abc857a20b9e24f83f814cf
+Source33:      https://github.com/SpiderLabs/ModSecurity/releases/download/v%{modsecurity_version}/modsecurity-v%{modsecurity_version}.tar.gz
+# Source33-md5:        42c9860e0c073ca32a4a015ead970774
 Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
-# Source101-md5:       a87ab77c4414f80d394d712cceb39016
+# Source101-md5:       639ac2b78103adaccbcfe484a92acf44
+Source102:     https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
+# Source102-md5:       409a10dbd85e0b807cc77eecec29a3b5
+Source103:     https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
+# Source103-md5:       95e15a2331c2d4db3691a56268df5f47
 Patch0:                %{name}-no-Werror.patch
 Patch1:                %{name}-modsecurity-xheaders.patch
-URL:           http://nginx.net/
+URL:           http://nginx.org/
 BuildRequires: mailcap
 BuildRequires: pcre-devel
 BuildRequires: rpmbuild(macros) >= 1.644
@@ -117,6 +127,9 @@ Requires(pre):      /usr/sbin/useradd
 Requires:      rc-scripts >= 0.2.0
 Requires:      systemd-units >= 38
 Suggests:      vim-syntax-nginx
+Obsoletes:     nginx-common < 1.13.3
+Obsoletes:     nginx-light < 1.13.3
+Obsoletes:     nginx-standard < 1.13.3
 Conflicts:     rpm < 4.4.2-0.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -177,6 +190,14 @@ opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
 prostej konfiguracji oraz małej "zasobożerności".
 
+%package mod_headers_more
+Summary:       Nginx HTTP headers more module
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_headers_more
+Set and clear input and output headers...more than "add".
+
 %package mod_http_geoip
 Summary:       Nginx HTTP geoip module
 Group:         Daemons
@@ -228,6 +249,14 @@ Requires:  %{name} = %{version}-%{release}
 %description mod_mail
 Nginx mail module.
 
+%package mod_vts
+Summary:       Nginx virtual host traffic status module
+Group:         Networking/Daemons/HTTP
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_vts
+Nginx virtual host traffic status module.
+
 %package mod_stream
 Summary:       Nginx stream modules
 Group:         Daemons
@@ -250,7 +279,7 @@ monitrc file for monitoring nginx webserver.
 Plik monitrc do monitorowania serwera WWW nginx.
 
 %prep
-%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
+%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102} %{?with_headers_more:-a103}
 %patch0 -p0
 %{?with_modsecurity:%patch1 -p0}
 
@@ -258,6 +287,14 @@ Plik monitrc do monitorowania serwera WWW nginx.
 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
 %endif
 
+%if %{with vts}
+mv nginx-module-vts-%{vts_version} nginx-vts-module
+%endif
+
+%if %{with headers_more}
+mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
+%endif
+
 # build mime.types.conf
 #sh %{SOURCE17} /etc/mime.types
 
@@ -278,6 +315,7 @@ cp -f configure auto/
        --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
        --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
+       --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
        --user=nginx \
        --group=nginx \
        %{?with_select:--with-select_module} \
@@ -308,7 +346,9 @@ cp -f configure auto/
        %{?with_stub_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
+       %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
        %{?with_threads:--with-threads} \
        %{?with_http2:--with-http_v2_module} \
@@ -338,6 +378,7 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
        $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
        $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
        $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
        $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
        $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
 
@@ -385,6 +426,8 @@ load_module http_xslt_filter
 %if %{with mail}
 load_module mail
 %endif
+%{?with_vts:load_module http_vhost_traffic_status}
+%{?with_headers_more:load_module http_headers_more_filter}
 %if %{with stream}
 load_module stream
 %endif
@@ -431,6 +474,8 @@ fi
 %module_scripts mod_http_perl
 %module_scripts mod_http_xslt_filter
 %module_scripts mod_mail
+%module_scripts mod_vts
+%module_scripts mod_headers_more
 %module_scripts mod_stream
 %module_scripts mod_stream_geoip
 
@@ -443,6 +488,7 @@ fi
 %dir %attr(750,root,nginx) %{_sysconfdir}
 %dir %{_sysconfdir}/conf.d
 %dir %{_sysconfdir}/modules.d
+%dir %{_sysconfdir}/snippets
 %dir %{_sysconfdir}/vhosts.d
 %dir %{_sysconfdir}/webapps.d
 %attr(640,root,root) %{_sysconfdir}/mime.types
@@ -515,6 +561,20 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
 %endif
 
+%if %{with headers_more}
+%files mod_headers_more
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
+%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
+%endif
+
+%if %{with vts}
+%files mod_vts
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
+%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
+%endif
+
 %if %{with stream}
 %files mod_stream
 %defattr(644,root,root,755)
This page took 0.046824 seconds and 4 git commands to generate.