]> git.pld-linux.org Git - packages/nghttp2.git/blobdiff - nghttp2.spec
- updated to 1.22.0
[packages/nghttp2.git] / nghttp2.spec
index 08f4d94a2cb4f8f9a03c1b05661669ba262539ae..bdc9433e1ca4be3beab47455a125702861ef7951 100644 (file)
@@ -1,27 +1,31 @@
 #
 # Conditional build:
 %bcond_without asio            # libnghttp2_asio C++ library
+%bcond_without spdy            # SPDY support via spdylay
 %bcond_without static_libs     # static libraries
 %bcond_without tests           # "make check" call
 
 Summary:       HTTP/2.0 C library
 Summary(pl.UTF-8):     Biblioteka C HTTP/2.0
 Name:          nghttp2
-Version:       0.7.9
-Release:       2
+Version:       1.22.0
+Release:       1
 License:       MIT
 Group:         Libraries
-#Source0Download: https://github.com/tatsuhiro-t/nghttp2/releases
-Source0:       https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: ceee5061f556c0f6fce9025fce77d8c4
+#Source0Download: https://github.com/nghttp2/nghttp2/releases
+Source0:       https://github.com/nghttp2/nghttp2/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 99d7d2c8073be8dd8801e453a4307037
 Patch0:                %{name}-link.patch
-URL:           https://github.com/tatsuhiro-t/nghttp2
+Patch1:                %{name}-python.patch
+URL:           https://nghttp2.org/
 %{?with_tests:BuildRequires:   CUnit >= 2.1}
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 %{?with_asio:BuildRequires:    boost-devel >= 1.54.0}
+BuildRequires: c-ares-devel >= 1.7.5
 BuildRequires: jansson-devel >= 2.5
 BuildRequires: libev-devel
+# for examples
 BuildRequires: libevent-devel >= 2.0.8
 BuildRequires: libstdc++-devel >= 6:4.3
 BuildRequires: libtool >= 2:2.2.6
@@ -29,16 +33,24 @@ BuildRequires:      libxml2-devel >= 1:2.7.7
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig >= 1:0.20
 BuildRequires: python >= 1:2.7
-BuildRequires: python-Cython
-BuildRequires: spdylay-devel >= 1.3.0
+BuildRequires: python-Cython >= 0.19
+BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-setuptools
+BuildRequires: rpm-pythonprov
+BuildRequires: sed >= 4.0
+%{?with_spdy:BuildRequires:    spdylay-devel >= 1.3.2}
+BuildRequires: systemd-devel >= 1:209
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 BuildRequires: zlib-devel >= 1.2.3
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      c-ares >= 1.7.5
 Requires:      jansson >= 2.5
-Requires:      libevent >= 2.0.8
+# noinst examples only
+#Requires:     libevent >= 2.0.8
 Requires:      libxml2 >= 1:2.7.7
 Requires:      openssl >= 1.0.1
-Requires:      spdylay >= 1.3.0
+%{?with_spdy:Requires: spdylay >= 1.3.2}
 Requires:      zlib >= 1.2.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -53,12 +65,25 @@ version 2.0.
 Ta biblioteka jest eksperymentalną implementacją protokołu HTTP
 (Hypertext Transfer Protocol) w wersji 2.0.
 
+%package libs
+Summary:       A library implementing the HTTP/2 protocol
+Summary(pl.UTF-8):     Biblioteka implementująca protokół HTTP/2
+Group:         Libraries
+Conflicts:     nghttp2 < 1.11.1-2
+
+%description libs
+libnghttp2 is a library implementing the Hypertext Transfer Protocol
+version 2 (HTTP/2) protocol in C.
+
+%description libs -l pl.UTF-8
+libnghttp2 to napisana w C biblioteka implementująca protokół HTTP/2
+(Hypertext Transfer Protocol w wersji 2).
+
 %package devel
 Summary:       Files needed for developing with libnghttp2
 Summary(pl.UTF-8):     Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      zlib-devel >= 1.2.3
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
 Files needed for building applications with libnghttp2.
@@ -95,7 +120,7 @@ Wiązanie Pythona do biblioteki nghttp2.
 Summary:       HTTP/2.0 C++ library
 Summary(pl.UTF-8):     Biblioteka C++ HTTP/2.0
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      openssl >= 1.0.1
 
 %description asio
@@ -133,6 +158,9 @@ Statyczna biblioteka libnghttp2_asio.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+
+%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' script/fetch-ocsp-response
 
 %build
 %{__libtoolize}
@@ -147,7 +175,8 @@ Statyczna biblioteka libnghttp2_asio.
        --enable-python-bindings \
        --disable-silent-rules \
        %{!?with_static_libs:--disable-static} \
-       --without-jemalloc
+       --without-jemalloc \
+       %{?with_spdy:--with-spdylay}
 
 %{__make}
 
@@ -169,28 +198,33 @@ rm -rf $RPM_BUILD_ROOT
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
 %post  asio -p /sbin/ldconfig
 %postun        asio -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING README.rst
+%doc AUTHORS COPYING ChangeLog README.rst
 %attr(755,root,root) %{_bindir}/deflatehd
 %attr(755,root,root) %{_bindir}/h2load
 %attr(755,root,root) %{_bindir}/inflatehd
 %attr(755,root,root) %{_bindir}/nghttp
 %attr(755,root,root) %{_bindir}/nghttpd
 %attr(755,root,root) %{_bindir}/nghttpx
-%attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.5
+%dir %{_datadir}/nghttp2
+%attr(755,root,root) %{_datadir}/nghttp2/fetch-ocsp-response
 %{_mandir}/man1/h2load.1*
 %{_mandir}/man1/nghttp.1*
 %{_mandir}/man1/nghttpd.1*
 %{_mandir}/man1/nghttpx.1*
 
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.14
+
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libnghttp2.so
This page took 0.11632 seconds and 4 git commands to generate.