]> git.pld-linux.org Git - packages/nghttp2.git/blobdiff - nghttp2.spec
up to 1.61.0 (fixes CVE-2024-28182)
[packages/nghttp2.git] / nghttp2.spec
index 7d0628263a1345b0c2f5e516e503b750d98d3099..55910f5bcac293437b8f68db82c488d04bd84703 100644 (file)
@@ -1,40 +1,54 @@
+# TODO: mruby, neverbleed?
 #
 # Conditional build:
-%bcond_without tests           # don't perform "make check"
-%bcond_without static_libs     # don't build static library
+%bcond_with    http3           # experimental HTTP/3 support
+%bcond_with    libbpf          # BPF support (requires CC=clang)
+%bcond_without static_libs     # static libraries
+%bcond_without systemd         # don't include systemd support
+%bcond_without tests           # "make check" call
 
 Summary:       HTTP/2.0 C library
 Summary(pl.UTF-8):     Biblioteka C HTTP/2.0
 Name:          nghttp2
-Version:       0.5.0
+Version:       1.61.0
 Release:       1
 License:       MIT
 Group:         Libraries
-#Source0Download: https://github.com/tatsuhiro-t/nghttp2/releases
-Source0:       https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 7eb82c4d113c13c526249c3941b8b411
-URL:           https://github.com/tatsuhiro-t/nghttp2
-%{?with_tests:BuildRequires:   CUnit >= 2.1}
+#Source0Download: https://github.com/nghttp2/nghttp2/releases
+Source0:       https://github.com/nghttp2/nghttp2/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 0bb5661ff08b983487d6683350770c36
+URL:           https://nghttp2.org/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
+BuildRequires: c-ares-devel >= 1.7.5
 BuildRequires: jansson-devel >= 2.5
+%{?with_libbpf:BuildRequires:  libbpf-devel >= 0.7.0}
+BuildRequires: libev-devel
+# for examples
 BuildRequires: libevent-devel >= 2.0.8
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 6:5
 BuildRequires: libtool >= 2:2.2.6
-BuildRequires: libxml2-devel >= 1:2.7.7
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: libxml2-devel >= 1:2.6.26
+%{?with_http3:BuildRequires:   nghttp3-devel >= 1.1.0}
+# +ngtcp2-crypto-openssl or ngtcp2-crypto-boringssl
+%{?with_http3:BuildRequires:   ngtcp2-devel >= 1.4.0}
+BuildRequires: openssl-devel >= 1.1.1
+%{?with_http3:BuildRequires:   openssl-devel(quic)}
 BuildRequires: pkgconfig >= 1:0.20
-BuildRequires: python >= 1:2.7
-BuildRequires: python-Cython
-BuildRequires: spdylay-devel >= 1.2.3
+BuildRequires: python3 >= 1:3.8
+BuildRequires: rpmbuild(macros) >= 1.734
+BuildRequires: sed >= 4.0
+%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 BuildRequires: zlib-devel >= 1.2.3
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      c-ares >= 1.7.5
 Requires:      jansson >= 2.5
-Requires:      libevent >= 2.0.8
-Requires:      libxml2 >= 1:2.7.7
-Requires:      openssl >= 1.0.1
-Requires:      spdylay >= 1.2.3
+# noinst examples only
+#Requires:     libevent >= 2.0.8
+Requires:      libxml2 >= 1:2.6.26
+Requires:      openssl >= 1.1.1
 Requires:      zlib >= 1.2.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -46,12 +60,26 @@ version 2.0.
 Ta biblioteka jest eksperymentalną implementacją protokołu HTTP
 (Hypertext Transfer Protocol) w wersji 2.0.
 
+%package libs
+Summary:       A library implementing the HTTP/2 protocol
+Summary(pl.UTF-8):     Biblioteka implementująca protokół HTTP/2
+Group:         Libraries
+Obsoletes:     python3-nghttp2 < 1.55.1
+Conflicts:     nghttp2 < 1.11.1-2
+
+%description libs
+libnghttp2 is a library implementing the Hypertext Transfer Protocol
+version 2 (HTTP/2) protocol in C.
+
+%description libs -l pl.UTF-8
+libnghttp2 to napisana w C biblioteka implementująca protokół HTTP/2
+(Hypertext Transfer Protocol w wersji 2).
+
 %package devel
 Summary:       Files needed for developing with libnghttp2
 Summary(pl.UTF-8):     Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      zlib-devel >= 1.2.3
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
 Files needed for building applications with libnghttp2.
@@ -71,22 +99,11 @@ Static libnghttp2 library.
 %description static -l pl.UTF-8
 Statyczna biblioteka libnghttp2.
 
-%package -n python-nghttp2
-Summary:       Python binding to nghttp2 library
-Summary(pl.UTF-8):     Wiązanie Pythona do biblioteki nghttp2
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-Requires:      python-libs >= 1:2.7
-
-%description -n python-nghttp2
-Python binding to nghttp2 library.
-
-%description -n python-nghttp2 -l pl.UTF-8
-Wiązanie Pythona do biblioteki nghttp2.
-
 %prep
 %setup -q
 
+%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' script/fetch-ocsp-response
+
 %build
 %{__libtoolize}
 %{__aclocal} -I m4
@@ -94,8 +111,13 @@ Wiązanie Pythona do biblioteki nghttp2.
 %{__autoheader}
 %{__automake}
 %configure \
+       --enable-app \
+       --enable-hpack-tools \
+       %{?with_http3:--enable-http3} \
        --disable-silent-rules \
-       %{!?with_static_libs:--disable-static}
+       %{!?with_static_libs:--disable-static} \
+       --without-jemalloc \
+       %{?with_libbpf:--with-libbpf}
 
 %{__make}
 
@@ -110,36 +132,42 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libnghttp2.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
 # packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/nghttp2
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING README.rst
+%doc AUTHORS COPYING ChangeLog README.rst
 %attr(755,root,root) %{_bindir}/deflatehd
 %attr(755,root,root) %{_bindir}/h2load
 %attr(755,root,root) %{_bindir}/inflatehd
 %attr(755,root,root) %{_bindir}/nghttp
 %attr(755,root,root) %{_bindir}/nghttpd
 %attr(755,root,root) %{_bindir}/nghttpx
-%attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.4
+%dir %{_datadir}/nghttp2
+%attr(755,root,root) %{_datadir}/nghttp2/fetch-ocsp-response
 %{_mandir}/man1/h2load.1*
 %{_mandir}/man1/nghttp.1*
 %{_mandir}/man1/nghttpd.1*
 %{_mandir}/man1/nghttpx.1*
 
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.14
+
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libnghttp2.so
-%{_includedir}/nghttp2
+%dir %{_includedir}/nghttp2
+%{_includedir}/nghttp2/nghttp2*.h
 %{_pkgconfigdir}/libnghttp2.pc
 
 %if %{with static_libs}
@@ -147,8 +175,3 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libnghttp2.a
 %endif
-
-%files -n python-nghttp2
-%defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/nghttp2.so
-%{py_sitedir}/python_nghttp2-0.0.0-py*.egg-info
This page took 0.033893 seconds and 4 git commands to generate.