]> git.pld-linux.org Git - packages/nagios.git/blobdiff - nagios.spec
Do not package nagioswall.php twice
[packages/nagios.git] / nagios.spec
index afa43ace4ab155bff14e19a6abe73b3b0cb26cac..0955580a51cbc9296d8cff00551bfcd22f428ba4 100644 (file)
@@ -3,7 +3,7 @@
 #
 # Conditional build:
 %bcond_without gd      # without statusmap and trends, which require gd library
-%bcond_without epn     # without Embedded Perl
+%bcond_with    epn     # with Embedded Perl
 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
 %bcond_with    tests
 
@@ -11,12 +11,12 @@ Summary:    Host/service/network monitoring program
 Summary(pl.UTF-8):     Program do monitorowania serwerów/usług/sieci
 Summary(pt_BR.UTF-8):  Programa para monitoração de máquinas e serviços
 Name:          nagios
-Version:       3.3.1
+Version:       3.4.3
 Release:       1
 License:       GPL v2+
 Group:         Networking
 Source0:       http://downloads.sourceforge.net/nagios/%{name}-%{version}.tar.gz
-# Source0-md5: c935354ce0d78a63bfabc3055fa77ad5
+# Source0-md5: adb04a255a3bb1574840ebd4a0f2eb76
 Source1:       %{name}-apache.conf
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -28,6 +28,7 @@ Source6:      http://www.google.com/mapfiles/shadow50.png
 Source7:       http://www.google.com/mapfiles/marker.png
 # Source7-md5: edefef4bdfc29e1c953694651f05b466
 Source8:       googlemap.js
+Source9:       nagioswall.php
 Patch0:                %{name}-resources.patch
 Patch1:                %{name}-iconv-in-libc.patch
 Patch2:                %{name}-webapps.patch
@@ -37,17 +38,23 @@ Patch5:             config.patch
 Patch6:                %{name}-googlemap.patch
 Patch7:                %{name}-doc-usermacros.patch
 Patch8:                archivelog-timeformat.patch
-Patch9:                %{name}-html-Makefile.in.patch
+Patch9:                system-magpierss.patch
+Patch10:       system-jquery.patch
+Patch11:       do-not-fetch-rss.patch
 URL:           http://www.nagios.org/
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: sed >= 4.0
 %if %{with gd}
 BuildRequires: gd-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 %endif
-BuildRequires: rpmbuild(macros) >= 1.268
-BuildRequires: sed >= 4.0
+%if %{with tests}
+BuildRequires: perl-HTML-Lint
+BuildRequires: perl-Test-WWW-Mechanize-CGI
+%endif
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-common = %{version}-%{release}
 Requires:      rc-scripts
@@ -135,6 +142,7 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      %{name}-imagepaks
 Requires:      %{name}-theme
 Requires:      group(http)
+Requires:      jquery
 Requires:      webapps
 Requires:      webserver
 Requires:      webserver(access)
@@ -143,6 +151,7 @@ Requires:   webserver(auth)
 Requires:      webserver(cgi)
 Requires:      webserver(indexfile)
 Suggests:      %{name}-doc
+Suggests:      php-magpierss >= 0.72
 
 %description cgi
 CGI webinterface for Nagios.
@@ -169,21 +178,32 @@ Group:            Documentation
 %description doc
 HTML Documentation for Nagios.
 
-%package theme-default
-Summary:       Default Nagios theme
-Summary(pl.UTF-8):     Domyślny motyw Nagiosa
+%package theme-classicui
+Summary:       ClassicUI Nagios theme
 Group:         Applications/WWW
 Requires:      %{name}-cgi = %{version}-%{release}
 Requires:      webserver(php)
 Provides:      nagios-theme
 Obsoletes:     nagios-theme
 
-%description theme-default
+%description theme-classicui
 Original theme from Nagios.
 
-%description theme-default -l pl.UTF-8
+%description theme-classicui -l pl.UTF-8
 Oryginalny motyw z Nagiosa.
 
+%package theme-default
+Summary:       Virtual package to handle Nagios theme migration
+Group:         Applications/WWW
+Requires:      nagios-theme
+Suggests:      nagios-theme-classicui
+Suggests:      nagios-theme-exfoliation
+Suggests:      nagios-theme-nuvola
+Obsoletes:     nagios-theme-default < 3.3.1-1.4
+
+%description theme-default
+Virtual package to handle Nagios theme migration
+
 %package devel
 Summary:       Include files that Nagios-related applications may compile against
 Summary(pl.UTF-8):     Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
@@ -209,7 +229,6 @@ mv %{name}/* .
 %undos cgi/*.c
 %undos include/*.h
 %undos base/*
-%undos p1.pl
 %patch0 -p0
 %patch1 -p1
 %patch2 -p1
@@ -221,6 +240,8 @@ mv %{name}/* .
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
+%patch11 -p1
 
 find -name .cvsignore -o -name .gitignore | xargs rm
 
@@ -257,10 +278,19 @@ sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
 #      s,/usr/local/%{name}/var/archives/,/var/log/%{name}/archives/,
 #' html/docs/configmain.html
 
+#rm t/611cgistatus-hosturgencies.t
+
 %build
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
+%if %{with tests}
+cd tap
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+cd ..
+%endif
 %configure \
        CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        --bindir=%{_sbindir} \
@@ -327,6 +357,7 @@ cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
+cp -p %{SOURCE9} $RPM_BUILD_ROOT%{htmldir}
 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
 
@@ -468,7 +499,7 @@ done
 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
 
-%attr(770,root,nagios) %dir %{_var}/spool/%{name}/checkresults
+%attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
 
 %{_examplesdir}/%{name}-%{version}
 
@@ -492,7 +523,7 @@ done
 %dir %{_prefix}/lib/%{name}/eventhandlers
 %endif
 
-%attr(770,root,nagios) %dir %{_var}/spool/%{name}
+%attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
 
 %files mrtggraphs
 %defattr(644,root,root,755)
@@ -525,9 +556,11 @@ done
 %{htmldir}/images/favicon.ico
 %{htmldir}/images/marker.png
 %{htmldir}/images/shadow50.png
+%{htmldir}/nagioswall.php
 
-%files theme-default
+%files theme-classicui
 %defattr(644,root,root,755)
+%exclude %{htmldir}/nagioswall.php
 %{htmldir}/*.php
 %{htmldir}/includes/*
 %{htmldir}/images/*
@@ -536,6 +569,9 @@ done
 %exclude %{htmldir}/images/shadow50.png
 %{htmldir}/stylesheets/*
 
+%files theme-default
+%defattr(644,root,root,755)
+
 %files devel
 %defattr(644,root,root,755)
 %dir %{_includedir}/%{name}
This page took 0.071887 seconds and 4 git commands to generate.