]> git.pld-linux.org Git - packages/mythtv.git/blobdiff - mythtv.spec
- linuxtv-dvb-1.1.1 from llh
[packages/mythtv.git] / mythtv.spec
index 333e1f8bc68ef0f9ff48ad717b7aa607616a9147..05633c7e6cce7faaf3f8d1264b8ec5cb579c2978 100644 (file)
@@ -1,3 +1,7 @@
+# TODO
+# - CFLAGS doesn't get passed
+# - bconds broken?
+# - mythtv user
 #
 # Specfile for MythTV
 #
 #  to use "--with cpu_autodetect" to let mythtv decide for you.
 #
 
-# The name of the DVB driver package (used in a couple of places,
-# so it's not hard-coded in the spec itself)
-%define linuxtv_dvb_package linuxtv-dvb-1.1.1
-
 # Set up some custom-build parameters
-%bcond_with    lirc
-%bcond_without alsa
-%bcond_without oss
-%bcond_with opengl_vsync
-%bcond_with arts
-%bcond_with xvmc
+%bcond_with    lirc    # lirc
+%bcond_without alsa    # alsa
+%bcond_without oss # oss
+%bcond_with opengl_vsync # opengl vsync
+%bcond_with arts # arts
+%bcond_with xvmc # xvmc
 %bcond_with cpu_autodetect # enable cpu autodetection at compile time
-
 Name:          mythtv
 Version:       0.17
 #define _snap 20050326
-Release:       0.2
+Release:       0.3
 Summary:       A personal video recorder (PVR) application.
 Group:         Applications/Multimedia
 License:       GPL v2
@@ -32,7 +31,6 @@ Source0:      http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
 Source1:       mythbackend.sysconfig
 Source2:       mythbackend.init
 Source3:       mythbackend.logrotate
-Source12:      http://linuxtv.org/download/dvb/%{linuxtv_dvb_package}.tar.bz2
 Patch0:                %{name}-configure.patch
 # Source12-md5:        6dd599f24b7abecd1e32c203eaa7fa8a
 ExclusiveArch: i386 i686 athlon x86_64
@@ -46,21 +44,13 @@ BuildRequires:      qt-devel >= 6:3.2.1-4
 BuildRequires: qmake >= 6:3.2.1-4
 BuildRequires: mysql-devel
 BuildRequires: desktop-file-utils
-%if %{with alsa}
-BuildRequires: alsa-lib-devel
-%endif
-%if %{with lirc}
-BuildRequires: lirc-devel
-%endif
-%if %{with arts}
-BuildRequires: arts-devel >= 13:0.9.5
-%endif
-%if %{with xvmc}
-BuildRequires: nvidia-graphics-devel
-%endif
-%if %{with opengl_vsync}
-BuildRequires: nvidia-graphics-devel
-%endif
+BuildRequires: sed >= 4.0
+BuildRequires: linux-libc-headers >= 7:2.6.10
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_lirc:BuildRequires:    lirc-devel}
+%{?with_arts:BuildRequires:    arts-devel >= 13:0.9.5}
+%{?with_xvmc:BuildRequires:    nvidia-graphics-devel}
+%{?with_opengl_vsync:BuildRequires:    nvidia-graphics-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -182,32 +172,23 @@ This package contains only the setup software for configuring the
 mythtv backend.
 
 %prep
-%setup -q -a 12
+%setup -q
 %patch0 -p1
 
 %build
 export QTDIR="%{_prefix}"
-#export QMAKESPEC="linux-g++"
-
-# Initialize the options string
-OPTS=""
-
-
-# Finally, actually configure
+export QMAKESPEC="linux-g++"
+export CFLAGS="%{rpmcflags} -fomit-frame-pointer"
 
 # BTW: this is not autoconf configure
 %configure \
     --compile-type=%{?debug:debug}%{!?debug:release} \
     --disable-audio-jack \
-    --enable-dvb \
-    --dvb-path=%{_builddir}/%{name}-%{version}/%{linuxtv_dvb_package}/linux/include \
+    --enable-dvb --dvb-path=%{_includedir} \
 %if %{with cpu_autodetect}
-    %ifarch i386
+    %ifarch i386 i686
                --cpu=i386 --tune=pentium4 --enable-mmx \
     %endif
-    %ifarch i686
-        --cpu=i686 --tune=pentium4 --enable-mmx \
-    %endif
     %ifarch athlon
         --arch=athlon \
     %endif
@@ -228,12 +209,16 @@ OPTS=""
 #  --enable-dvb-eit \
 
 #sed -i -e 's:OPTFLAGS=.*:OPTFLAGS=%{rpmcflags} -Wno-switch:g' config.mak
+# dunno. the configure doesn't take --prefix...
+sed -i -e 's:PREFIX =.*:PREFIX = %{_prefix}:g' settings.pro
 
 # MythTV doesn't support parallel builds
-qmake -o Makefile mythtv.pro \
-    QMAKE_CXX="%{__cxx}" \
-    QMAKE_LINK="%{__cxx}" \
-    QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}"
+#qmake -o Makefile mythtv.pro \
+#    QMAKE_CXX="%{__cxx}" \
+#    QMAKE_LINK="%{__cxx}" \
+#    QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}"
+
+qmake mythtv.pro
 
 %{__make} qmake
 
@@ -244,14 +229,10 @@ find contrib -type f | xargs -r chmod a-x
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT
 
+export QTDIR="%{_prefix}"
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT{/usr/local/bin,%{_bindir}}
-mv $RPM_BUILD_ROOT{/usr/local/include,%{_includedir}}
-mv $RPM_BUILD_ROOT{/usr/local/share,%{_datadir}}
-mv $RPM_BUILD_ROOT{/usr/local/lib,%{_libdir}}
-
 # Install the files that we added on top of mythtv's own stuff
 install -pD %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/mythbackend
 install -pD %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/mythbackend
@@ -303,7 +284,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files backend
 %defattr(644,root,root,755)
-#%attr(755,root,root) %{_bindir}/mythbackend # MISSING
+%attr(755,root,root) %{_bindir}/mythbackend
 %attr(755,root,root) %{_bindir}/mythfilldatabase
 %attr(755,root,root) %{_bindir}/mythjobqueue
 %attr(-,mythtv,mythtv) %dir /var/lib/mythtv
@@ -320,7 +301,7 @@ rm -rf $RPM_BUILD_ROOT
 %files frontend
 %defattr(644,root,root,755)
 %{_datadir}/mythtv/*.xml
-#%attr(755,root,root) %{_bindir}/mythfrontend # MISSING
+%attr(755,root,root) %{_bindir}/mythfrontend
 %attr(755,root,root) %{_bindir}/mythtv
 %attr(755,root,root) %{_bindir}/mythepg
 %attr(755,root,root) %{_bindir}/mythprogfind
This page took 0.059494 seconds and 4 git commands to generate.