]> git.pld-linux.org Git - packages/mythplugins.git/blobdiff - mythplugins.spec
- fix shebangs and files, rel 11
[packages/mythplugins.git] / mythplugins.spec
index d8f533a0e78f89ff29f8355cbf9897998af3d047..3eccc83863147bee28b14f3dedd71d9a8c5e5e35 100644 (file)
 %undefine      with_mythweather
 %endif
 
-%include       /usr/lib/rpm/macros.perl
 
 Summary:       Main MythTV plugins
 Summary(pl.UTF-8):     Główne wtyczki MythTV
 Name:          mythplugins
-Version:       0.26.0
-Release:       1
+Version:       0.26.1
+Release:       11
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
-# Source0-md5: 15bd7b2f4173488966f3d761e0eacffa
+# Source0-md5: d896d9f9313ba5dd95e2e977bf9c0f8f
 Source1:       mythweb-apache.conf
 Source2:       mythweb_lighttpd.conf
 Source3:       htdigest.sh
@@ -43,11 +42,13 @@ Source4:    http_servers_conf_tips.txt
 Source5:       mythweb-httpd.conf
 Patch0:                mythweb-chdir.patch
 Patch1:                system-zmq.patch
+Patch2:                cxx11.patch
+Patch3:                gcc11.patch
 Patch10:       %{name}-compile_fixes_for_qt_4_7.patch
 Patch20:       %{name}-mytharchive-INT64.patch
 URL:           http://www.mythtv.org/
 %if %{with binary}
-%if %{with mythgallery} || %{with myhtmusic}
+%if %{with mythgallery} || %{with mythmusic}
 BuildRequires: OpenGL-devel
 %endif
 BuildRequires: Qt3Support-devel
@@ -60,12 +61,18 @@ BuildRequires:      QtWebKit-devel
 BuildRequires: QtXml-devel
 BuildRequires: SDL-devel
 BuildRequires: a52dec-libs-devel
-BuildRequires: cdparanoia-III-devel
 BuildRequires: faad2-devel >= 2.0-5.2
-%{?with_mythmusic:BuildRequires:       fftw-devel >= 2.1.3}
+%if %{with mythmusic}
+BuildRequires: cdparanoia-III-devel
+BuildRequires: fftw3-devel
+BuildRequires: fftw3-single-devel
 BuildRequires: flac-devel >= 1.0.4
-BuildRequires: freetype-devel
+BuildRequires: lame-libs-devel
 BuildRequires: libcdaudio-devel >= 0.99.12p2
+BuildRequires: libvorbis-devel >= 1:1.0
+BuildRequires: taglib-devel
+%endif
+BuildRequires: freetype-devel
 BuildRequires: libdvdcss-devel >= 1.2.7
 BuildRequires: libdvdread-devel >= 0.9.4
 %{?with_mythgallery:BuildRequires:     libexif-devel >= 1:0.6.9}
@@ -76,7 +83,6 @@ BuildRequires:        libmyth-devel > 0.26
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: libvisual-devel
-BuildRequires: libvorbis-devel >= 1:1.0
 BuildRequires: mjpegtools-devel >= 1.6.1
 BuildRequires: nasm
 BuildRequires: patchutils
@@ -84,8 +90,11 @@ BuildRequires:       patchutils
 %{?with_mythweather:BuildRequires:      perl-Image-Size}
 %{?with_mythweather:BuildRequires:     perl-XML-Simple}
 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
-%{?with_mythnetvision:BuildRequires:   python-MythTV}
-%{?with_mythnetvision:BuildRequires:   python-oauth}
+%if %{with mythnetvision}
+BuildRequires: python-MythTV
+BuildRequires: python-lxml
+BuildRequires: python-oauth
+%endif
 BuildRequires: qt4-build
 BuildRequires: qt4-qmake
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -95,8 +104,6 @@ BuildRequires:       xorg-lib-libX11-devel
 BuildRequires: xvid-devel >= 1:0.9.1
 BuildRequires: zlib-devel
 %endif
-Obsoletes:     mythdvd < %{version}-%{release}
-Obsoletes:     mythmovies < %{version}-%{release}
 %{?with_mytharchive:Requires:  mytharchive}
 %{?with_mythbrowser:Requires:  mythbrowser}
 %{?with_mythgallery:Requires:  mythgallery}
@@ -106,8 +113,10 @@ Obsoletes: mythmovies < %{version}-%{release}
 %{?with_mythnews:Requires:     mythnews}
 %{?with_mythweather:Requires:  mythweather}
 %{?with_mythweb:Requires:      mythweb}
+Obsoletes:     mythdvd < %{version}-%{release}
+Obsoletes:     mythmovies < %{version}-%{release}
 Obsoletes:     mythvideo
-ExclusiveArch: %{ix86} %{x8664} ppc
+ExclusiveArch: %{ix86} %{x8664} x32 ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
@@ -278,7 +287,6 @@ Requires:   mythtv-frontend-api = %{myth_api_version}
 %description -n mythzoneminder
 MythTV security TV manager.
 
-
 %description -n mythzoneminder -l pl.UTF-8
 Obsługa kamer przemysłowych dla MythTV.
 
@@ -286,11 +294,13 @@ Obsługa kamer przemysłowych dla MythTV.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 #%patch10 -p1
 %patch20 -p1
 
 # lib64 fix - enable to update patch
-%if %{_lib} != "lib" && 0
+%if "%{_lib}" != "lib" && 0
 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
 xargs grep -l /lib/ . | xargs sed -i -e '
 s,%{_prefix}/lib/,/%{_lib}/,g
@@ -299,6 +309,12 @@ s,%{_prefix}/lib/,/%{_lib}/,g
 exit 1
 %endif
 
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
+      mytharchive/mythburn/scripts/mythburn.py \
+      mythgame/mythgame/scripts/giantbomb.py \
+      mythgame/mythgame/scripts/giantbomb/giantbomb_api.py \
+      mythgame/mythgame/scripts/giantbomb/giantbomb_exceptions.py
+
 %build
 %if %{with binary}
 export QTDIR="%{_prefix}"
@@ -354,7 +370,7 @@ install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
-ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
+ln -sfr $RPM_BUILD_ROOT/var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
@@ -624,7 +640,7 @@ which packages you can need to run mythweb and how to set it quickly."
 %doc mythzoneminder/{AUTHORS,README}
 %attr(755,root,root) %{_bindir}/mythzmserver
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
-%dir %{_datadir}/mythtv/zonemindermenu.xml
+%{_datadir}/mythtv/zonemindermenu.xml
 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
 %{_datadir}/mythtv/themes/default/mz_*png
This page took 0.04895 seconds and 4 git commands to generate.