]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- missed BR,
[packages/firefox.git] / mozilla-firefox.spec
index 9a22f20fe3a09acc33484c01c69d6f954f7e44ab..75d53c0534f84654e9cadb2118bd2f6839c00225 100644 (file)
@@ -4,37 +4,54 @@
 # - move most of %%post to external script as it's done in debian
 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
 #   for hints how to make locales and other stuff like extensions working
+# - SECURITY: http://securitytracker.com/alerts/2004/Sep/1011318.html
 #
 # Conditional build:
 %bcond_with    tests   # enable tests (whatever they check)
+%bcond_with    ft218   # compile with freetype >= 2.1.8
 #
 Summary:       Mozilla Firefox web browser
 Summary(pl):   Mozilla Firefox - przegl±darka WWW
 Name:          mozilla-firefox
-Version:       0.9.3
-Release:       0.2
+Version:       1.0
+Release:       0.1
 License:       MPL/LGPL
 Group:         X11/Applications/Networking
-Source0:       http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/firefox-%{version}-source.tar.bz2
-# Source0-md5: 641ebf96d2211b3c5527e88389b9687e
+Source0:       http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0/source/firefox-1.0-source.tar.bz2
+# Source0-md5: 49c16a71f4de014ea471be81e46b1da8
 Source1:       %{name}.desktop
+Source2:       %{name}.sh
 Patch0:                %{name}-alpha-gcc3.patch
-Patch1:                %{name}-nspr.patch
-Patch2:                %{name}-nss.patch
-Patch3:                %{name}-lib_path.patch
+Patch1:                %{name}-nss.patch
+Patch2:                %{name}-lib_path.patch
+Patch3:                %{name}-freetype.patch
 URL:           http://www.mozilla.org/projects/firefox/
 BuildRequires: automake
-BuildRequires: gtk+2-devel >= 2.0.0
+%if %{with ft218}
+BuildRequires: freetype-devel >= 1:2.1.8
+%else
+BuildRequires: freetype-devel >= 2.1.3
+BuildRequires: freetype-devel < 1:2.1.8
+BuildConflicts:        freetype-devel = 2.1.8
+%endif
+BuildRequires: gtk+2-devel >= 1:2.0.0
 BuildRequires: libIDL-devel >= 0.8.0
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.2.0
 BuildRequires: libstdc++-devel
-BuildRequires: nspr-devel >= 1:4.5.0
 BuildRequires: nss-devel >= 3.8
-BuildRequires: pango-devel >= 1.1.0
+BuildRequires: nspr-devel
+BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: perl(Time::localtime)
 BuildRequires: zip
 Requires:      %{name}-lang-resources = %{version}
-Requires:      nspr >= 1:4.5.0
+%if %{with ft218}
+Requires:      freetype >= 1:2.1.3
+%else
+Requires:      freetype >= 2.1.3
+Requires:      freetype < 1:2.1.8
+Conflicts:     freetype = 2.1.8
+%endif
 Requires:      nss >= 3.8
 PreReq:                XFree86-Xvfb
 Obsoletes:     mozilla-firebird
@@ -42,20 +59,21 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _firefoxdir     %{_libdir}/%{name}
 # mozilla and firefox provide their own versions
-%define                _noautoreqdep   libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so
+%define                _noautoreqdep   libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so libnspr4.so
+%define                _noautoprovfiles libnspr4.so libplc4.so libplds4.so
 
 %description
 Mozilla Firefox is an open-source web browser, designed for standards
 compliance, performance and portability.
 
 %description -l pl
-Mozilla Firefox jest open sourcow± przegl±dark± sieci www, stworzon± z
-my¶l± o zgodno¶ci ze standartami, wydajno¶ci± i przeno¶no¶ci±.
+Mozilla Firefox jest open sourcow± przegl±dark± sieci WWW, stworzon± z
+my¶l± o zgodno¶ci ze standardami, wydajno¶ci± i przeno¶no¶ci±.
 
 %package lang-en
 Summary:       English resources for Mozilla-firefox
 Summary(pl):   Anglojêzyczne zasoby dla Mozilla-FireFox
-Group: X11/Applications/Networking
+Group:         X11/Applications/Networking
 Requires(post,postun): %{name} = %{version}-%{release}
 Requires(post,postun): textutils
 Requires:      %{name} = %{version}-%{release}
@@ -72,16 +90,18 @@ Angloj
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%{?with_ft218:%patch3 -p1}
 
 %build
 export CFLAGS="%{rpmcflags}"
 export CXXFLAGS="%{rpmcflags}"
 export MOZ_PHOENIX="1"
+export BUILD_OFFICIAL="1"
+export MOZILLA_OFFICIAL="1"
 
-cp -f /usr/share/automake/config.* build/autoconf
-cp -f /usr/share/automake/config.* nsprpub/build/autoconf
-cp -f /usr/share/automake/config.* directory/c-sdk/config/autoconf
+cp -f %{_datadir}/automake/config.* build/autoconf
+cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
+cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
 %configure2_13 \
 %if %{?debug:1}0
        --enable-debug \
@@ -114,10 +134,12 @@ cp -f /usr/share/automake/config.* directory/c-sdk/config/autoconf
        --enable-xft \
        --enable-default-toolkit="gtk2" \
        --with-pthreads \
+       --without-system-nspr \
        --with-system-jpeg \
-       --with-system-nspr \
        --with-system-png \
-       --with-system-zlib
+       --with-system-zlib \
+       --enable-single-profile \
+       --disable-profilesharing
 
 %{__make}
 
@@ -130,12 +152,12 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}}
        MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
        EXCLUDE_NSPR_LIBS=1
 
-#install -m0755 %{name}.sh $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
-ln -sf %{_firefoxdir}/firefox $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
+install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
+sed -i $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox -e "s@/usr/lib/@%{_libdir}/@g"
 
 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*-linux-gnu.tar.gz
 
-install browser/base/skin/Throbber.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
+install other-licenses/branding/firefox/content/icon32.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
 
@@ -237,7 +259,8 @@ cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installe
 %{_firefoxdir}/searchplugins
 %{_firefoxdir}/icons
 %{_firefoxdir}/defaults
-%{_firefoxdir}/ipc
+%{_firefoxdir}/greprefs
+%dir %{_firefoxdir}/init.d
 %attr(755,root,root) %{_firefoxdir}/*.so
 %attr(755,root,root) %{_firefoxdir}/*.sh
 %attr(755,root,root) %{_firefoxdir}/m*
@@ -266,10 +289,9 @@ cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installe
 %{_firefoxdir}/chrome/pip*.jar
 %{_firefoxdir}/chrome/toolkit.jar
 %{_firefoxdir}/chrome/mozilla-firefox-misc-installed-chrome.txt
+%{_firefoxdir}/chrome/icons/default
 
 %files lang-en
 %defattr(644,root,root,755)
 %{_firefoxdir}/chrome/en-US.jar
-%{_firefoxdir}/chrome/en-unix.jar
-%{_firefoxdir}/chrome/US.jar
 %{_firefoxdir}/chrome/mozilla-firefox-en-US-installed-chrome.txt
This page took 0.462446 seconds and 4 git commands to generate.