]> git.pld-linux.org Git - packages/mediastreamer.git/blobdiff - mediastreamer.spec
- added dependencies and bcond for bv16 codec
[packages/mediastreamer.git] / mediastreamer.spec
index 5c2a58b1ea0edbac101045086de3f25d3a0a264f..7827c133b6c8d35cef68cb62629673f95f8af201 100644 (file)
@@ -1,6 +1,3 @@
-# TODO:
-# - BV16 (https://gitlab.linphone.org/BC/public/external/bv16-floatingpoint or BroadVoice16OpenSource.v1.2.zip from Broadcom)
-# - bcmatroska2
 #
 # Conditional build:
 %bcond_with    pcap            # audio playing from PCAP files
 %bcond_without pulseaudio      # PulseAudio sound I/O support
 # audio codecs
 %bcond_without bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
+%bcond_without bv16            # BV16 codec support
 %bcond_without spandsp         # G726 codec support via spandsp
 # video I/O
 %bcond_without opengl          # X11+OpenGL rendering support
 %bcond_without sdl             # SDL support
 # video codecs
-%bcond_without matroska        # Matroska support via libebml2/libmatroska2
+%bcond_without matroska        # Matroska support via bcmatroska2
 %bcond_without zxing           # QRcode support via zxing-cpp
 #
 Summary:       Audio/Video real-time streaming
@@ -49,7 +47,9 @@ URL:          http://www.linphone.org/technical-corner/mediastreamer2/overview
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
 %{?with_bcg729:BuildRequires:  bcg729-devel >= 1.1.1-1}
+%{?with_matroska:BuildRequires:        bcmatroska2-devel}
 BuildRequires: bctoolbox-devel >= 0.4.0
+%{?with_bv16:BuildRequires:    bv16-floatingpoint-devel}
 %{?with_zrtp:BuildRequires:    bzrtp-devel >= 4.5.15-1}
 BuildRequires: cmake >= 3.1
 BuildRequires: doxygen
@@ -66,7 +66,6 @@ BuildRequires:        libtheora-devel >= 1.0-0.alpha7
 BuildRequires: libupnp-devel >= 1.8
 BuildRequires: libv4l-devel
 BuildRequires: libvpx-devel >= 0.9.6
-%{?with_matroska:BuildRequires:        matroska-foundation-devel}
 BuildRequires: opus-devel >= 0.9.0
 BuildRequires: ortp-devel >= 4.5.15-1
 BuildRequires: pkgconfig
@@ -114,7 +113,9 @@ Requires:   %{name} = %{version}-%{release}
 %{?with_opengl:Requires:       OpenGL-devel}
 %{?with_alsa:Requires: alsa-lib-devel}
 %{?with_bcg729:Requires:       bcg729-devel >= 1.1.1-1}
+%{?with_matroska:Requires:     bcmatroska2-devel}
 Requires:      bctoolbox-devel >= 0.4.0
+%{?with_bv16:Requires: bv16-floatingpoint-devel}
 %{?with_zrtp:Requires: bzrtp-devel >= 4.5.15-1}
 Requires:      ffmpeg-devel
 %{?with_opengl:Requires:       glew-devel >= 1.5}
@@ -122,7 +123,6 @@ Requires:   libtheora-devel >= 1.0-0.alpha7
 Requires:      libupnp-devel >= 1.8
 Requires:      libv4l-devel
 Requires:      libvpx-devel >= 0.9.6
-%{?with_matroska:Requires:     matroska-foundation-devel}
 Requires:      opus-devel >= 0.9.0
 Requires:      ortp-devel >= 4.5.15-1
 %{?with_portaudio:Requires:    portaudio-devel}
@@ -179,6 +179,7 @@ CPPFLAGS="%{rpmcppflags} -DENABLE_NLS=1 -DGETTEXT_PACKAGE=\"mediastreamer\" -DLO
        -DCMAKE_INSTALL_LIBDIR=%{_lib} \
        %{!?with_alsa:-DENABLE_ALSA=OFF} \
        %{?with_arts:-DENABLE_ARTSC=ON} \
+       %{!?with_bv16:-DENABLE_BV16=OFF} \
        %{?with_spandsp:-DENABLE_G726=ON} \
        %{!?with_bcg729:-DENABLE_G729=OFF} \
        %{?with_bcg729:-DENABLE_G729B_CNG=ON} \
This page took 0.038537 seconds and 4 git commands to generate.