]> git.pld-linux.org Git - packages/lvm2.git/blobdiff - lvm2.spec
- fix conditional
[packages/lvm2.git] / lvm2.spec
index f759448091554ea02afb5bbdaaec28bf8d42145b..9eb78160ce8b5e00cccd80b76564e408c1db82fc 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
@@ -17,7 +17,7 @@
 
 # lvmlockd requires lvmpolld
 %if %{without lvmpolld}
-%undefine      with_lvmpolld
+%undefine      with_lvmlockd
 %endif
 
 %if %{without cluster} && %{without sanlock}
 Summary:       The new version of Logical Volume Manager for Linux
 Summary(pl.UTF-8):     Nowa wersja Logical Volume Managera dla Linuksa
 Name:          lvm2
-Version:       2.03.11
-Release:       2
+Version:       2.03.23
+Release:       1
 License:       GPL v2 and LGPL v2.1
 Group:         Applications/System
 Source0:       ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
-# Source0-md5: 81b7a8b59d3f7ecf9dc00f978f41d725
+# Source0-md5: 0535b5e638b6f0b48f7b259e0ec0ba65
 Patch0:                device-mapper-dmsetup-export.patch
 Patch1:                %{name}-pld_init.patch
 Patch2:                device-mapper-dmsetup-deps-export.patch
 Patch3:                %{name}-thin.patch
-Patch4:                paths.patch
 URL:           http://www.sourceware.org/lvm2/
 BuildRequires: autoconf >= 2.69
+BuildRequires: autoconf-archive
 BuildRequires: automake
 # for /run detection
 BuildRequires: filesystem >= 3.0-43
@@ -66,7 +66,7 @@ BuildRequires:        glibc-static
 BuildRequires: libaio-static
 %{?with_selinux:BuildRequires: pcre-static}
 %else
-Obsoletes:     lvm2-initrd
+Obsoletes:     lvm2-initrd < %{version}-%{release}
 %endif
 %if %{with cluster}
 # for cmirrord
@@ -82,9 +82,9 @@ Requires:     systemd-units >= 38
 # doesn't work with 2.4 kernels
 Requires:      uname(release) >= 2.6
 Suggests:      thin-provisioning-tools >= 0.7.0
-Obsoletes:     lvm
+Obsoletes:     lvm < 2
 Obsoletes:     lvm2-clvmd < 2.03
-Obsoletes:     lvm2-systemd
+Obsoletes:     lvm2-systemd < 2.02.94
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
@@ -137,7 +137,7 @@ This daemon relies on the cluster infrastructure provided by the
 Cluster MANager (CMAN), which must be set up and running in order for
 cmirrord to function.
 
-%description cmirrord
+%description cmirrord -l pl.UTF-8
 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
@@ -269,7 +269,7 @@ Statyczna biblioteka devmapper.
 Summary:       Userspace support for the device-mapper - initrd version
 Summary(pl.UTF-8):     Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
 Group:         Base
-Obsoletes:     device-mapper-initrd-devel
+Obsoletes:     device-mapper-initrd-devel < 2
 Conflicts:     geninitrd < 10000.10
 
 %description -n device-mapper-initrd
@@ -299,7 +299,6 @@ potrzeby initrd.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %build
 %{__aclocal}
@@ -355,6 +354,9 @@ unset CC
 %configure \
        --enable-cache_check_needs_check \
        --enable-cmdlib \
+%if %{with cluster}
+       --enable-cmirrord \
+%endif
        %{?with_lvmdbusd:--enable-dbus-service --enable-notify-dbus} \
        %{?debug:--enable-debug} \
        --enable-dmeventd \
@@ -378,12 +380,10 @@ unset CC
        --with-cache-dump=/usr/sbin/cache_dump \
        --with-cache-repair=/usr/sbin/cache_repair \
        --with-cache-restore=/usr/sbin/cache_restore \
-%if %{with cluster}
-       --enable-cmirrord \
-%endif
        --with-default-locking-dir=/var/lock/lvm \
        --with-dmeventd-path=%{_sbindir}/dmeventd \
        --with-interface=ioctl \
+       --with-libexecdir=%{_libexecdir} \
        --with-mirrors=internal \
        --with-optimisation="%{rpmcflags}" \
        --with-snapshots=internal \
@@ -395,9 +395,9 @@ unset CC
        --with-thin-repair=/usr/sbin/thin_repair \
        --with-thin-restore=/usr/sbin/thin_restore \
        --with-udev-prefix=/ \
+       --with-usrlibdir=%{_libdir} \
        --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
-       --with-writecache=internal \
-       --with-usrlibdir=%{_libdir}
+       --with-writecache=internal
 
 # no --enable-nls: no translations exist, broken
 
@@ -416,6 +416,7 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/
 
 %{__make} install install_system_dirs install_systemd_units install_systemd_generators install_initscripts install_tmpfiles_configuration \
        DESTDIR=$RPM_BUILD_ROOT \
+       PYTHON_PREFIX=%{_prefix} \
        OWNER="" \
        GROUP=""
 
@@ -513,7 +514,9 @@ fi
 %attr(755,root,root) %{_sbindir}/lvdisplay
 %attr(755,root,root) %{_sbindir}/lvextend
 %attr(755,root,root) %{_sbindir}/lvm
+%attr(755,root,root) %{_sbindir}/lvm_import_vdo
 %attr(755,root,root) %{_sbindir}/lvmconfig
+%attr(755,root,root) %{_sbindir}/lvmdevices
 %attr(755,root,root) %{_sbindir}/lvmdiskscan
 %attr(755,root,root) %{_sbindir}/lvmdump
 %attr(755,root,root) %{_sbindir}/lvmsadc
@@ -544,6 +547,7 @@ fi
 %attr(755,root,root) %{_sbindir}/vgextend
 %attr(755,root,root) %{_sbindir}/vgimport
 %attr(755,root,root) %{_sbindir}/vgimportclone
+%attr(755,root,root) %{_sbindir}/vgimportdevices
 %attr(755,root,root) %{_sbindir}/vgmerge
 %attr(755,root,root) %{_sbindir}/vgmknodes
 %attr(755,root,root) %{_sbindir}/vgreduce
@@ -552,12 +556,15 @@ fi
 %attr(755,root,root) %{_sbindir}/vgs
 %attr(755,root,root) %{_sbindir}/vgscan
 %attr(755,root,root) %{_sbindir}/vgsplit
+%attr(755,root,root) %{_libexecdir}/lvresize_fs_helper
 %{_mandir}/man5/lvm.conf.5*
+%{_mandir}/man7/lvmautoactivation.7*
 %{_mandir}/man7/lvmcache.7*
 %{_mandir}/man7/lvmraid.7*
 %{_mandir}/man7/lvmreport.7*
 %{_mandir}/man7/lvmsystemid.7*
 %{_mandir}/man7/lvmthin.7*
+%{_mandir}/man7/lvmvdo.7*
 %{_mandir}/man8/blkdeactivate.8*
 %{_mandir}/man8/fsadm.8*
 %{_mandir}/man8/lvchange.8*
@@ -565,13 +572,14 @@ fi
 %{_mandir}/man8/lvcreate.8*
 %{_mandir}/man8/lvdisplay.8*
 %{_mandir}/man8/lvextend.8*
-%{_mandir}/man8/lvm2-activation-generator.8*
 %{_mandir}/man8/lvm-config.8*
 %{_mandir}/man8/lvm-dumpconfig.8*
 %{_mandir}/man8/lvm-fullreport.8*
 %{_mandir}/man8/lvm-lvpoll.8*
 %{_mandir}/man8/lvm.8*
+%{_mandir}/man8/lvm_import_vdo.8*
 %{_mandir}/man8/lvmconfig.8*
+%{_mandir}/man8/lvmdevices.8*
 %{_mandir}/man8/lvmdiskscan.8*
 %{_mandir}/man8/lvmdump.8*
 %{_mandir}/man8/lvmsadc.8*
@@ -602,6 +610,7 @@ fi
 %{_mandir}/man8/vgextend.8*
 %{_mandir}/man8/vgimport.8*
 %{_mandir}/man8/vgimportclone.8*
+%{_mandir}/man8/vgimportdevices.8*
 %{_mandir}/man8/vgmerge.8*
 %{_mandir}/man8/vgmknodes.8*
 %{_mandir}/man8/vgreduce.8*
@@ -624,8 +633,6 @@ fi
 %{systemdtmpfilesdir}/lvm2.conf
 %{systemdunitdir}/blk-availability.service
 %{systemdunitdir}/lvm2-monitor.service
-%{systemdunitdir}/lvm2-pvscan@.service
-%attr(755,root,root) /lib/systemd/system-generators/lvm2-activation-generator
 %dir %{_sysconfdir}/lvm/cache
 %ghost %{_sysconfdir}/lvm/cache/.cache
 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
@@ -683,8 +690,8 @@ fi
 /lib/udev/rules.d/10-dm.rules
 /lib/udev/rules.d/11-dm-lvm.rules
 /lib/udev/rules.d/13-dm-disk.rules
+/lib/udev/rules.d/69-dm-lvm.rules
 /lib/udev/rules.d/95-dm-notify.rules
-/lib/udev/rules.d/69-dm-lvm-metad.rules
 %attr(755,root,root) %{_sbindir}/dmeventd
 %attr(755,root,root) %{_sbindir}/dmfilemapd
 %attr(755,root,root) %{_sbindir}/dmsetup
@@ -700,7 +707,6 @@ fi
 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
-%{_mandir}/man7/lvmvdo.7*
 %{_mandir}/man8/dmfilemapd.8*
 %{_mandir}/man8/dmsetup.8*
 %{_mandir}/man8/dmstats.8*
This page took 0.05143 seconds and 4 git commands to generate.