]> git.pld-linux.org Git - packages/lm_sensors.git/blobdiff - lm_sensors.spec
- modules are loaded now by separate script
[packages/lm_sensors.git] / lm_sensors.spec
index b8f88a8a8cea79b5d6ce80b40b9f559372d9923c..0a84d7cc6dee26926f2143e2c92c0a0cfb154ad9 100644 (file)
@@ -1,7 +1,13 @@
 # TODO
 # - unpackaged:
-#   /usr/sbin/fancontrol.pl
+#   /usr/sbin/fancontrol.pl (isn't that the same as sh fancontrol script?)
+# - a big trigger warning how to use fancontrol and to init it first
 #
+%define                cmodule         %{_sysconfdir}/sysconfig/sensors_modules
+%define                cdaemon         %{_sysconfdir}/sysconfig/sensors
+%define                smodule         %{_sysconfdir}/rc.d/init.d/sensors_modules
+%define                sdaemon         %{_sysconfdir}/rc.d/init.d/sensors
+
 %include       /usr/lib/rpm/macros.perl
 Summary:       Hardware health monitoring
 Summary(pl):   Monitor stanu sprzêtu
@@ -9,30 +15,35 @@ Summary(pt_BR):      Ferramentas para monitora
 Summary(ru):   õÔÉÌÉÔÙ ÄÌÑ ÍÏÎÉÔÏÒÉÎÇÁ ÁÐÐÁÒÁÔÕÒÙ
 Summary(uk):   õÔÉ̦ÔÉ ÄÌÑ ÍÏΦÔÏÒÉÎÇÕ ÁÐÁÒÁÔÕÒÉ
 Name:          lm_sensors
-Version:       2.10.0
+Version:       2.10.1
 Release:       2
 License:       GPL
 Group:         Applications/System
-Source0:       http://secure.netroedge.com/~lm78/archive/%{name}-%{version}.tar.gz
-# Source0-md5: 6a5327c9e291c5e2bef62e2277bce962
+Source0:       http://dl.lm-sensors.org/lm-sensors/releases/%{name}-%{version}.tar.gz
+# Source0-md5: cdc857b78e813b88cbf8be92441aa299
 Source1:       sensors.init
 Source2:       sensors.sysconfig
+Source3:       fancontrol.init
+Source4:       fancontrol.sysconfig
+Source5:       sensors.sh
+Source6:       sensors_modules.init
+Source7:       sensors_modules.sysconfig
 Patch0:                %{name}-make.patch
 Patch1:                %{name}-ppc.patch
 Patch2:                %{name}-iconv-in-libc.patch
 Patch3:                %{name}-sensors-detect-PATH.patch
-Patch4:                %{name}-CAN-2005-2672.patch
 URL:           http://www.lm-sensors.nu/
-BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: bison
 BuildRequires: flex >= 2.5.1
 BuildRequires: perl-modules >= 5.6
 BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: rrdtool-devel >= 1.2.10
 BuildRequires: sysfsutils-devel
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      dev >= 2.9.0-13
 Requires:      dmidecode
-Obsoletes:     liblm_sensors1
+Requires:      %{name}-config
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -62,6 +73,8 @@ SMBus 
 Summary:       lm_sensors library
 Summary(pl):   Biblioteka lm_sensors
 Group:         Libraries
+Obsoletes:     liblm_sensors1
+Conflicts:     lm_sensors <= 2.9.2-2
 
 %description libs
 lm_sensors library.
@@ -123,12 +136,23 @@ Bibliotecas est
 ðÁËÅÔ lm_sensors-static Í¦ÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ
 ÐÏÂÕÄÏ×É ÐÒÏÇÒÁÍ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ ÄÁΦ ÓÅÎÓÏÒ¦×.
 
+%package config-default
+Summary:       Sensors configuration files
+Summary(pl):   Pliki konfiguracyjne lm_sensors
+Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-config
+
+%description config-default
+Default configuration files for lm_sensors.
+
 %package sensord
 Summary:       Sensord daemon
 Summary(pl):   Demon sensord
 Group:         Daemons
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-config
 Requires:      rc-scripts
 
 %description sensord
@@ -137,13 +161,37 @@ Sensord daemon.
 %description sensord -l pl
 Demon sensord.
 
+%package fancontrol
+Summary:       Fancontrol daemon
+Summary(pl):   Demon sterowania wiatraczkami
+Group:         Daemons
+Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-sensord = %{version}-%{release}
+Requires:      rc-scripts
+
+%description fancontrol
+Fancontrol daemon monitors current temperature of the computer and
+adjusts fans speed acordingly.
+
+It is crucial to correctly configure this daemon (via running service
+fancontrol init) and ensuring, that the temperature levels are set not
+to burn the insides of the computer!
+
+%description fancontrol -l pl
+Demon fancontrol monitoruje obecn± temperaturê komputera i ustawia
+odpowiednio prêdko¶æ wiatraków.
+
+Kluczowym jest, aby poprawnie skonfigurowaæ tego demona (poprzez
+uruchomienie service fancontrol init) oraz upewniæ siê, ¿e progi
+temperatury s± ustawione poprawnie, by nie spaliæ wnêtrza komputera!
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %build
 %{__make} user \
@@ -164,7 +212,7 @@ Demon sensord.
 rm -rf $RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
-       $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
+       $RPM_BUILD_ROOT%{_sysconfdir}/{rc.d/init.d,sysconfig}
 
 %{__make} user_install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -179,8 +227,13 @@ install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
 
 install prog/eepromer/{eeprom,eepromer}        $RPM_BUILD_ROOT%{_sbindir}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/sensors
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/sensors
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/sensors
+install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/sensors
+install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/fancontrol
+install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/fancontrol
+install %{SOURCE5} $RPM_BUILD_ROOT%{_bindir}
+install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/sensors_modules
+install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/sensors_modules
 
 # i2c API for userspace - included in glibc-kernel-headers
 rm -f $RPM_BUILD_ROOT%{_includedir}/linux/i2c-dev.h
@@ -191,12 +244,65 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%post sensord
+%post
+if [ -f "%{cmodule}" ]; then
+       /sbin/chkconfig --add sensors_modules
+       %service sensors_modules restart "sensors modules"
+       if [ -f "%{sdaemon}" ]; then
+               /sbin/chkconfig --add sensors
+               %service sensors restart "sensors deamon"
+       fi
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       if [ -f "%{sdaemon}" ]; then
+               %service sensors stop
+               /sbin/chkconfig --del sensors
+       fi
+       %service sensors_modules stop
+       /sbin/chkconfig --del sensors_modules
+fi
+
+%post config-default
 if [ "$1" = 1 ]; then
-       echo "You have to configure sensors modules in /etc/sysconfig/sensors"
+cat << EOF
+ *********************************************************************
+ *                                                                   *
+ *  NOTE:                                                            *
+ *  You have to configure sensors to match your motherboard sensors  *
+ *  in  /etc/sensors.conf  and  /etc/sysconfig/sensors_modules. Use  *
+ *  sensors-detect script which  can  help you find proper modules.  *
+ *                                                                   *
+ *********************************************************************
+EOF
+fi
+if [ -f "%{smodule}" ]; then
+       /sbin/chkconfig --add sensors_modules
+       %service sensors_modules restart "sensors modules"
+fi
+if [ -f "%{sdaemon}" ]; then
+       /sbin/chkconfig --add sensors
+       %service sensors restart "sensors daemon"
+fi
+
+%preun config-default
+if [ "$1" = "0" ]; then
+       if [ -f "%{sdaemon}" ]; then
+               %service sensors stop
+               /sbin/chkconfig --del sensors
+       fi
+       if [ -f "%{smodule}" ]; then
+               %service sensors_modules stop
+               /sbin/chkconfig --del sensors_modules
+       fi
+fi
+
+%post sensord
+if [ -f "%{cmodule}" ]; then
+       /sbin/chkconfig --add sensors
+       %service sensors restart "sensors daemon"
 fi
-/sbin/chkconfig --add sensors
-%service sensors restart "sensors daemon"
 
 %preun sensord
 if [ "$1" = "0" ]; then
@@ -204,6 +310,19 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del sensors
 fi
 
+%post fancontrol
+if [ "$1" = 1 ]; then
+       echo "You have to configure fancontrol by running service fancontrol init first."
+fi
+/sbin/chkconfig --add fancontrol
+%service fancontrol restart "fancontrol daemon"
+
+%preun fancontrol
+if [ "$1" = "0" ]; then
+       %service fancontrol stop
+       /sbin/chkconfig --del fancontrol
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc BACKGROUND BUGS CHANGES README README.thinkpad TODO doc/{busses,chips}
@@ -212,24 +331,25 @@ fi
 %attr(755,root,root) %{_bindir}/ddcmon
 %attr(755,root,root) %{_bindir}/decode-*.pl
 %attr(755,root,root) %{_bindir}/sensors
-%attr(755,root,root) %{_sbindir}/sensors-detect
+%attr(755,root,root) %{_bindir}/sensors.sh
 %attr(755,root,root) %{_sbindir}/eeprom*
-%attr(755,root,root) %{_sbindir}/fancontrol
 %attr(755,root,root) %{_sbindir}/i2c*
+%attr(755,root,root) %{_sbindir}/sensors-detect
 %ifarch %{ix86} %{x8664}
 %attr(755,root,root) %{_sbindir}/isadump
 %attr(755,root,root) %{_sbindir}/isaset
+%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/sensors_modules
 %{_mandir}/man8/isadump.8*
 %{_mandir}/man8/isaset.8*
 %endif
-%attr(755,root,root) %{_sbindir}/pwmconfig
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sensors.conf
 %{_mandir}/man1/sensors.1*
 %{_mandir}/man5/sensors.conf.5*
-%{_mandir}/man8/fancontrol.8*
 %{_mandir}/man8/i2c*.8*
-%{_mandir}/man8/pwmconfig.8*
-%{_mandir}/man8/sensors-detect.8*
+
+%files config-default
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sensors.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sysconfig/sensors_modules
 
 %files libs
 %defattr(644,root,root,755)
@@ -250,6 +370,16 @@ fi
 %files sensord
 %defattr(644,root,root,755)
 %attr(754,root,root) %{_sbindir}/sensord
-%attr(754,root,root) /etc/rc.d/init.d/sensors
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sensors
+%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/sensors
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sysconfig/sensors
+%{_mandir}/man8/sensors-detect.8*
 %{_mandir}/man8/sensord.8*
+
+%files fancontrol
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/fancontrol
+%attr(755,root,root) %{_sbindir}/pwmconfig
+%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/fancontrol
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sysconfig/fancontrol
+%{_mandir}/man8/fancontrol.8*
+%{_mandir}/man8/pwmconfig.8*
This page took 0.076474 seconds and 4 git commands to generate.