]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
up to 17.0.2
[packages/llvm.git] / llvm.spec
index e8a1ecdf169671963da260c6a7b2afd176edbbe0..752fe26ad8dc2e4bbf68e82f8372654a4e521618 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
 # - system isl in polly?
 # - dependencies and files for lua module
+#      %{_libdir}/lua/5.3/lldb.so
 # - figure out whether we need obj.MLIRCAPIIR files
+# - cmake dependencies mess (LLVMExports.cmake appears to require all -devels):
+#   with llvm-devel and spirv-tools-devel installed but without llvm-mlir (or other packages):
+#   $ cat CMakeLists.txt
+#   find_package(LLVM)
+#   find_package(SPIRV-Tools)
+#   $ cmake -B build
+#   ...
+#   The imported target "mlir-tblgen" references the file
+#
+#      "/usr/bin/mlir-tblgen"
+#
+#   but this file does not exist.  Possible reasons include:
+#   ...
 #
 # Conditional build:
 %bcond_without lldb                    # LLDB debugger
@@ -30,6 +44,7 @@
 %bcond_without target_bpf              # BPF target support
 %bcond_without target_hexagon          # Hexagon target support
 %bcond_without target_lanai            # Lanai target support
+%bcond_without target_loongarch        # LoongArch target support
 %bcond_without target_mips             # Mips target support
 %bcond_without target_msp430           # MSP430 target support
 %bcond_without target_nvptx            # NVPTX target support
 %undefine      with_ocaml
 %endif
 
-%ifarch armv3l armv4b armv4l armv4tl armv5tl armv5tel armv5tejl armv6l armv6hl
+%ifarch armv3l %{armv4} %{armv5} %{armv6}
 %undefine      with_rt
 %endif
 
-%ifarch %{arm} aarch64
-%define                with_lowmem             1
+%ifarch i386 i486 armv3l %{armv4} %{armv5} %{armv6}
+%define                with_libatomic  1
 %endif
 
-%define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_ve:VE;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
+%define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_loongarch:LoongArch;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_ve:VE;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
 
 %if %{without mlir}
 %undefine      with_flang
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       14.0.4
+Version:       17.0.2
 Release:       1
 License:       Apache 2.0 with LLVM exceptions
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 8aad3395466b23d3d34e98dbe386b018
+# Source0-md5: ad114e00a5350c96de9d7ca4866d8d01
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 335980de1f61d2641acc83bdf0ab0faf
+# Source1-md5: da00c6de5a1946fcc0b6419ee5600a65
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 1068037dce5e42a0eeb2217484f501fd
+# Source2-md5: b0ce0f1c7e687f96e9d775c4aa3978c1
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 8741b5d30a5390a7daef639cf4042f0c
+# Source3-md5: a51abb56e09a172fe9c5a795e0890cf3
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 5d37eabbfb147314187fc8abe7880796
+# Source4-md5: 24843481f9e054de13f5335a07883eaf
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 2c71885c8bad1724cea3d021224a69a1
+# Source5-md5: 6862a7a0af802291c929d2f104ecf909
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: cd93e87550e48b1a8ae3ee638861f47c
+# Source6-md5: 7389729b6ea88a71bc69d20aec8a4ea8
 Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
-# Source7-md5: ce6eebfe98c5372c969cd1da6145bfb6
-# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-13.0.1/llvm-project-13.0.1.src.tar.xz
-Source8:       mlir-%{version}.tar.xz
-# Source8-md5: 34fbb0505b40478016d9e518b0fcf24c
+# Source7-md5: 9eb16034e79717d54be3a69d9673f5d5
+Source8:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/mlir-%{version}.src.tar.xz
+# Source8-md5: bf6d5e89bc58b880b01b38878af7e20f
+Source9:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
+# Source9-md5: fa05d0b40615544f0e421a28f173d634
 Patch1:                %{name}-pld.patch
-Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
-Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 Patch6:                %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
 Patch8:                %{name}-selective_bindings.patch
 Patch9:                %{name}-libexecdir.patch
 Patch10:       compiler-rt-paths.patch
+Patch11:       cmake-utils-path-override.patch
+Patch12:       x32-compiler-rt.patch
 URL:           https://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
 BuildRequires: bison
-BuildRequires: cmake >= 3.13.4
+BuildRequires: cmake >= 3.20.0
 BuildRequires: flex
 BuildRequires: groff
+%{?with_libatomic:BuildRequires:       libatomic-devel}
 BuildRequires: libedit-devel
 BuildRequires: libltdl-devel
 BuildRequires: libpfm-devel
@@ -126,16 +143,18 @@ BuildRequires:    perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
 BuildRequires: python3 >= 1:3
 BuildRequires: python3-PyYAML
+BuildRequires: python3-modules
 BuildRequires: python3-pygments >= 2.0
 BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.742
+BuildRequires: rpmbuild(macros) >= 2.007
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xar-devel >= 1.6
 BuildRequires: xz
 %{?with_z3:BuildRequires:      z3-devel >= 4.7.1}
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 %if %{with apidocs}
 BuildRequires: doxygen
 BuildRequires: graphviz
@@ -153,17 +172,14 @@ BuildRequires:    libstdc++-multilib-32-devel
 %ifarch x32
 BuildRequires: gcc-c++-multilib-32
 BuildRequires: gcc-c++-multilib-64
-BuildRequires: glibc-devel(x86_64)
 BuildRequires: glibc-devel(ix86)
+BuildRequires: glibc-devel(x86_64)
 BuildRequires: libstdc++-multilib-32-devel
 BuildRequires: libstdc++-multilib-64-devel
 %endif
 %endif
 %if %{with lldb}
 BuildRequires: epydoc
-%ifarch i386 i486 %{arm}
-BuildRequires: libatomic-devel
-%endif
 BuildRequires: libxml2-devel >= 2
 BuildRequires: lua-devel
 BuildRequires: ncurses-ext-devel
@@ -188,7 +204,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     14
+%define                abi     17
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -247,8 +263,13 @@ Biblioteki współdzielone LLVM-a.
 Summary:       Static libraries and header files for LLVM
 Summary(pl.UTF-8):     Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
 Group:         Development/Languages
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs%{?_isa} = %{version}-%{release}
+%{?with_libatomic:Requires:    libatomic-devel}
 Requires:      libstdc++-devel >= 6:3.4
+Requires:      ncurses-devel
+%{?with_z3:Requires:   z3-devel}
+Requires:      zlib-devel
+Requires:      zstd-devel
 
 %description devel
 This package contains static libraries and header files needed to
@@ -276,6 +297,7 @@ Summary:    API documentation for LLVM
 Summary(pl.UTF-8):     Dokumentacja API LLVM-a
 Group:         Development/Languages
 Requires:      %{name}-doc = %{version}-%{release}
+BuildArch:     noarch
 
 %description apidocs
 API documentation for the LLVM compiler infrastructure.
@@ -434,6 +456,7 @@ Summary(pl.UTF-8):  Dokumentacja do Clanga
 URL:           https://clang.llvm.org/
 Group:         Documentation
 Requires:      %{name} = %{version}-%{release}
+BuildArch:     noarch
 
 %description -n clang-doc
 Documentation for the Clang compiler front-end.
@@ -447,6 +470,7 @@ Summary(pl.UTF-8):  Dokumentacja API Clanga
 URL:           https://clang.llvm.org/
 Group:         Development/Languages
 Requires:      clang-doc = %{version}-%{release}
+BuildArch:     noarch
 
 %description -n clang-apidocs
 API documentation for the Clang compiler.
@@ -493,8 +517,9 @@ Dodatkowe narzędzia do kompilatora Clang.
 Summary:       Bash completion for clang command
 Summary(pl.UTF-8):     Bashowe dopełnianie składni polecenia clang
 Group:         Applications/Shells
-Requires:      bash-completion >= 2.0
+Requires:      bash-completion >= 1:2.0
 Requires:      clang = %{version}-%{release}
+BuildArch:     noarch
 
 %description -n bash-completion-clang
 Bash completion for clang command.
@@ -629,6 +654,7 @@ Summary:    Documentation for LLVM's OCaml binding
 Summary(pl.UTF-8):     Dokumentacja wiązania OCamla do LLVM-a
 Group:         Documentation
 Requires:      %{name}-ocaml = %{version}-%{release}
+BuildArch:     noarch
 
 %description ocaml-doc
 HTML documentation for LLVM's OCaml binding.
@@ -663,7 +689,7 @@ Clang format and rename integration for Vim.
 Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7} %{?with_mlir:-a8}
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7} %{?with_mlir:-a8} -a9
 %{__mv} clang-%{version}.src tools/clang
 %{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
@@ -674,13 +700,12 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %{__mv} flang-%{version}.src tools/flang
 %endif
 %if %{with mlir}
-%{__mv} mlir tools/mlir
+%{__mv} mlir-%{version}.src tools/mlir
 %endif
+%{__mv} cmake-%{version}.src cmake-utils
 
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 %if %{with flang}
 %patch6 -p1
@@ -690,7 +715,9 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %patch9 -p1
 %if %{with rt}
 %patch10 -p1
+%patch12 -p1
 %endif
+%patch11 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python3\?,#!%{__python3},
@@ -702,7 +729,7 @@ find -name '*.py' -print0 | xargs -0 sed -i -e '1{
 }'
 
 %if %{with flang}
-%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang.in
+%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang-to-external-fc.in
 %endif
 
 %build
@@ -714,18 +741,22 @@ cd build
 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 
 %if %{with lowmem}
-export CFLAGS="%{rpmcflags} -g0"
-export CXXFLAGS="%{rpmcxxflags} -g0"
+export CFLAGS="%{rpmcflags} -NDEBUG -g0"
+export CXXFLAGS="%{rpmcxxflags} -NDEBUG -g0"
+if echo 'int main(){}' | %{__cc} -x c %{rpmldflags} -Wl,--reduce-memory-overheads -o /dev/null - > /dev/null 2>&1; then
 export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
+fi
 %endif
 
 %cmake .. \
        -DBUILD_SHARED_LIBS:BOOL=OFF \
        -DENABLE_LINKER_BUILD_ID:BOOL=ON \
+       -DLLVM_COMMON_CMAKE_UTILS="%{_builddir}/%{buildsubdir}/cmake-utils" \
        -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
        -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
        -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
+       -DLLVM_INSTALL_PACKAGE_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_libdir}/cmake/llvm") \
        -DLLVM_TOOLS_INSTALL_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_bindir}") \
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
@@ -745,16 +776,19 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
        -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
 %endif
        -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
+       -DLLVM_TARGET_ARCH:STRING=%{_target_base_arch} \
        -DLLVM_DEFAULT_TARGET_TRIPLE:STRING=%{_target_platform} \
 %if %{with lowmem}
        -DLLVM_PARALLEL_LINK_JOBS:STRING=1 \
 %endif
        -DLLVM_TARGETS_TO_BUILD="%{targets_to_build}" \
+       -DLLVM_INCLUDE_TESTS:BOOL=OFF \
 %if %{with polly}
        %{cmake_on_off target_nvptx POLLY_ENABLE_GPGPU_CODEGEN} \
 %endif
        -DSPHINX_WARNINGS_AS_ERRORS=OFF \
 %if %{with rt}
+       -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF \
 %ifarch x32
        -DCOMPILER_RT_BUILD_MEMPROF:BOOL=OFF
 %endif
@@ -772,12 +806,10 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
 %if %{with doc}
 %{__make} -C docs docs-llvm-html
 %{__make} -C docs docs-llvm-man
-%if %{with ocaml}
-%{__make} -C docs ocaml_doc
-%endif
 %{__make} -C tools/clang/docs docs-clang-html
 %{__make} -C tools/clang/docs docs-clang-man
 %{__make} -C tools/lld/docs docs-lld-html
+%if %{with lldb}
 # workaround failed import of _lldb
 cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
 %{__make} \
@@ -785,6 +817,10 @@ cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
        -C tools/lldb/docs lldb-python-doc-package
 %{__make} -C tools/lldb/docs lldb-cpp-doc
 %endif
+%endif
+%if %{with ocaml}
+%{__make} -C docs ocaml_doc
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -839,10 +875,11 @@ install -d $RPM_BUILD_ROOT%{bash_compdir}
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/c-index-test
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
-# use system six
-%{?with_lldb:%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/{,__pycache__/}six*.py*}
 # it seems it is used internally by an extra clang tool
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
+%if %{with mlir}
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/objects-PLD
+%endif
 
 # disable completeness check incompatible with split packaging
 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' \
@@ -891,11 +928,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-cxxdump
 %attr(755,root,root) %{_bindir}/llvm-cxxfilt
 %attr(755,root,root) %{_bindir}/llvm-cxxmap
+%attr(755,root,root) %{_bindir}/llvm-debuginfo-analyzer
+%attr(755,root,root) %{_bindir}/llvm-debuginfod
 %attr(755,root,root) %{_bindir}/llvm-debuginfod-find
 %attr(755,root,root) %{_bindir}/llvm-diff
 %attr(755,root,root) %{_bindir}/llvm-dis
 %attr(755,root,root) %{_bindir}/llvm-dlltool
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
+%attr(755,root,root) %{_bindir}/llvm-dwarfutil
 %attr(755,root,root) %{_bindir}/llvm-dwp
 %attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
@@ -927,6 +967,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-readelf
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-reduce
+%attr(755,root,root) %{_bindir}/llvm-remark-size-diff
+%attr(755,root,root) %{_bindir}/llvm-remarkutil
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
 %attr(755,root,root) %{_bindir}/llvm-sim
 %attr(755,root,root) %{_bindir}/llvm-size
@@ -944,7 +986,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/opt
 %attr(755,root,root) %{_bindir}/sancov
 %attr(755,root,root) %{_bindir}/sanstats
-%attr(755,root,root) %{_bindir}/split-file
+%attr(755,root,root) %{_bindir}/tblgen-lsp-server
 %attr(755,root,root) %{_bindir}/verify-uselistorder
 %if %{with doc}
 %{_mandir}/man1/bugpoint.1*
@@ -959,11 +1001,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-cov.1*
 %{_mandir}/man1/llvm-cxxfilt.1*
 %{_mandir}/man1/llvm-cxxmap.1*
+%{_mandir}/man1/llvm-debuginfo-analyzer.1*
 %{_mandir}/man1/llvm-diff.1*
 %{_mandir}/man1/llvm-dis.1*
 %{_mandir}/man1/llvm-dwarfdump.1*
+%{_mandir}/man1/llvm-dwarfutil.1*
 %{_mandir}/man1/llvm-exegesis.1*
 %{_mandir}/man1/llvm-extract.1*
+%{_mandir}/man1/llvm-ifs.1*
 %{_mandir}/man1/llvm-install-name-tool.1*
 %{_mandir}/man1/llvm-lib.1*
 %{_mandir}/man1/llvm-libtool-darwin.1*
@@ -974,6 +1019,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-nm.1*
 %{_mandir}/man1/llvm-objcopy.1*
 %{_mandir}/man1/llvm-objdump.1*
+%{_mandir}/man1/llvm-opt-report.1*
 %{_mandir}/man1/llvm-otool.1*
 %{_mandir}/man1/llvm-pdbutil.1*
 %{_mandir}/man1/llvm-profdata.1*
@@ -981,6 +1027,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-ranlib.1*
 %{_mandir}/man1/llvm-readelf.1*
 %{_mandir}/man1/llvm-readobj.1*
+%{_mandir}/man1/llvm-remark-size-diff.1*
+%{_mandir}/man1/llvm-remarkutil.1*
 %{_mandir}/man1/llvm-size.1*
 %{_mandir}/man1/llvm-stress.1*
 %{_mandir}/man1/llvm-strings.1*
@@ -998,9 +1046,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLTO.so.14
-%attr(755,root,root) %{_libdir}/libRemarks.so.14
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.14
+%attr(755,root,root) %{_libdir}/libLTO.so.17
+%attr(755,root,root) %{_libdir}/libRemarks.so.17
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.17
 
 %files devel
 %defattr(644,root,root,755)
@@ -1034,13 +1082,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/mlir-lsp-server
 %attr(755,root,root) %{_bindir}/mlir-opt
 %attr(755,root,root) %{_bindir}/mlir-pdll
+%attr(755,root,root) %{_bindir}/mlir-pdll-lsp-server*
 %attr(755,root,root) %{_bindir}/mlir-reduce
 %attr(755,root,root) %{_bindir}/mlir-tblgen
 %attr(755,root,root) %{_bindir}/mlir-translate
-%attr(755,root,root) %{_libdir}/libMLIR.so.14
-%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.14
-%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.14
-%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.14
+%attr(755,root,root) %{_libdir}/libMLIR.so.17
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.17
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.17
+%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so.17
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.17
 %if %{with doc}
 %{_mandir}/man1/mlir-tblgen.1*
 %endif
@@ -1050,6 +1100,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libMLIR.so
 %attr(755,root,root) %{_libdir}/libmlir_async_runtime.so
 %attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so
+%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so
 %attr(755,root,root) %{_libdir}/libmlir_runner_utils.so
 %{_libdir}/libMLIR*.a
 %{_includedir}/mlir
@@ -1076,6 +1127,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n clang
 %defattr(644,root,root,755)
 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
+%attr(755,root,root) %{_bindir}/amdgpu-arch
 %attr(755,root,root) %{_bindir}/clang
 %attr(755,root,root) %{_bindir}/clang++
 %attr(755,root,root) %{_bindir}/clang-%{abi}
@@ -1085,74 +1137,87 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-doc
 %attr(755,root,root) %{_bindir}/clang-format
 %attr(755,root,root) %{_bindir}/clang-linker-wrapper
-%attr(755,root,root) %{_bindir}/clang-nvlink-wrapper
 %attr(755,root,root) %{_bindir}/clang-offload-bundler
-%attr(755,root,root) %{_bindir}/clang-offload-wrapper
+%attr(755,root,root) %{_bindir}/clang-offload-packager
+%attr(755,root,root) %{_bindir}/clang-pseudo
 %attr(755,root,root) %{_bindir}/clang-repl
+%attr(755,root,root) %{_bindir}/clang-tblgen
 %attr(755,root,root) %{_bindir}/git-clang-format
+%attr(755,root,root) %{_bindir}/nvptx-arch
 %dir %{_libdir}/clang
-%dir %{_libdir}/clang/%{version}
-%{_libdir}/clang/%{version}/include
+%dir %{_libdir}/clang/%{abi}
+%{_libdir}/clang/%{abi}/include
 %if %{with rt}
 %ifarch %{x8664} x32 aarch64
-%dir %{_libdir}/clang/%{version}/bin
-%attr(755,root,root) %{_libdir}/clang/%{version}/bin/hwasan_symbolize
+%dir %{_libdir}/clang/%{abi}/bin
+%attr(755,root,root) %{_libdir}/clang/%{abi}/bin/hwasan_symbolize
 %endif
-%ifarch %{ix86} %{x8664} aarch64 armv7hl armv7hnl
-%dir %{_libdir}/clang/%{version}/lib
-%dir %{_libdir}/clang/%{version}/lib/linux
-%dir %{_libdir}/clang/%{version}/share
+%ifarch %{ix86} %{x8664} aarch64 %{armv7}
+%dir %{_libdir}/clang/%{abi}/lib
+%dir %{_libdir}/clang/%{abi}/lib/*-linux*
+%dir %{_libdir}/clang/%{abi}/share
 %endif
 %ifarch x32
 %if %{with multilib}
-%dir %{_libdir}/clang/%{version}/lib
-%dir %{_libdir}/clang/%{version}/lib/linux
-%dir %{_libdir}/clang/%{version}/share
+%dir %{_libdir}/clang/%{abi}/lib
+%dir %{_libdir}/clang/%{abi}/lib/*-linux*
+%dir %{_libdir}/clang/%{abi}/share
 %endif
 %endif
 %ifarch %{ix86}
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-i*86.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
+%{_libdir}/clang/%{abi}/lib/i*86-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/i*86-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/i*86-*linux/libclang_rt.*.so
 %endif
 %ifarch %{x8664}
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-x86_64.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/liborc_rt.a
 %endif
 %ifarch aarch64
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-aarch64.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a.syms
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/liborc_rt.a
+%endif
+%ifarch %{armv7}
+%ifarch %{arm32_with_hf}
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/liborc_rt.a
+%else
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/liborc_rt.a
 %endif
-%ifarch armv7hl armv7hnl
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-armhf.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a.syms
 %endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
-%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/asan_ignorelist.txt
 %endif
-%ifarch %{ix86} %{x8664} mips64 aarch64 armv7hl armv7hnl
-%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
+%ifarch %{ix86} %{x8664} mips64 aarch64 %{armv7}
+%{_libdir}/clang/%{abi}/share/cfi_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64 mips64
-%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/dfsan_abilist.txt
+%{_libdir}/clang/%{abi}/share/msan_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64
-%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/hwasan_ignorelist.txt
 %endif
 %ifarch x32
 %if %{with multilib}
-%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
-%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
-%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
-%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/asan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/cfi_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/dfsan_abilist.txt
+%{_libdir}/clang/%{abi}/share/msan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/hwasan_ignorelist.txt
 %endif
 %endif
 %endif
@@ -1163,21 +1228,22 @@ rm -rf $RPM_BUILD_ROOT
 %ifarch %{x8664} x32
 %files -n clang-multilib
 %defattr(644,root,root,755)
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-i386.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
+%{_libdir}/clang/%{abi}/lib/i386-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/i386-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/i386-*linux/libclang_rt.*.so
 %endif
 %ifarch x32
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-x86_64.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/liborc_rt.a
 %endif
 %endif
 
 %files -n clang-libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang.so.13
+%attr(755,root,root) %{_libdir}/libclang.so.17
 %attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %files -n clang-devel
@@ -1217,8 +1283,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-cc
 %attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-c++
 %attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-cc
-%{_prefix}/lib/libear
-%{_prefix}/lib/libscanbuild
+%{_prefix}/%{_lib}/libear
+%{_prefix}/%{_lib}/libscanbuild
 %{_datadir}/scan-view
 
 %files -n clang-tools-extra
@@ -1227,6 +1293,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-apply-replacements
 %attr(755,root,root) %{_bindir}/clang-change-namespace
 %attr(755,root,root) %{_bindir}/clang-extdef-mapping
+%attr(755,root,root) %{_bindir}/clang-include-cleaner
 %attr(755,root,root) %{_bindir}/clang-include-fixer
 %attr(755,root,root) %{_bindir}/clang-move
 %attr(755,root,root) %{_bindir}/clang-query
@@ -1254,10 +1321,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -n flang
 %defattr(644,root,root,755)
 %doc tools/flang/{LICENSE.TXT,README.md}
-%attr(755,root,root) %{_bindir}/f18
+%attr(755,root,root) %{_bindir}/bbc
 %attr(755,root,root) %{_bindir}/f18-parse-demo
 %attr(755,root,root) %{_bindir}/fir-opt
-%attr(755,root,root) %{_bindir}/flang
+%attr(755,root,root) %{_bindir}/flang-new
+%attr(755,root,root) %{_bindir}/flang-to-external-fc
 %attr(755,root,root) %{_bindir}/tco
 %dir %{_includedir}/flang
 %{_includedir}/flang/Version.inc
@@ -1268,8 +1336,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n flang-devel
 %defattr(644,root,root,755)
-%{_libdir}/libFIROptimizer.a
+%{_libdir}/libFIR*.a
+%{_libdir}/libHLFIR*.a
 %{_libdir}/libFortran*.a
+%{_libdir}/libflangFrontend*.a
 %{_includedir}/flang/Common
 %{_includedir}/flang/Decimal
 %{_includedir}/flang/Evaluate
@@ -1278,7 +1348,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/flang/Lower
 %{_includedir}/flang/Optimizer
 %{_includedir}/flang/Parser
+%{_includedir}/flang/Runtime
 %{_includedir}/flang/Semantics
+%{_includedir}/flang/Tools
 %{_includedir}/flang/ISO_Fortran_binding.h
 %{_libdir}/cmake/flang
 %endif
@@ -1307,8 +1379,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.14
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.14
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.17
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.17
 %dir %{py3_sitedir}/lldb
 %attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
 %{py3_sitedir}/lldb/formatters
@@ -1319,8 +1391,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/lldb/plugins
 %{py3_sitedir}/lldb/plugins/__pycache__
 %{py3_sitedir}/lldb/plugins/__init__.py
+%{py3_sitedir}/lldb/plugins/scripted_platform.py
 %{py3_sitedir}/lldb/plugins/scripted_process.py
-%attr(755,root,root) %{py3_sitedir}/lldb/_lldb.cpython-*-linux-gnu.so
+%attr(755,root,root) %{py3_sitedir}/lldb/_lldb.cpython-*.so
 
 %files -n lldb-devel
 %defattr(644,root,root,755)
This page took 0.097288 seconds and 4 git commands to generate.