]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
BR: llvm-devel for ocaml bindings
[packages/llvm.git] / llvm.spec
index ecd5160da818f633bf9ae3989a16ea28e1cb30c3..729bac7503d10a79178dda44c65a64b7d0976d7c 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       16.0.1
-Release:       0.1
+Version:       17.0.2
+Release:       1
 License:       Apache 2.0 with LLVM exceptions
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 9dab5bef4c8ec371c5dda8a6a729fe55
+# Source0-md5: ad114e00a5350c96de9d7ca4866d8d01
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 3ec8a646958609b28fe5544515ab4eed
+# Source1-md5: da00c6de5a1946fcc0b6419ee5600a65
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 63d741ca23cf0dad94237c9e11063b4e
+# Source2-md5: b0ce0f1c7e687f96e9d775c4aa3978c1
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 0250ec197adcdb1daa4b874b7a6739b0
+# Source3-md5: a51abb56e09a172fe9c5a795e0890cf3
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 8af8b4dd326a4b5d25028891d7a6fe04
+# Source4-md5: 24843481f9e054de13f5335a07883eaf
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 1015d09e53bb9f539b04300f47e97680
+# Source5-md5: 6862a7a0af802291c929d2f104ecf909
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: e04be72798080b214f01bc88d0ea4fa1
+# Source6-md5: 7389729b6ea88a71bc69d20aec8a4ea8
 Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
-# Source7-md5: fd87ca60b8513a79c47d32d6bf09cec5
+# Source7-md5: 9eb16034e79717d54be3a69d9673f5d5
 Source8:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/mlir-%{version}.src.tar.xz
-# Source8-md5: 476bc7039a879b45f9990455005bb217
+# Source8-md5: bf6d5e89bc58b880b01b38878af7e20f
 Source9:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
-# Source9-md5: 7d225951160c463a5aa528015acf3439
+# Source9-md5: fa05d0b40615544f0e421a28f173d634
 Patch1:                %{name}-pld.patch
 Patch3:                x32-gcc-toolchain.patch
-Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 Patch6:                %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
@@ -118,12 +117,13 @@ Patch8:           %{name}-selective_bindings.patch
 Patch9:                %{name}-libexecdir.patch
 Patch10:       compiler-rt-paths.patch
 Patch11:       cmake-utils-path-override.patch
-Patch12:       x32-compiler-rt.patch
+Patch12:       cmake-utils-path-override-rt.patch
+Patch13:       x32-compiler-rt.patch
 URL:           https://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
 BuildRequires: bison
-BuildRequires: cmake >= 3.13.4
+BuildRequires: cmake >= 3.20.0
 BuildRequires: flex
 BuildRequires: groff
 %{?with_libatomic:BuildRequires:       libatomic-devel}
@@ -132,6 +132,7 @@ BuildRequires:      libltdl-devel
 BuildRequires: libpfm-devel
 BuildRequires: libstdc++-devel >= 6:5
 BuildRequires: libxml2-devel >= 2
+%{?with_ocaml:BuildRequires:   llvm-devel >= 17}
 BuildRequires: ncurses-devel
 %if %{with ocaml}
 BuildRequires: ocaml >= 4.00.0
@@ -173,8 +174,8 @@ BuildRequires:      libstdc++-multilib-32-devel
 %ifarch x32
 BuildRequires: gcc-c++-multilib-32
 BuildRequires: gcc-c++-multilib-64
-BuildRequires: glibc-devel(x86_64)
 BuildRequires: glibc-devel(ix86)
+BuildRequires: glibc-devel(x86_64)
 BuildRequires: libstdc++-multilib-32-devel
 BuildRequires: libstdc++-multilib-64-devel
 %endif
@@ -205,7 +206,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     16
+%define                abi     17
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -264,7 +265,7 @@ Biblioteki współdzielone LLVM-a.
 Summary:       Static libraries and header files for LLVM
 Summary(pl.UTF-8):     Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
 Group:         Development/Languages
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs%{?_isa} = %{version}-%{release}
 %{?with_libatomic:Requires:    libatomic-devel}
 Requires:      libstdc++-devel >= 6:3.4
 Requires:      ncurses-devel
@@ -707,7 +708,6 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 
 %patch1 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 %if %{with flang}
 %patch6 -p1
@@ -718,6 +718,7 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %if %{with rt}
 %patch10 -p1
 %patch12 -p1
+%patch13 -p1
 %endif
 %patch11 -p1
 
@@ -731,7 +732,7 @@ find -name '*.py' -print0 | xargs -0 sed -i -e '1{
 }'
 
 %if %{with flang}
-%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang.in
+%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang-to-external-fc.in
 %endif
 
 %build
@@ -760,9 +761,6 @@ fi
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
        -DLLVM_INSTALL_PACKAGE_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_libdir}/cmake/llvm") \
        -DLLVM_TOOLS_INSTALL_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_bindir}") \
-%ifarch %{arm}
-       -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR:BOOL=ON \
-%endif
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
@@ -811,12 +809,10 @@ fi
 %if %{with doc}
 %{__make} -C docs docs-llvm-html
 %{__make} -C docs docs-llvm-man
-%if %{with ocaml}
-%{__make} -C docs ocaml_doc
-%endif
 %{__make} -C tools/clang/docs docs-clang-html
 %{__make} -C tools/clang/docs docs-clang-man
 %{__make} -C tools/lld/docs docs-lld-html
+%if %{with lldb}
 # workaround failed import of _lldb
 cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
 %{__make} \
@@ -824,6 +820,10 @@ cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
        -C tools/lldb/docs lldb-python-doc-package
 %{__make} -C tools/lldb/docs lldb-cpp-doc
 %endif
+%endif
+%if %{with ocaml}
+%{__make} -C docs ocaml_doc
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -880,6 +880,9 @@ install -d $RPM_BUILD_ROOT%{bash_compdir}
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
 # it seems it is used internally by an extra clang tool
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
+%if %{with mlir}
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/objects-PLD
+%endif
 
 # disable completeness check incompatible with split packaging
 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' \
@@ -1046,9 +1049,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLTO.so.16
-%attr(755,root,root) %{_libdir}/libRemarks.so.16
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.16
+%attr(755,root,root) %{_libdir}/libLTO.so.17
+%attr(755,root,root) %{_libdir}/libRemarks.so.17
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.17
 
 %files devel
 %defattr(644,root,root,755)
@@ -1086,11 +1089,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/mlir-reduce
 %attr(755,root,root) %{_bindir}/mlir-tblgen
 %attr(755,root,root) %{_bindir}/mlir-translate
-%attr(755,root,root) %{_libdir}/libMLIR.so.16
-%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.16
-%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.16
-%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so.16
-%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.16
+%attr(755,root,root) %{_libdir}/libMLIR.so.17
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.17
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.17
+%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so.17
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.17
 %if %{with doc}
 %{_mandir}/man1/mlir-tblgen.1*
 %endif
@@ -1113,13 +1116,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc tools/polly/{CREDITS.txt,LICENSE.TXT,README} tools/polly/www/{bugs,changelog,contributors}.html
 %attr(755,root,root) %{_libdir}/LLVMPolly.so
-%{?with_target_nvptx:%attr(755,root,root) %{_libdir}/libGPURuntime.so}
 
 %files polly-devel
 %defattr(644,root,root,755)
 %{_libdir}/libPolly.a
 %{_libdir}/libPollyISL.a
-%{?with_target_nvptx:%{_libdir}/libPollyPPCG.a}
 %{_includedir}/polly
 %{_libdir}/cmake/polly
 %endif
@@ -1184,11 +1185,19 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/clang/%{abi}/lib/aarch64-*linux/liborc_rt.a
 %endif
 %ifarch %{armv7}
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/clang_rt.*.o
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.a
-%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.so
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.a.syms
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/liborc_rt.a
+%ifarch %{arm32_with_hf}
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/liborc_rt.a
+%else
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/liborc_rt.a
+%endif
 %endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
 %{_libdir}/clang/%{abi}/share/asan_ignorelist.txt
@@ -1235,7 +1244,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n clang-libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang.so.16
+%attr(755,root,root) %{_libdir}/libclang.so.17
 %attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %files -n clang-devel
@@ -1313,10 +1322,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -n flang
 %defattr(644,root,root,755)
 %doc tools/flang/{LICENSE.TXT,README.md}
-%attr(755,root,root) %{_bindir}/f18
+%attr(755,root,root) %{_bindir}/bbc
 %attr(755,root,root) %{_bindir}/f18-parse-demo
 %attr(755,root,root) %{_bindir}/fir-opt
-%attr(755,root,root) %{_bindir}/flang
+%attr(755,root,root) %{_bindir}/flang-new
+%attr(755,root,root) %{_bindir}/flang-to-external-fc
 %attr(755,root,root) %{_bindir}/tco
 %dir %{_includedir}/flang
 %{_includedir}/flang/Version.inc
@@ -1327,8 +1337,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n flang-devel
 %defattr(644,root,root,755)
-%{_libdir}/libFIROptimizer.a
+%{_libdir}/libFIR*.a
+%{_libdir}/libHLFIR*.a
 %{_libdir}/libFortran*.a
+%{_libdir}/libflangFrontend*.a
 %{_includedir}/flang/Common
 %{_includedir}/flang/Decimal
 %{_includedir}/flang/Evaluate
@@ -1337,7 +1349,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/flang/Lower
 %{_includedir}/flang/Optimizer
 %{_includedir}/flang/Parser
+%{_includedir}/flang/Runtime
 %{_includedir}/flang/Semantics
+%{_includedir}/flang/Tools
 %{_includedir}/flang/ISO_Fortran_binding.h
 %{_libdir}/cmake/flang
 %endif
@@ -1366,8 +1380,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.16
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.16
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.17
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.17
 %dir %{py3_sitedir}/lldb
 %attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
 %{py3_sitedir}/lldb/formatters
This page took 0.318017 seconds and 4 git commands to generate.