]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
BR: llvm-devel for ocaml bindings
[packages/llvm.git] / llvm.spec
index 923323fdc9613a0e0cc3a049a5b1a2027a8a206e..729bac7503d10a79178dda44c65a64b7d0976d7c 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 %undefine      with_ocaml
 %endif
 
-%ifarch armv3l armv4b armv4l armv4tl armv5tl armv5tel armv5tejl armv6l armv6hl
+%ifarch armv3l %{armv4} %{armv5} %{armv6}
 %undefine      with_rt
 %endif
 
+%ifarch i386 i486 armv3l %{armv4} %{armv5} %{armv6}
+%define                with_libatomic  1
+%endif
+
 %define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_loongarch:LoongArch;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_ve:VE;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
 
 %if %{without mlir}
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       16.0.0
-Release:       0.1
+Version:       17.0.2
+Release:       1
 License:       Apache 2.0 with LLVM exceptions
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: c465413aa9ab18837f40cc5750d39a33
+# Source0-md5: ad114e00a5350c96de9d7ca4866d8d01
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: d38fd3897a0fd6dc396c973ba08662aa
+# Source1-md5: da00c6de5a1946fcc0b6419ee5600a65
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 5f0633ec762fed4f1e2c450b3654caa6
+# Source2-md5: b0ce0f1c7e687f96e9d775c4aa3978c1
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: ad78eb12a144c7e5eb7ae235af8d6dfd
+# Source3-md5: a51abb56e09a172fe9c5a795e0890cf3
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 4ede663c676600ed63e4d7d840ff480b
+# Source4-md5: 24843481f9e054de13f5335a07883eaf
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 9c21e090e61e0dda6c7a044207af38e3
+# Source5-md5: 6862a7a0af802291c929d2f104ecf909
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: 4c031fc367188d0a45b7ab8838dd9b49
+# Source6-md5: 7389729b6ea88a71bc69d20aec8a4ea8
 Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
-# Source7-md5: b895740c1fd1c69bd28d03f93fa3eea1
-# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-16.0.0/llvm-project-16.0.0.src.tar.xz
-Source8:       mlir-%{version}.tar.xz
-# Source8-md5: 9596f341d62129b9c7204305c111d5be
+# Source7-md5: 9eb16034e79717d54be3a69d9673f5d5
+Source8:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/mlir-%{version}.src.tar.xz
+# Source8-md5: bf6d5e89bc58b880b01b38878af7e20f
 Source9:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
-# Source9-md5: b2103df1421f7bcc271fcacec27a24bb
+# Source9-md5: fa05d0b40615544f0e421a28f173d634
 Patch1:                %{name}-pld.patch
 Patch3:                x32-gcc-toolchain.patch
-Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 Patch6:                %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
@@ -115,22 +117,22 @@ Patch8:           %{name}-selective_bindings.patch
 Patch9:                %{name}-libexecdir.patch
 Patch10:       compiler-rt-paths.patch
 Patch11:       cmake-utils-path-override.patch
-Patch12:       x32-compiler-rt.patch
+Patch12:       cmake-utils-path-override-rt.patch
+Patch13:       x32-compiler-rt.patch
 URL:           https://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
 BuildRequires: bison
-BuildRequires: cmake >= 3.13.4
+BuildRequires: cmake >= 3.20.0
 BuildRequires: flex
 BuildRequires: groff
-%ifarch i386 i486 %{arm}
-BuildRequires: libatomic-devel
-%endif
+%{?with_libatomic:BuildRequires:       libatomic-devel}
 BuildRequires: libedit-devel
 BuildRequires: libltdl-devel
 BuildRequires: libpfm-devel
 BuildRequires: libstdc++-devel >= 6:5
 BuildRequires: libxml2-devel >= 2
+%{?with_ocaml:BuildRequires:   llvm-devel >= 17}
 BuildRequires: ncurses-devel
 %if %{with ocaml}
 BuildRequires: ocaml >= 4.00.0
@@ -147,7 +149,7 @@ BuildRequires:      python3-modules
 BuildRequires: python3-pygments >= 2.0
 BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.742
+BuildRequires: rpmbuild(macros) >= 2.007
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xar-devel >= 1.6
@@ -172,8 +174,8 @@ BuildRequires:      libstdc++-multilib-32-devel
 %ifarch x32
 BuildRequires: gcc-c++-multilib-32
 BuildRequires: gcc-c++-multilib-64
-BuildRequires: glibc-devel(x86_64)
 BuildRequires: glibc-devel(ix86)
+BuildRequires: glibc-devel(x86_64)
 BuildRequires: libstdc++-multilib-32-devel
 BuildRequires: libstdc++-multilib-64-devel
 %endif
@@ -204,7 +206,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     16
+%define                abi     17
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -263,8 +265,13 @@ Biblioteki współdzielone LLVM-a.
 Summary:       Static libraries and header files for LLVM
 Summary(pl.UTF-8):     Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
 Group:         Development/Languages
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs%{?_isa} = %{version}-%{release}
+%{?with_libatomic:Requires:    libatomic-devel}
 Requires:      libstdc++-devel >= 6:3.4
+Requires:      ncurses-devel
+%{?with_z3:Requires:   z3-devel}
+Requires:      zlib-devel
+Requires:      zstd-devel
 
 %description devel
 This package contains static libraries and header files needed to
@@ -695,13 +702,12 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %{__mv} flang-%{version}.src tools/flang
 %endif
 %if %{with mlir}
-%{__mv} mlir tools/mlir
+%{__mv} mlir-%{version}.src tools/mlir
 %endif
 %{__mv} cmake-%{version}.src cmake-utils
 
 %patch1 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 %if %{with flang}
 %patch6 -p1
@@ -712,6 +718,7 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %if %{with rt}
 %patch10 -p1
 %patch12 -p1
+%patch13 -p1
 %endif
 %patch11 -p1
 
@@ -725,7 +732,7 @@ find -name '*.py' -print0 | xargs -0 sed -i -e '1{
 }'
 
 %if %{with flang}
-%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang.in
+%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang-to-external-fc.in
 %endif
 
 %build
@@ -754,9 +761,6 @@ fi
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
        -DLLVM_INSTALL_PACKAGE_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_libdir}/cmake/llvm") \
        -DLLVM_TOOLS_INSTALL_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_bindir}") \
-%ifarch %{arm}
-       -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR:BOOL=ON \
-%endif
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
@@ -805,12 +809,10 @@ fi
 %if %{with doc}
 %{__make} -C docs docs-llvm-html
 %{__make} -C docs docs-llvm-man
-%if %{with ocaml}
-%{__make} -C docs ocaml_doc
-%endif
 %{__make} -C tools/clang/docs docs-clang-html
 %{__make} -C tools/clang/docs docs-clang-man
 %{__make} -C tools/lld/docs docs-lld-html
+%if %{with lldb}
 # workaround failed import of _lldb
 cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
 %{__make} \
@@ -818,6 +820,10 @@ cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
        -C tools/lldb/docs lldb-python-doc-package
 %{__make} -C tools/lldb/docs lldb-cpp-doc
 %endif
+%endif
+%if %{with ocaml}
+%{__make} -C docs ocaml_doc
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -874,6 +880,9 @@ install -d $RPM_BUILD_ROOT%{bash_compdir}
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
 # it seems it is used internally by an extra clang tool
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
+%if %{with mlir}
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/objects-PLD
+%endif
 
 # disable completeness check incompatible with split packaging
 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' \
@@ -1040,9 +1049,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLTO.so.16
-%attr(755,root,root) %{_libdir}/libRemarks.so.16
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.16
+%attr(755,root,root) %{_libdir}/libLTO.so.17
+%attr(755,root,root) %{_libdir}/libRemarks.so.17
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.17
 
 %files devel
 %defattr(644,root,root,755)
@@ -1080,11 +1089,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/mlir-reduce
 %attr(755,root,root) %{_bindir}/mlir-tblgen
 %attr(755,root,root) %{_bindir}/mlir-translate
-%attr(755,root,root) %{_libdir}/libMLIR.so.16
-%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.16
-%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.16
-%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so.16
-%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.16
+%attr(755,root,root) %{_libdir}/libMLIR.so.17
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.17
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.17
+%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so.17
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.17
 %if %{with doc}
 %{_mandir}/man1/mlir-tblgen.1*
 %endif
@@ -1107,13 +1116,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc tools/polly/{CREDITS.txt,LICENSE.TXT,README} tools/polly/www/{bugs,changelog,contributors}.html
 %attr(755,root,root) %{_libdir}/LLVMPolly.so
-%{?with_target_nvptx:%attr(755,root,root) %{_libdir}/libGPURuntime.so}
 
 %files polly-devel
 %defattr(644,root,root,755)
 %{_libdir}/libPolly.a
 %{_libdir}/libPollyISL.a
-%{?with_target_nvptx:%{_libdir}/libPollyPPCG.a}
 %{_includedir}/polly
 %{_libdir}/cmake/polly
 %endif
@@ -1146,7 +1153,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/clang/%{abi}/bin
 %attr(755,root,root) %{_libdir}/clang/%{abi}/bin/hwasan_symbolize
 %endif
-%ifarch %{ix86} %{x8664} aarch64 armv7hl armv7hnl
+%ifarch %{ix86} %{x8664} aarch64 %{armv7}
 %dir %{_libdir}/clang/%{abi}/lib
 %dir %{_libdir}/clang/%{abi}/lib/*-linux*
 %dir %{_libdir}/clang/%{abi}/share
@@ -1177,17 +1184,25 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.a.syms
 %{_libdir}/clang/%{abi}/lib/aarch64-*linux/liborc_rt.a
 %endif
-%ifarch armv7hl armv7hnl
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/clang_rt.*.o
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.a
-%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.so
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.a.syms
-%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/liborc_rt.a
+%ifarch %{armv7}
+%ifarch %{arm32_with_hf}
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}hf/liborc_rt.a
+%else
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/arm-*linux%{_gnu}/liborc_rt.a
+%endif
 %endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
 %{_libdir}/clang/%{abi}/share/asan_ignorelist.txt
 %endif
-%ifarch %{ix86} %{x8664} mips64 aarch64 armv7hl armv7hnl
+%ifarch %{ix86} %{x8664} mips64 aarch64 %{armv7}
 %{_libdir}/clang/%{abi}/share/cfi_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64 mips64
@@ -1229,7 +1244,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n clang-libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang.so.16
+%attr(755,root,root) %{_libdir}/libclang.so.17
 %attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %files -n clang-devel
@@ -1307,10 +1322,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -n flang
 %defattr(644,root,root,755)
 %doc tools/flang/{LICENSE.TXT,README.md}
-%attr(755,root,root) %{_bindir}/f18
+%attr(755,root,root) %{_bindir}/bbc
 %attr(755,root,root) %{_bindir}/f18-parse-demo
 %attr(755,root,root) %{_bindir}/fir-opt
-%attr(755,root,root) %{_bindir}/flang
+%attr(755,root,root) %{_bindir}/flang-new
+%attr(755,root,root) %{_bindir}/flang-to-external-fc
 %attr(755,root,root) %{_bindir}/tco
 %dir %{_includedir}/flang
 %{_includedir}/flang/Version.inc
@@ -1321,8 +1337,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n flang-devel
 %defattr(644,root,root,755)
-%{_libdir}/libFIROptimizer.a
+%{_libdir}/libFIR*.a
+%{_libdir}/libHLFIR*.a
 %{_libdir}/libFortran*.a
+%{_libdir}/libflangFrontend*.a
 %{_includedir}/flang/Common
 %{_includedir}/flang/Decimal
 %{_includedir}/flang/Evaluate
@@ -1331,7 +1349,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/flang/Lower
 %{_includedir}/flang/Optimizer
 %{_includedir}/flang/Parser
+%{_includedir}/flang/Runtime
 %{_includedir}/flang/Semantics
+%{_includedir}/flang/Tools
 %{_includedir}/flang/ISO_Fortran_binding.h
 %{_libdir}/cmake/flang
 %endif
@@ -1360,8 +1380,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.16
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.16
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.17
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.17
 %dir %{py3_sitedir}/lldb
 %attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
 %{py3_sitedir}/lldb/formatters
This page took 0.519452 seconds and 4 git commands to generate.