]> git.pld-linux.org Git - packages/linux-gpib.git/blobdiff - linux-gpib.spec
- firmware is now available in linux-gpib-firmware package (some require fxload)
[packages/linux-gpib.git] / linux-gpib.spec
index b2946a221881ca24400078ae82a3689dc454f4e7..b8d2c04f43a835edee534342e23631fd6dad4821 100644 (file)
@@ -1,8 +1,9 @@
-# TODO:
-# - where to get firmware from?
 #
 # Conditional build:
 %bcond_without kernel          # kernel modules
+%bcond_without drivers_isa     # ISA kernel drivers [ix86 only]
+%bcond_without drivers_pcmcia  # PCMCIA support in kernel drivers
+%bcond_without drivers_usb     # USB kernel drivers
 %bcond_without userspace       # userspace packages
 %bcond_without verbose         # verbose modules build (V=1)
 
 %bcond_without python          # Python binding
 %bcond_without tcl             # Tcl binding
 
+%ifnarch %{ix86}
+%undefine      with_drivers_isa
+%undefine      with_drivers_pcmcia
+%endif
 %include       /usr/lib/rpm/macros.perl
 %define                php_name        php%{?php_suffix}
 Summary:       GPIB (IEEE 488) Linux support
 Summary(pl.UTF-8):     Obsługa GPIB (IEEE 488) dla Linuksa
 Name:          linux-gpib
 Version:       4.0.3
-%define        rel     0.1
+%define        rel     1
 Release:       %{rel}
 License:       GPL v2+
 Group:         Applications/System
@@ -54,6 +59,10 @@ BuildRequires:       readline-devel
 %{?with_tcl:BuildRequires:     tcl-devel}
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
+# for agilent_82357a and ni_usb_gpib
+Suggests:      fxload
+# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
+Suggests:      linux-gpib-firmware
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -220,7 +229,7 @@ Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
 TOPDIR=$(pwd)\
 %build_kernel_modules -C drivers/gpib -m gpib -- EARLYCPPFLAGS="-I$TOPDIR -I$TOPDIR/drivers/gpib/include -I$TOPDIR/include"\
 cd drivers/gpib\
-%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,agilent_82357a/agilent_82357a,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,lpvo_usb_gpib/lpvo_usb_gpib,nec7210/nec7210,ni_usb/ni_usb_gpib,pc2/pc2_gpib,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882 -d kernel/gpib\
+%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
 %{nil}
 
 %define install_kernel_pkg()\
@@ -256,10 +265,8 @@ done
 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.0"
 %endif
 %configure \
-%ifarch %{ix86}
-       --enable-isa \
-       --enable-pcmcia \
-%endif
+       %{?with_drivers_isa:--enable-isa} \
+       %{?with_drivers_pcmcia:--enable-pcmcia} \
        %{!?with_docs:--disable-documentation} \
        %{!?with_guile:--disable-guile-binding} \
        %{!?with_perl:--disable-perl-binding} \
@@ -292,11 +299,16 @@ cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
        HOTPLUG_USB_CONF_DIR=/lib/udev \
        UDEV_RULES_DIR=/lib/udev/rules.d \
        USB_FIRMWARE_DIR=/lib/firmware
+
+%if %{with hotplug}
 # use udev paths as base and legacy hotplug as addon (not the opposite)
 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
+%else
+%{__rm} $RPM_BUILD_ROOT/lib/udev/*.usermap
+%endif
 
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
@@ -380,14 +392,6 @@ fi
 /lib/udev/rules.d/99-ni_usb_gpib.rules
 %attr(755,root,root) /lib/udev/agilent_82357a
 %attr(755,root,root) /lib/udev/ni_usb_gpib
-%dir /lib/firmware/agilent_82357a
-# TODO:
-#/lib/firmware/agilent_82357a/82357a_fw.hex
-#/lib/firmware/agilent_82357a/measat_releaseX1.8.hex
-%dir /lib/firmware/ni_usb_gpib
-# TODO:
-#/lib/firmware/ni_usb_gpib/niusbb_firmware.hex
-#/lib/firmware/ni_usb_gpib/niusbb_loader.hex
 
 %if %{with hotplug}
 %files hotplug
This page took 0.090766 seconds and 4 git commands to generate.