]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- add webserver(setenv)
[packages/lighttpd.git] / lighttpd.spec
index d02cb1be8361fe98a1addbcddbec26f2107cfc57..f8d745bac5934240f85d509cbe6448d7c13d91e0 100644 (file)
@@ -1,5 +1,5 @@
 # TODO:
-# - test ldap and mysql (failed at this time)
+# - test mysql (failed at this time)
 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
 # - fam over gamin is possible, just configure doesn't check other than gamin
 # - feature stat-cache-fam (doesn't work)
@@ -17,7 +17,7 @@
 %bcond_without largefile       # largefile support (see notes above)
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost
-%bcond_with    ldap            # ldap support in mod_auth
+%bcond_without ldap            # ldap support in mod_auth
 %bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
 %define                webdav_progs    1
 %endif
 
-%define                _rel 1
+%define                rel 10
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.15
-Release:       %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
+Version:       1.4.19
+Release:       %{rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
 License:       BSD
 Group:         Networking/Daemons
-Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
-# Source0-md5: d2ceaaf242b2b3593ff4d8222d543649
+Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.bz2
+# Source0-md5: d787374e4e4aaa09d5cfa9ab9d23ad40
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
 Source4:       %{name}.logrotate
 Source5:       %{name}.sysconfig
 Source6:       %{name}-mime.types.sh
-Source7:       http://www.lighttpd.net/favicon.ico
-# Source7-md5: a358994becabd4060393a5454bde505d
+Source7:       http://glen.alkohol.ee/pld/lighty/favicon.ico
+# Source7-md5: 00fcac5b861a54f5eb147a589504d480
 Source8:       http://www.lighttpd.net/light_button.png
 # Source8-md5: 02330e2313fadc29144edfd6000879f8
 Source9:       http://www.lighttpd.net/light_logo.png
@@ -63,6 +63,7 @@ Source10:     http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
 # Source10-md5:        486ecec3f6f4fe7f9bf7cee757b864f4
 Source11:      %{name}-pld.html
 Source12:      %{name}.monitrc
+Source13:      %{name}-branch.sh
 Source100:     %{name}-mod_access.conf
 Source101:     %{name}-mod_accesslog.conf
 Source102:     %{name}-mod_alias.conf
@@ -99,9 +100,15 @@ Source132:  %{name}-ssl.conf
 Source133:     %{name}-mod_mysql_vhost.conf
 Source134:     %{name}-mod_magnet.conf
 Source135:     %{name}-mod_extforward.conf
+Source136:     %{name}-mod_h264_streaming.conf
+Source137:     %{name}-mod_cgi_php.conf
+Patch100:      %{name}-branch.diff
 Patch0:                %{name}-use_bin_sh.patch
 Patch1:                %{name}-mod_evasive-status_code.patch
-Patch2:                %{name}-mod_deflate.patch
+Patch2:                %{name}-mod_h264_streaming.patch
+Patch3:                %{name}-branding.patch
+Patch4:                %{name}-modinit-before-fork.patch
+#Patchx:       %{name}-mod_deflate.patch
 URL:           http://www.lighttpd.net/
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf
@@ -134,15 +141,16 @@ Requires(pre):    /usr/lib/rpm/user_group.sh
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/sbin/usermod
-Requires:      %{name}-mod_dirlisting
-Requires:      %{name}-mod_indexfile
-Requires:      %{name}-mod_staticfile
+Requires:      %{name}-mod_dirlisting = %{version}-%{release}
+Requires:      %{name}-mod_indexfile = %{version}-%{release}
+Requires:      %{name}-mod_staticfile = %{version}-%{release}
 Requires:      rc-scripts
 Requires:      webapps
 Provides:      group(http)
 Provides:      group(lighttpd)
 Provides:      user(lighttpd)
 Provides:      webserver
+Conflicts:     logrotate < 3.7-4
 # for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
 Conflicts:     rpm < 4.4.2-0.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -247,6 +255,27 @@ Moduł cgi udostępnia interfejs zgodny z CGI.
 Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
 prosty i naturalny sposób.
 
+%package mod_cgi_php
+Summary:       lighttpd module for CGI handling PHP scripts
+Summary(pl.UTF-8):     Moduł lighttpd do obsługi skryptów PHP przez CGI
+Group:         Networking/Daemons
+Requires:      %{name}-mod_cgi = %{version}-%{release}
+Requires:      php(cgi)
+Provides:      webserver(php)
+
+%description mod_cgi_php
+The cgi module provides a CGI-conforming interface for PHP scripts.
+
+CGI programs allow you to enhance the functionality of the server in a
+very straight and simple way.
+
+%description mod_cgi_php -l pl.UTF-8
+Moduł cgi udostępnia interfejs zgodny z CGI do wywoływania skryptów
+PHP.
+
+Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
+prosty i naturalny sposób.
+
 %package mod_cml
 Summary:       lighttpd module for Cache Meta Language
 Summary(pl.UTF-8):     Moduł Cache Meta Language
@@ -400,6 +429,18 @@ lighttpd module for flv streaming.
 %description mod_flv_streaming -l pl.UTF-8
 Moduł lighttpd do streamingu flv.
 
+%package mod_h264_streaming
+Summary:       lighttpd module for h264 streaming
+License:       GPL v3+
+Group:         Networking/Daemons
+URL:           http://h264.code-shop.com/
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_h264_streaming
+lighttpd module for h264 streaming.
+
+Please note that this module is experimental and work-in-progress.
+
 %package mod_indexfile
 Summary:       lighttpd indexfile module
 Summary(pl.UTF-8):     Moduł indexfile dla lighttpd
@@ -553,6 +594,7 @@ Summary:    lighttpd module for setting conditional request headers
 Summary(pl.UTF-8):     Moduł lighttpd do ustawiania warunkowych nagłówków żądań
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
+Provides:      webserver(setenv)
 
 %description mod_setenv
 mod_setenv is used to add request headers.
@@ -682,6 +724,7 @@ zaimplementowane. Jak na razie są:
 - DELETE
 - PUT
 - LOCK (experimental)
+
 oraz zwykłe GET, POST, HEAD z HTTP/1.1.
 
 Jak na razie montowanie zasobu webdav pod Windows XP działa i
@@ -750,15 +793,21 @@ Requires: %{name} = %{version}-%{release}
 Requires:      monit
 
 %description -n monit-rc-lighttpd
-monitrc file for monitoring MySQL database server.
+monitrc file for monitoring lighttpd web server.
 
 %description -n monit-rc-lighttpd -l pl.UTF-8
-Plik monitrc do monitorowania serwera baz danych MySQL.
+Plik monitrc do monitorowania serwera www lighttpd.
 
 %prep
 %setup -q
+%patch100 -p0
+%patch4 -p0
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
 # build mime.types.conf
 sh %{SOURCE6} /etc/mime.types
@@ -785,7 +834,8 @@ sh %{SOURCE6} /etc/mime.types
        %{?with_gamin:--with-gamin} \
        %{?with_gdbm:--with-gdbm}
 
-%{__make}
+# -j1 as src/mod_ssi_exprparser.h regeneration deps are broken
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -793,7 +843,8 @@ install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d
        $RPM_BUILD_ROOT%{_sysconfdir}/{conf,webapps}.d \
        $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}} \
        $RPM_BUILD_ROOT%{_datadir}/lighttpd/errordocs \
-       $RPM_BUILD_ROOT/var/lib/lighttpd
+       $RPM_BUILD_ROOT/var/lib/lighttpd \
+       $RPM_BUILD_ROOT/var/cache/lighttpd/mod_compress
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -825,6 +876,7 @@ install %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_access.conf
 install %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_alias.conf
 install %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_auth.conf
 install %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi.conf
+install %{SOURCE137} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi_php.conf
 install %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cml.conf
 install %{SOURCE106} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_compress.conf
 install %{SOURCE107} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_deflate.conf
@@ -832,9 +884,10 @@ install %{SOURCE108} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_dirlisting.conf
 install %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
 install %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
 install %{SOURCE111} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_expire.conf
-install %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_extforward.conf
+install %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/91_mod_extforward.conf
 install %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
 install %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
+install %{SOURCE136} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_h264_streaming.conf
 install %{SOURCE114} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_indexfile.conf
 install %{SOURCE134} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_magnet.conf
 install %{SOURCE115} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_proxy.conf
@@ -950,6 +1003,7 @@ fi
 %module_scripts mod_extforward
 %module_scripts mod_fastcgi
 %module_scripts mod_flv_streaming
+%module_scripts mod_h264_streaming
 %module_scripts mod_indexfile
 %module_scripts mod_magnet
 %module_scripts mod_mysql_vhost
@@ -983,11 +1037,11 @@ fi
 %module_scripts php-spawned
 %module_scripts php-external
 
-%triggerpostun -- %{name} <= 1.3.6-2
-%banner %{name} -e <<EOF
-spawn-fcgi program is now available separately from spawn-fcgi package.
-
-EOF
+%triggerpostun -- %{name} < 1.4.18-10.1
+if [ -f /etc/lighttpd/conf.d/50_mod_extforward.conf.rpmsave ]; then
+       cp -f /etc/lighttpd/conf.d/91_mod_extforward.conf{,.rpmnew}
+       mv -f /etc/lighttpd/conf.d/{50_mod_extforward.conf.rpmsave,91_mod_extforward.conf}
+fi
 
 %files
 %defattr(644,root,root,755)
@@ -1007,7 +1061,8 @@ EOF
 %dir %attr(770,root,lighttpd) /var/run/%{name}
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
-%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_sbindir}/lighttpd
+%attr(755,root,root) %{_sbindir}/lighttpd-angel
 %dir %{_libdir}
 %{_mandir}/man?/*
 %dir %{_lighttpddir}
@@ -1021,6 +1076,9 @@ EOF
 # rrdtool database is stored there
 %dir %attr(771,root,lighttpd) /var/lib/lighttpd
 
+# mod_compress can put cached files there
+%dir /var/cache/lighttpd
+
 %files mod_access
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_access.conf
@@ -1046,6 +1104,10 @@ EOF
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi.conf
 %attr(755,root,root) %{_libdir}/mod_cgi.so
 
+%files mod_cgi_php
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi_php.conf
+
 %files mod_cml
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cml.conf
@@ -1055,6 +1117,7 @@ EOF
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_compress.conf
 %attr(755,root,root) %{_libdir}/mod_compress.so
+%dir %attr(775,root,lighttpd) /var/cache/lighttpd/mod_compress
 
 %if %{with deflate}
 %files mod_deflate
@@ -1098,6 +1161,11 @@ EOF
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_flv_streaming.conf
 %attr(755,root,root) %{_libdir}/mod_flv_streaming.so
 
+%files mod_h264_streaming
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_h264_streaming.conf
+%attr(755,root,root) %{_libdir}/mod_h264_streaming.so
+
 %files mod_indexfile
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_indexfile.conf
This page took 0.054233 seconds and 4 git commands to generate.