]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- add webserver(setenv)
[packages/lighttpd.git] / lighttpd.spec
index 89e521e3afc3f587b22aafb7083d73732c7c58f2..f8d745bac5934240f85d509cbe6448d7c13d91e0 100644 (file)
@@ -1,5 +1,5 @@
 # TODO:
-# - test ldap and mysql (failed at this time)
+# - test mysql (failed at this time)
 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
 # - fam over gamin is possible, just configure doesn't check other than gamin
 # - feature stat-cache-fam (doesn't work)
@@ -17,7 +17,7 @@
 %bcond_without largefile       # largefile support (see notes above)
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost
-%bcond_with    ldap            # ldap support in mod_auth
+%bcond_without ldap            # ldap support in mod_auth
 %bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
 %define                webdav_progs    1
 %endif
 
-%define                _rel 6.2
+%define                rel 10
 Summary:       Fast and light HTTP server
-Summary(pl.UTF-8):   Szybki i lekki serwer HTTP
+Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.13
-Release:       %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
+Version:       1.4.19
+Release:       %{rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
 License:       BSD
 Group:         Networking/Daemons
-Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
-# Source0-md5: d775d6478391b95d841a1018c8db0b95
+Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.bz2
+# Source0-md5: d787374e4e4aaa09d5cfa9ab9d23ad40
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
 Source4:       %{name}.logrotate
 Source5:       %{name}.sysconfig
 Source6:       %{name}-mime.types.sh
-Source7:       http://www.lighttpd.net/favicon.ico
-# Source7-md5: a358994becabd4060393a5454bde505d
+Source7:       http://glen.alkohol.ee/pld/lighty/favicon.ico
+# Source7-md5: 00fcac5b861a54f5eb147a589504d480
 Source8:       http://www.lighttpd.net/light_button.png
 # Source8-md5: 02330e2313fadc29144edfd6000879f8
 Source9:       http://www.lighttpd.net/light_logo.png
@@ -63,6 +63,7 @@ Source10:     http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
 # Source10-md5:        486ecec3f6f4fe7f9bf7cee757b864f4
 Source11:      %{name}-pld.html
 Source12:      %{name}.monitrc
+Source13:      %{name}-branch.sh
 Source100:     %{name}-mod_access.conf
 Source101:     %{name}-mod_accesslog.conf
 Source102:     %{name}-mod_alias.conf
@@ -99,12 +100,15 @@ Source132: %{name}-ssl.conf
 Source133:     %{name}-mod_mysql_vhost.conf
 Source134:     %{name}-mod_magnet.conf
 Source135:     %{name}-mod_extforward.conf
-#Patch100: %{name}-branch.diff
+Source136:     %{name}-mod_h264_streaming.conf
+Source137:     %{name}-mod_cgi_php.conf
+Patch100:      %{name}-branch.diff
 Patch0:                %{name}-use_bin_sh.patch
 Patch1:                %{name}-mod_evasive-status_code.patch
-Patch2:                %{name}-mod_deflate.patch
-Patch3:                %{name}-mod_extforward-v2.patch
-Patch4:                %{name}-mod_expire-weeks.patch
+Patch2:                %{name}-mod_h264_streaming.patch
+Patch3:                %{name}-branding.patch
+Patch4:                %{name}-modinit-before-fork.patch
+#Patchx:       %{name}-mod_deflate.patch
 URL:           http://www.lighttpd.net/
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf
@@ -137,15 +141,16 @@ Requires(pre):    /usr/lib/rpm/user_group.sh
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/sbin/usermod
-Requires:      %{name}-mod_dirlisting
-Requires:      %{name}-mod_indexfile
-Requires:      %{name}-mod_staticfile
+Requires:      %{name}-mod_dirlisting = %{version}-%{release}
+Requires:      %{name}-mod_indexfile = %{version}-%{release}
+Requires:      %{name}-mod_staticfile = %{version}-%{release}
 Requires:      rc-scripts
 Requires:      webapps
 Provides:      group(http)
 Provides:      group(lighttpd)
 Provides:      user(lighttpd)
 Provides:      webserver
+Conflicts:     logrotate < 3.7-4
 # for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
 Conflicts:     rpm < 4.4.2-0.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -175,7 +180,7 @@ powodu problemów z obciążeniem.
 
 %package mod_access
 Summary:       lighttpd module for making access restrictions
-Summary(pl.UTF-8):   Moduł lighttpd ograniczający dostęp
+Summary(pl.UTF-8):     Moduł lighttpd ograniczający dostęp
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(access)
@@ -190,7 +195,7 @@ Moduł access służy do ograniczania dostępu do plików o podanych
 
 %package mod_accesslog
 Summary:       lighttpd module to record access logs
-Summary(pl.UTF-8):   Moduł lighttpd do zapisu logów dostępu
+Summary(pl.UTF-8):     Moduł lighttpd do zapisu logów dostępu
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -202,7 +207,7 @@ Domyślnie podobny do CLF, elastyczny jak Apache.
 
 %package mod_alias
 Summary:       lighttpd module for making URL aliasing
-Summary(pl.UTF-8):   Moduł lighttpd odpowiadający za aliasy URL-i
+Summary(pl.UTF-8):     Moduł lighttpd odpowiadający za aliasy URL-i
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(alias)
@@ -217,7 +222,7 @@ dla podanego podzbioru URL-i.
 
 %package mod_auth
 Summary:       lighttpd module for authentication support
-Summary(pl.UTF-8):   Moduł lighttpd do obsługi uwierzytelniania
+Summary(pl.UTF-8):     Moduł lighttpd do obsługi uwierzytelniania
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(auth)
@@ -232,7 +237,7 @@ basic i digest.
 
 %package mod_cgi
 Summary:       lighttpd module for CGI handling
-Summary(pl.UTF-8):   Moduł lighttpd do obsługi CGI
+Summary(pl.UTF-8):     Moduł lighttpd do obsługi CGI
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      %{name}-mod_alias = %{version}-%{release}
@@ -250,9 +255,30 @@ Moduł cgi udostępnia interfejs zgodny z CGI.
 Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
 prosty i naturalny sposób.
 
+%package mod_cgi_php
+Summary:       lighttpd module for CGI handling PHP scripts
+Summary(pl.UTF-8):     Moduł lighttpd do obsługi skryptów PHP przez CGI
+Group:         Networking/Daemons
+Requires:      %{name}-mod_cgi = %{version}-%{release}
+Requires:      php(cgi)
+Provides:      webserver(php)
+
+%description mod_cgi_php
+The cgi module provides a CGI-conforming interface for PHP scripts.
+
+CGI programs allow you to enhance the functionality of the server in a
+very straight and simple way.
+
+%description mod_cgi_php -l pl.UTF-8
+Moduł cgi udostępnia interfejs zgodny z CGI do wywoływania skryptów
+PHP.
+
+Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
+prosty i naturalny sposób.
+
 %package mod_cml
 Summary:       lighttpd module for Cache Meta Language
-Summary(pl.UTF-8):   Moduł Cache Meta Language
+Summary(pl.UTF-8):     Moduł Cache Meta Language
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -267,7 +293,7 @@ z drugiej strony do budowania strony z fragmentów przy użyciu LUA.
 
 %package mod_compress
 Summary:       lighttpd module for output compression
-Summary(pl.UTF-8):   Moduł lighttpd do kompresji wyjścia
+Summary(pl.UTF-8):     Moduł lighttpd do kompresji wyjścia
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -291,7 +317,7 @@ Obsługiwane są gzip, deflate i bzip.
 
 %package mod_deflate
 Summary:       lighttpd module for output compression using deflate method
-Summary(pl.UTF-8):   Moduł lighttpd do kompresji wyjścia metodą deflate
+Summary(pl.UTF-8):     Moduł lighttpd do kompresji wyjścia metodą deflate
 Group:         Networking/Daemons
 URL:           http://trac.lighttpd.net/trac/wiki/Mod_Deflate
 Requires:      %{name} = %{version}-%{release}
@@ -307,7 +333,7 @@ mod_compress.
 
 %package mod_dirlisting
 Summary:       lighttpd module for directory listings
-Summary(pl.UTF-8):   Moduł lighttpd do tworzenia listingów katalogów
+Summary(pl.UTF-8):     Moduł lighttpd do tworzenia listingów katalogów
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -321,7 +347,7 @@ kontrolą CSS.
 
 %package mod_evasive
 Summary:       lighttpd evasive module
-Summary(pl.UTF-8):   Moduł evasive dla lighttpd
+Summary(pl.UTF-8):     Moduł evasive dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -333,7 +359,7 @@ Moduł evasive dla lighttpd.
 
 %package mod_evhost
 Summary:       lighttpd module for enhanced virtual-hosting
-Summary(pl.UTF-8):   Moduł lighttpd rozszerzający obsługę hostów wirtualnych
+Summary(pl.UTF-8):     Moduł lighttpd rozszerzający obsługę hostów wirtualnych
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -349,7 +375,7 @@ nazwy hosta.
 
 %package mod_expire
 Summary:       lighttpd module for controlling the expiration of content in caches
-Summary(pl.UTF-8):   Moduł lighttpd sterujący wygasaniem treści w cache'ach
+Summary(pl.UTF-8):     Moduł lighttpd sterujący wygasaniem treści w cache'ach
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -361,7 +387,7 @@ mod_expire steruje ustawianiem nagłówka odpowiedzi Expire.
 
 %package mod_extforward
 Summary:       lighttpd module to extract the client's "real" IP from X-Forwarded-For header
-Summary(pl.UTF-8):   Moduł lighttpd wyciągający "prawdziwy" IP klienta z nagłówka X-Forwarded-For
+Summary(pl.UTF-8):     Moduł lighttpd wyciągający "prawdziwy" IP klienta z nagłówka X-Forwarded-For
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -377,7 +403,7 @@ serwerów stojących za odwrotnymi serwerami proxy.
 
 %package mod_fastcgi
 Summary:       lighttpd module for FastCGI interface
-Summary(pl.UTF-8):   Moduł lighttpd do interfejsu FastCGI
+Summary(pl.UTF-8):     Moduł lighttpd do interfejsu FastCGI
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -393,7 +419,7 @@ jak Perl, PHP czy własne aplikacje.
 
 %package mod_flv_streaming
 Summary:       lighttpd module for flv streaming
-Summary(pl.UTF-8):   Moduł lighttpd do streamingu flv
+Summary(pl.UTF-8):     Moduł lighttpd do streamingu flv
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -403,9 +429,21 @@ lighttpd module for flv streaming.
 %description mod_flv_streaming -l pl.UTF-8
 Moduł lighttpd do streamingu flv.
 
+%package mod_h264_streaming
+Summary:       lighttpd module for h264 streaming
+License:       GPL v3+
+Group:         Networking/Daemons
+URL:           http://h264.code-shop.com/
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_h264_streaming
+lighttpd module for h264 streaming.
+
+Please note that this module is experimental and work-in-progress.
+
 %package mod_indexfile
 Summary:       lighttpd indexfile module
-Summary(pl.UTF-8):   Moduł indexfile dla lighttpd
+Summary(pl.UTF-8):     Moduł indexfile dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(indexfile)
@@ -418,7 +456,7 @@ Moduł indexfile.
 
 %package mod_magnet
 Summary:       lighttpd powermagnet module
-Summary(pl.UTF-8):   Moduł powermagnet dla lighttpd
+Summary(pl.UTF-8):     Moduł powermagnet dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -430,7 +468,7 @@ mod_magnet to moduł sterujący obsługą żądań w lighty.
 
 %package mod_mysql_vhost
 Summary:       lighttpd module for MySQL based vhosting
-Summary(pl.UTF-8):   Moduł lighttpd obsługujący vhosty oparte na MySQL-u
+Summary(pl.UTF-8):     Moduł lighttpd obsługujący vhosty oparte na MySQL-u
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Conflicts:     %{name}-mod_simple_vhost
@@ -443,7 +481,7 @@ Ten moduł udostępnia wirtualne hosty (vhosty) oparte na tabeli MySQL.
 
 %package mod_proxy
 Summary:       lighttpd module for proxying requests
-Summary(pl.UTF-8):   Moduł lighttpd do przekazywania żądań
+Summary(pl.UTF-8):     Moduł lighttpd do przekazywania żądań
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -457,7 +495,7 @@ mającymi interfejs HTTP.
 
 %package mod_proxy_core
 Summary:       lighttpd module for proxying requests
-Summary(pl.UTF-8):   Moduł lighttpd do przekazywania żądań
+Summary(pl.UTF-8):     Moduł lighttpd do przekazywania żądań
 Group:         Networking/Daemons
 URL:           http://blog.lighttpd.net/articles/2006/07/18/mod_proxy_core-commited-to-svn
 Requires:      %{name} = %{version}-%{release}
@@ -476,7 +514,7 @@ Ten pakiet zawiera nowy moduł proxy.
 
 %package mod_redirect
 Summary:       lighttpd module for URL redirects
-Summary(pl.UTF-8):   Moduł lighttpd do przekierowań URL-i
+Summary(pl.UTF-8):     Moduł lighttpd do przekierowań URL-i
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -489,7 +527,7 @@ zewnątrz.
 
 %package mod_rewrite
 Summary:       lighttpd module for internal redirects, URL rewrite
-Summary(pl.UTF-8):   Moduł lighttpd do wewnętrznych przekierowań i przepisywania URL-i
+Summary(pl.UTF-8):     Moduł lighttpd do wewnętrznych przekierowań i przepisywania URL-i
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -503,7 +541,7 @@ WWW _przed_ ich obsługą.
 
 %package mod_rrdtool
 Summary:       lighttpd module for monitoring traffic and server load
-Summary(pl.UTF-8):   Moduł lighttpd do monitorowania ruchu i obciążenia serwera
+Summary(pl.UTF-8):     Moduł lighttpd do monitorowania ruchu i obciążenia serwera
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      rrdtool
@@ -525,7 +563,7 @@ WWW.
 
 %package mod_scgi
 Summary:       lighttpd module for SCGI interface
-Summary(pl.UTF-8):   Moduł lighttpd do interfejsu SCGI
+Summary(pl.UTF-8):     Moduł lighttpd do interfejsu SCGI
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -539,7 +577,7 @@ Pythona z WSGI.
 
 %package mod_secdownload
 Summary:       lighttpd module for secure and fast downloading
-Summary(pl.UTF-8):   Moduł lighttpd do bezpiecznego i szybkiego ściągania danych
+Summary(pl.UTF-8):     Moduł lighttpd do bezpiecznego i szybkiego ściągania danych
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -553,9 +591,10 @@ uwierzytelnieniem i zapobiec używaniu bezpośrednich odnośników.
 
 %package mod_setenv
 Summary:       lighttpd module for setting conditional request headers
-Summary(pl.UTF-8):   Moduł lighttpd do ustawiania warunkowych nagłówków żądań
+Summary(pl.UTF-8):     Moduł lighttpd do ustawiania warunkowych nagłówków żądań
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
+Provides:      webserver(setenv)
 
 %description mod_setenv
 mod_setenv is used to add request headers.
@@ -565,7 +604,7 @@ mod_setenv służy do dodawania nagłówków żądań.
 
 %package mod_simple_vhost
 Summary:       lighttpd module for simple virtual-hosting
-Summary(pl.UTF-8):   Moduł lighttpd do prostych hostów wirtualnych
+Summary(pl.UTF-8):     Moduł lighttpd do prostych hostów wirtualnych
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Conflicts:     %{name}-mod_mysql_vhost
@@ -578,7 +617,7 @@ Moduł lighttpd do prostych hostów wirtualnych.
 
 %package mod_ssi
 Summary:       lighttpd module for server-side includes
-Summary(pl.UTF-8):   Moduł lighttpd do SSI (server-side includes)
+Summary(pl.UTF-8):     Moduł lighttpd do SSI (server-side includes)
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -592,7 +631,7 @@ znanym z NSCA/Apache'a.
 
 %package mod_staticfile
 Summary:       lighttpd module for static file serving
-Summary(pl.UTF-8):   Moduł lighttpd do serwowania statycznych plików
+Summary(pl.UTF-8):     Moduł lighttpd do serwowania statycznych plików
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -604,7 +643,7 @@ Moduł lighttpd do serwowania statycznych plików.
 
 %package mod_status
 Summary:       lighttpd module for displaying server status
-Summary(pl.UTF-8):   Moduł lighttpd do wyświetlania stanu serwera
+Summary(pl.UTF-8):     Moduł lighttpd do wyświetlania stanu serwera
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -616,7 +655,7 @@ mod_status wyświetla stan i konfigurację serwera.
 
 %package mod_trigger_b4_dl
 Summary:       Trigger before Download
-Summary(pl.UTF-8):   Wyzwalacz przed ściąganiem
+Summary(pl.UTF-8):     Wyzwalacz przed ściąganiem
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -628,7 +667,7 @@ Jeszcze jeden moduł blokujący bezpośrednie linkowanie.
 
 %package mod_userdir
 Summary:       lighttpd module for user homedirs
-Summary(pl.UTF-8):   Moduł lighttpd obsługujący katalogi domowe użytkowników
+Summary(pl.UTF-8):     Moduł lighttpd obsługujący katalogi domowe użytkowników
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -642,7 +681,7 @@ użytkowników do globalnej przestrzeni nazw serwera WWW.
 
 %package mod_usertrack
 Summary:       lighttpd usertrack module
-Summary(pl.UTF-8):   Moduł usertrack dla lighttpd
+Summary(pl.UTF-8):     Moduł usertrack dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -654,7 +693,7 @@ Moduł usertrack dla lighttpd.
 
 %package mod_webdav
 Summary:       WebDAV module for lighttpd
-Summary(pl.UTF-8):   Moduł WebDAV dla libghttpd
+Summary(pl.UTF-8):     Moduł WebDAV dla libghttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -685,6 +724,7 @@ zaimplementowane. Jak na razie są:
 - DELETE
 - PUT
 - LOCK (experimental)
+
 oraz zwykłe GET, POST, HEAD z HTTP/1.1.
 
 Jak na razie montowanie zasobu webdav pod Windows XP działa i
@@ -692,7 +732,7 @@ podstawowe testy lakmusowe przechodzą.
 
 %package -n spawn-fcgi
 Summary:       Spawn fcgi-process directly
-Summary(pl.UTF-8):   Bezpośrednie uruchamianie procesów fcgi
+Summary(pl.UTF-8):     Bezpośrednie uruchamianie procesów fcgi
 Group:         Applications
 
 %description -n spawn-fcgi
@@ -705,7 +745,7 @@ pomocy serwera WWW ani samego programu.
 
 %package php-spawned
 Summary:       PHP support via FastCGI, spawned by lighttpd
-Summary(pl.UTF-8):   Obsługa PHP przez FastCGI, uruchamiane przez lighttpd
+Summary(pl.UTF-8):     Obsługa PHP przez FastCGI, uruchamiane przez lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      %{name}-mod_fastcgi = %{version}-%{release}
@@ -720,7 +760,7 @@ Obsługa PHP przez FastCGI, uruchamiane przez lighttpd.
 
 %package php-external
 Summary:       PHP support via FastCGI, spawning controlled externally
-Summary(pl.UTF-8):   Obsługa PHP przez FastCGI, uruchamianie sterowane zewnętrznie
+Summary(pl.UTF-8):     Obsługa PHP przez FastCGI, uruchamianie sterowane zewnętrznie
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      %{name}-mod_fastcgi = %{version}-%{release}
@@ -735,7 +775,7 @@ Obsługa PHP przez FastCGI, uruchamianie sterowane zewnętrznie.
 
 %package ssl
 Summary:       lighttpd support for SSLv2 and SSLv3
-Summary(pl.UTF-8):   Obsługa SSLv2 i SSLv3 dla lighttpd
+Summary(pl.UTF-8):     Obsługa SSLv2 i SSLv3 dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -745,13 +785,29 @@ lighttpd support for SSLv2 and SSLv3.
 %description ssl -l pl.UTF-8
 Obsługa SSLv2 i SSLv3 dla lighttpd.
 
+%package -n monit-rc-lighttpd
+Summary:       lighttpd support for monit
+Summary(pl.UTF-8):     Wsparcie lighttpd dla monit
+Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
+Requires:      monit
+
+%description -n monit-rc-lighttpd
+monitrc file for monitoring lighttpd web server.
+
+%description -n monit-rc-lighttpd -l pl.UTF-8
+Plik monitrc do monitorowania serwera www lighttpd.
+
 %prep
 %setup -q
-#%patch100 -p1
+%patch100 -p0
+%patch4 -p0
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 %patch3 -p1
-%patch4 -p1
+
+rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
 # build mime.types.conf
 sh %{SOURCE6} /etc/mime.types
@@ -778,15 +834,17 @@ sh %{SOURCE6} /etc/mime.types
        %{?with_gamin:--with-gamin} \
        %{?with_gdbm:--with-gdbm}
 
-%{__make}
+# -j1 as src/mod_ssi_exprparser.h regeneration deps are broken
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig,monit}} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{conf,webapps}.d \
-       $RPM_BUILD_ROOT{/var/log/{%{name},archiv/%{name}},/var/run/%{name}} \
+       $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}} \
        $RPM_BUILD_ROOT%{_datadir}/lighttpd/errordocs \
-       $RPM_BUILD_ROOT/var/lib/lighttpd
+       $RPM_BUILD_ROOT/var/lib/lighttpd \
+       $RPM_BUILD_ROOT/var/cache/lighttpd/mod_compress
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -818,6 +876,7 @@ install %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_access.conf
 install %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_alias.conf
 install %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_auth.conf
 install %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi.conf
+install %{SOURCE137} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi_php.conf
 install %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cml.conf
 install %{SOURCE106} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_compress.conf
 install %{SOURCE107} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_deflate.conf
@@ -825,9 +884,10 @@ install %{SOURCE108} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_dirlisting.conf
 install %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
 install %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
 install %{SOURCE111} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_expire.conf
-install %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_extforward.conf
+install %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/91_mod_extforward.conf
 install %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
 install %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
+install %{SOURCE136} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_h264_streaming.conf
 install %{SOURCE114} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_indexfile.conf
 install %{SOURCE134} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_magnet.conf
 install %{SOURCE115} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_proxy.conf
@@ -943,6 +1003,7 @@ fi
 %module_scripts mod_extforward
 %module_scripts mod_fastcgi
 %module_scripts mod_flv_streaming
+%module_scripts mod_h264_streaming
 %module_scripts mod_indexfile
 %module_scripts mod_magnet
 %module_scripts mod_mysql_vhost
@@ -976,11 +1037,11 @@ fi
 %module_scripts php-spawned
 %module_scripts php-external
 
-%triggerpostun -- %{name} <= 1.3.6-2
-%banner %{name} -e <<EOF
-spawn-fcgi program is now available separately from spawn-fcgi package.
-
-EOF
+%triggerpostun -- %{name} < 1.4.18-10.1
+if [ -f /etc/lighttpd/conf.d/50_mod_extforward.conf.rpmsave ]; then
+       cp -f /etc/lighttpd/conf.d/91_mod_extforward.conf{,.rpmnew}
+       mv -f /etc/lighttpd/conf.d/{50_mod_extforward.conf.rpmsave,91_mod_extforward.conf}
+fi
 
 %files
 %defattr(644,root,root,755)
@@ -993,15 +1054,15 @@ EOF
 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.user
 
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
-%attr(750,root,root) %dir /var/log/archiv/%{name}
+%attr(750,root,root) %dir /var/log/archive/%{name}
 %dir %attr(751,root,root) /var/log/%{name}
 %ghost %attr(644,lighttpd,lighttpd) /var/log/%{name}/access.log
 %ghost %attr(644,lighttpd,lighttpd) /var/log/%{name}/error.log
 %dir %attr(770,root,lighttpd) /var/run/%{name}
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
-%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_sbindir}/lighttpd
+%attr(755,root,root) %{_sbindir}/lighttpd-angel
 %dir %{_libdir}
 %{_mandir}/man?/*
 %dir %{_lighttpddir}
@@ -1015,6 +1076,9 @@ EOF
 # rrdtool database is stored there
 %dir %attr(771,root,lighttpd) /var/lib/lighttpd
 
+# mod_compress can put cached files there
+%dir /var/cache/lighttpd
+
 %files mod_access
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_access.conf
@@ -1040,6 +1104,10 @@ EOF
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi.conf
 %attr(755,root,root) %{_libdir}/mod_cgi.so
 
+%files mod_cgi_php
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi_php.conf
+
 %files mod_cml
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cml.conf
@@ -1049,6 +1117,7 @@ EOF
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_compress.conf
 %attr(755,root,root) %{_libdir}/mod_compress.so
+%dir %attr(775,root,lighttpd) /var/cache/lighttpd/mod_compress
 
 %if %{with deflate}
 %files mod_deflate
@@ -1092,6 +1161,11 @@ EOF
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_flv_streaming.conf
 %attr(755,root,root) %{_libdir}/mod_flv_streaming.so
 
+%files mod_h264_streaming
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_h264_streaming.conf
+%attr(755,root,root) %{_libdir}/mod_h264_streaming.so
+
 %files mod_indexfile
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_indexfile.conf
@@ -1201,3 +1275,7 @@ EOF
 %files ssl
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ssl.conf
+
+%files -n monit-rc-lighttpd
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.144345 seconds and 4 git commands to generate.