]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- add webserver(setenv)
[packages/lighttpd.git] / lighttpd.spec
index 593b9d4a21bb8c570cd2ae075fea858930da860d..f8d745bac5934240f85d509cbe6448d7c13d91e0 100644 (file)
@@ -1,5 +1,5 @@
 # TODO:
-# - test ldap and mysql (failed at this time)
+# - test mysql (failed at this time)
 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
 # - fam over gamin is possible, just configure doesn't check other than gamin
 # - feature stat-cache-fam (doesn't work)
@@ -17,7 +17,7 @@
 %bcond_without largefile       # largefile support (see notes above)
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost
-%bcond_with    ldap            # ldap support in mod_auth
+%bcond_without ldap            # ldap support in mod_auth
 %bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
 %define                webdav_progs    1
 %endif
 
-%define                _rel 5
+%define                rel 10
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.18
-Release:       %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
+Version:       1.4.19
+Release:       %{rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
 License:       BSD
 Group:         Networking/Daemons
 Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 26f98dddf9d8c0775221b800986003ee
+# Source0-md5: d787374e4e4aaa09d5cfa9ab9d23ad40
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -63,6 +63,7 @@ Source10:     http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
 # Source10-md5:        486ecec3f6f4fe7f9bf7cee757b864f4
 Source11:      %{name}-pld.html
 Source12:      %{name}.monitrc
+Source13:      %{name}-branch.sh
 Source100:     %{name}-mod_access.conf
 Source101:     %{name}-mod_accesslog.conf
 Source102:     %{name}-mod_alias.conf
@@ -99,11 +100,14 @@ Source132: %{name}-ssl.conf
 Source133:     %{name}-mod_mysql_vhost.conf
 Source134:     %{name}-mod_magnet.conf
 Source135:     %{name}-mod_extforward.conf
-Source136:     lighttpd-mod_h264_streaming.conf
+Source136:     %{name}-mod_h264_streaming.conf
+Source137:     %{name}-mod_cgi_php.conf
 Patch100:      %{name}-branch.diff
 Patch0:                %{name}-use_bin_sh.patch
 Patch1:                %{name}-mod_evasive-status_code.patch
 Patch2:                %{name}-mod_h264_streaming.patch
+Patch3:                %{name}-branding.patch
+Patch4:                %{name}-modinit-before-fork.patch
 #Patchx:       %{name}-mod_deflate.patch
 URL:           http://www.lighttpd.net/
 %{?with_xattr:BuildRequires:   attr-devel}
@@ -120,7 +124,7 @@ BuildRequires:      libuuid-devel
 %{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
-%{?with_ldap:BuildRequires:    openldap-devel >= 2.4.6}
+%{?with_ldap:BuildRequires:    openldap-devel}
 %{?with_ssl:BuildRequires:     openssl-devel}
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
@@ -137,9 +141,9 @@ Requires(pre):      /usr/lib/rpm/user_group.sh
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/sbin/usermod
-Requires:      %{name}-mod_dirlisting
-Requires:      %{name}-mod_indexfile
-Requires:      %{name}-mod_staticfile
+Requires:      %{name}-mod_dirlisting = %{version}-%{release}
+Requires:      %{name}-mod_indexfile = %{version}-%{release}
+Requires:      %{name}-mod_staticfile = %{version}-%{release}
 Requires:      rc-scripts
 Requires:      webapps
 Provides:      group(http)
@@ -251,6 +255,27 @@ Moduł cgi udostępnia interfejs zgodny z CGI.
 Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
 prosty i naturalny sposób.
 
+%package mod_cgi_php
+Summary:       lighttpd module for CGI handling PHP scripts
+Summary(pl.UTF-8):     Moduł lighttpd do obsługi skryptów PHP przez CGI
+Group:         Networking/Daemons
+Requires:      %{name}-mod_cgi = %{version}-%{release}
+Requires:      php(cgi)
+Provides:      webserver(php)
+
+%description mod_cgi_php
+The cgi module provides a CGI-conforming interface for PHP scripts.
+
+CGI programs allow you to enhance the functionality of the server in a
+very straight and simple way.
+
+%description mod_cgi_php -l pl.UTF-8
+Moduł cgi udostępnia interfejs zgodny z CGI do wywoływania skryptów
+PHP.
+
+Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
+prosty i naturalny sposób.
+
 %package mod_cml
 Summary:       lighttpd module for Cache Meta Language
 Summary(pl.UTF-8):     Moduł Cache Meta Language
@@ -569,6 +594,7 @@ Summary:    lighttpd module for setting conditional request headers
 Summary(pl.UTF-8):     Moduł lighttpd do ustawiania warunkowych nagłówków żądań
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
+Provides:      webserver(setenv)
 
 %description mod_setenv
 mod_setenv is used to add request headers.
@@ -698,6 +724,7 @@ zaimplementowane. Jak na razie są:
 - DELETE
 - PUT
 - LOCK (experimental)
+
 oraz zwykłe GET, POST, HEAD z HTTP/1.1.
 
 Jak na razie montowanie zasobu webdav pod Windows XP działa i
@@ -774,9 +801,13 @@ Plik monitrc do monitorowania serwera www lighttpd.
 %prep
 %setup -q
 %patch100 -p0
+%patch4 -p0
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+
+rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
 # build mime.types.conf
 sh %{SOURCE6} /etc/mime.types
@@ -803,7 +834,8 @@ sh %{SOURCE6} /etc/mime.types
        %{?with_gamin:--with-gamin} \
        %{?with_gdbm:--with-gdbm}
 
-%{__make}
+# -j1 as src/mod_ssi_exprparser.h regeneration deps are broken
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -844,6 +876,7 @@ install %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_access.conf
 install %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_alias.conf
 install %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_auth.conf
 install %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi.conf
+install %{SOURCE137} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi_php.conf
 install %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cml.conf
 install %{SOURCE106} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_compress.conf
 install %{SOURCE107} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_deflate.conf
@@ -851,7 +884,7 @@ install %{SOURCE108} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_dirlisting.conf
 install %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
 install %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
 install %{SOURCE111} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_expire.conf
-install %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_extforward.conf
+install %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/91_mod_extforward.conf
 install %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
 install %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
 install %{SOURCE136} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_h264_streaming.conf
@@ -1004,11 +1037,11 @@ fi
 %module_scripts php-spawned
 %module_scripts php-external
 
-%triggerpostun -- %{name} <= 1.3.6-2
-%banner %{name} -e <<EOF
-spawn-fcgi program is now available separately from spawn-fcgi package.
-
-EOF
+%triggerpostun -- %{name} < 1.4.18-10.1
+if [ -f /etc/lighttpd/conf.d/50_mod_extforward.conf.rpmsave ]; then
+       cp -f /etc/lighttpd/conf.d/91_mod_extforward.conf{,.rpmnew}
+       mv -f /etc/lighttpd/conf.d/{50_mod_extforward.conf.rpmsave,91_mod_extforward.conf}
+fi
 
 %files
 %defattr(644,root,root,755)
@@ -1028,7 +1061,8 @@ EOF
 %dir %attr(770,root,lighttpd) /var/run/%{name}
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
-%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_sbindir}/lighttpd
+%attr(755,root,root) %{_sbindir}/lighttpd-angel
 %dir %{_libdir}
 %{_mandir}/man?/*
 %dir %{_lighttpddir}
@@ -1070,6 +1104,10 @@ EOF
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi.conf
 %attr(755,root,root) %{_libdir}/mod_cgi.so
 
+%files mod_cgi_php
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi_php.conf
+
 %files mod_cml
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cml.conf
This page took 0.041233 seconds and 4 git commands to generate.