]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- reported upstream
[packages/lighttpd.git] / lighttpd.spec
index 4233921e390dd5907a4bbbd0047b8f3effd198fc..f31ecf85565049ec116259906875b3f00b29fda5 100644 (file)
@@ -4,7 +4,7 @@
 #   lighttpd-ssl server will still work
 #
 # Conditional build:
-%bcond_without tests           # build with tests
+%bcond_with            tests           # build with tests
 %bcond_without xattr           # support of extended attributes
 %bcond_without ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
 %bcond_without largefile       # largefile support (see notes above)
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.30
+Version:       1.4.32
 Release:       2
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       http://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.bz2
-# Source0-md5: 63f9df52dcae0ab5689a95c99c54e48a
+# Source0-md5: 8e2d4ae8e918d4de1aeb9842584d170b
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -53,6 +53,8 @@ Source12:     %{name}.monitrc
 Source13:      branch.sh
 Source14:      TODO
 Source15:      %{name}.upstart
+Source16:      %{name}.tmpfiles
+Source17:      %{name}.service
 Source100:     %{name}-mod_access.conf
 Source101:     %{name}-mod_accesslog.conf
 Source102:     %{name}-mod_alias.conf
@@ -98,12 +100,17 @@ Patch2:            %{name}-mod_h264_streaming.patch
 Patch3:                %{name}-branding.patch
 Patch5:                %{name}-mod_deflate.patch
 Patch6:                test-port-setup.patch
+Patch7:                %{name}-crypt.patch
 #Patch:                %{name}-modinit-before-fork.patch
 #Patch:                %{name}-errorlog-before-fork.patch
 URL:           http://www.lighttpd.net/
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf >= 2.57
+%if "%{pld_release}" != "ac"
+BuildRequires: automake >= 1:1.11.2
+%else
 BuildRequires: automake
+%endif
 BuildRequires: bzip2-devel
 BuildRequires: fcgi-devel
 %{?with_gamin:BuildRequires:   gamin-devel}
@@ -119,7 +126,8 @@ BuildRequires:      mailcap >= 2.1.14-4.4
 %{?with_ssl:BuildRequires:     openssl-devel}
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.647
 %{?with_webdav_props:BuildRequires:    sqlite3-devel}
 %{?with_valgrind:BuildRequires:        valgrind}
 BuildRequires: which
@@ -138,6 +146,7 @@ Requires:   %{name}-mod_indexfile = %{version}-%{release}
 Requires:      %{name}-mod_staticfile = %{version}-%{release}
 Requires:      rc-scripts >= 0.4.3.0
 Requires:      rpm-whiteout >= 1.5
+Requires:      systemd-units >= 38
 Suggests:      %{name}-mod_accesslog
 Provides:      group(http)
 Provides:      group(lighttpd)
@@ -828,6 +837,7 @@ Plik monitrc do monitorowania serwera www lighttpd.
 %patch3 -p1
 %{?with_deflate:%patch5 -p1}
 %patch6 -p1
+%patch7 -p1
 
 rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
@@ -848,8 +858,6 @@ fi
 %{__automake}
 
 %configure \
-       --enable-maintainer-mode \
-       --with-distribution="PLD Linux" \
        %{!?with_ipv6:--disable-ipv6} \
        %{!?with_largefile:--disable-lfs} \
        %{?with_valgrind:--with-valgrind} \
@@ -879,7 +887,8 @@ install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d
        $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}} \
        $RPM_BUILD_ROOT%{_datadir}/lighttpd/errordocs \
        $RPM_BUILD_ROOT/var/lib/lighttpd \
-       $RPM_BUILD_ROOT/var/cache/lighttpd/mod_compress
+       $RPM_BUILD_ROOT/var/cache/lighttpd/mod_compress \
+       $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -890,6 +899,8 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
 cp -p %{SOURCE15} $RPM_BUILD_ROOT/etc/init/%{name}.conf
+install %{SOURCE16} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
+install %{SOURCE17} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 
@@ -977,12 +988,14 @@ for a in access.log error.log breakage.log; do
        fi
 done
 /sbin/chkconfig --add %{name}
+%systemd_post %{name}.service
 
 %preun
 if [ "$1" = "0" ]; then
        %service %{name} stop
        /sbin/chkconfig --del %{name}
 fi
+%systemd_preun %{name}.service
 
 %postun
 if [ "$1" = "0" ]; then
@@ -990,6 +1003,7 @@ if [ "$1" = "0" ]; then
        %groupremove lighttpd
        %groupremove http
 fi
+%systemd_reload
 
 %posttrans
 # minimizing lighttpd restarts logics. we restart webserver:
@@ -1097,6 +1111,8 @@ fi
 %attr(644,lighttpd,lighttpd) %ghost /var/log/%{name}/error.log
 %attr(644,lighttpd,lighttpd) %ghost /var/log/%{name}/breakage.log
 %dir %attr(770,root,lighttpd) /var/run/%{name}
+%{systemdtmpfilesdir}/%{name}.conf
+%{systemdunitdir}/%{name}.service
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
 %attr(755,root,root) %{_sbindir}/lighttpd
This page took 0.088898 seconds and 4 git commands to generate.