]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- bcond corrected
[packages/lighttpd.git] / lighttpd.spec
index fbeef5a1b333a174b2a9f4f7d3ae634ae0498450..e13bb6ed94f1f9cb6584a57de337672b844ed032 100644 (file)
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost
 %bcond_with    ldap            # ldap support in mod_auth
-%bcond_with    lua             # LUA support in mod_cml (needs LUA >= 5.1)
+%bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
                                # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
 %bcond_with    gdbm            # gdbm in mod_trigger_b4_dl
 %bcond_with    webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
+%bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %bcond_with    deflate         # build deflate module (needs patch update with current svn)
 
 # Prerelease
 #define _snap r1332
 
-%define                _rel 1
+%if %{with webdav_locks}
+%define                webdav_progs    1
+%endif
+
+%define                _rel 2
 Summary:       Fast and light HTTP server
 Summary(pl):   Szybki i lekki serwer HTTP
 Name:          lighttpd
@@ -103,13 +108,14 @@ URL:              http://www.lighttpd.net/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
+%{?with_webdav_locks:BuildRequires:    e2fsprogs-devel}
 %{?with_gamin:BuildRequires:   gamin-devel}
 %{?with_gdbm:BuildRequires:    gdbm-devel}
 %{?with_memcache:BuildRequires:        libmemcache-devel}
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 %{?with_webdav_props:BuildRequires:    libxml2-devel}
-%{?with_lua:BuildRequires:     lua51-devel >= 5.1}
+%{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
@@ -631,6 +637,11 @@ Summary:   WebDAV module for lighttpd
 Summary(pl):   Modu³ WebDAV dla libghttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
+%{?with_webdav_locks:Requires: e2fsprogs}
+%if %{with webdav_progs}
+Requires:      libxml
+Requires:      sqlite
+%endif
 
 %description mod_webdav
 The WebDAV module is a very minimalistic implementation of RFC 2518.
@@ -642,6 +653,7 @@ So far we have
 - MKCOL
 - DELETE
 - PUT
+- LOCK (experimental)
 
 and the usual GET, POST, HEAD from HTTP/1.1.
 
@@ -657,6 +669,7 @@ zaimplementowane. Jak na razie s
 - MKCOL
 - DELETE
 - PUT
+- LOCK (experimental)
 oraz zwyk³e GET, POST, HEAD z HTTP/1.1.
 
 Jak na razie montowanie zasobu webdav pod Windows XP dzia³a i
@@ -741,9 +754,10 @@ sh %{SOURCE6} /etc/mime.types
        %{?with_mysql:--with-mysql} \
        %{?with_ldap:--with-ldap} \
        %{?with_ssl:--with-openssl} \
-       %{?with_lua:--with-lua} \
+       %{?with_lua:--with-lua=lua51} \
        %{?with_memcache:--with-memcache} \
        %{?with_webdav_props:--with-webdav-props} \
+       %{?with_webdav_locks:--with-webdav-locks} \
        %{?with_gamin:--with-gamin} \
        %{?with_gdbm:--with-gdbm}
 
@@ -930,6 +944,7 @@ EOF
 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
 %dir %attr(750,root,lighttpd) %{_sysconfdir}
 %dir %attr(750,root,root) %{_sysconfdir}/webapps.d
+%dir %attr(570,root,root) %{_sysconfdir}/lighttpd/conf.d
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.types.conf
 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.user
This page took 0.042947 seconds and 4 git commands to generate.