]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- bcond corrected
[packages/lighttpd.git] / lighttpd.spec
index 3379d2a2070d32d21f66b7b4018b8d0702b050d3..e13bb6ed94f1f9cb6584a57de337672b844ed032 100644 (file)
@@ -25,6 +25,7 @@
                                # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
 %bcond_with    gdbm            # gdbm in mod_trigger_b4_dl
 %bcond_with    webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
+%bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %bcond_with    deflate         # build deflate module (needs patch update with current svn)
 
 # Prerelease
 #define _snap r1332
 
-%define                _rel 0.66
+%if %{with webdav_locks}
+%define                webdav_progs    1
+%endif
+
+%define                _rel 2
 Summary:       Fast and light HTTP server
 Summary(pl):   Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.12
+Version:       1.4.13
 Release:       %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
 License:       BSD
 Group:         Networking/Daemons
 Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
-# Source0-md5: 8f6756452138f5da384251f849b329f2
+# Source0-md5: d775d6478391b95d841a1018c8db0b95
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -58,6 +63,7 @@ Source9:      http://www.lighttpd.net/light_logo.png
 Source10:      http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
 # Source10-md5:        486ecec3f6f4fe7f9bf7cee757b864f4
 Source11:      %{name}-pld.html
+Source12:      %{name}.monitrc
 Source100:     %{name}-mod_access.conf
 Source101:     %{name}-mod_accesslog.conf
 Source102:     %{name}-mod_alias.conf
@@ -94,23 +100,22 @@ Source132: %{name}-ssl.conf
 Source133:     %{name}-mod_mysql_vhost.conf
 Source134:     %{name}-mod_magnet.conf
 #Patch100: %{name}-branch.diff
-Patch0:                %{name}-mod_deflate.patch
-Patch1:                %{name}-use_bin_sh.patch
-Patch2:                %{name}-initgroups.patch
-Patch3:                http://trac.lighttpd.net/trac/attachment/ticket/444/%{name}-apr1.patch?format=txt
-Patch4:                %{name}-mod_evasive-status_code.patch
+Patch0:                %{name}-use_bin_sh.patch
+Patch1:                %{name}-mod_evasive-status_code.patch
+Patch2:                %{name}-mod_deflate.patch
 URL:           http://www.lighttpd.net/
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
+%{?with_webdav_locks:BuildRequires:    e2fsprogs-devel}
 %{?with_gamin:BuildRequires:   gamin-devel}
 %{?with_gdbm:BuildRequires:    gdbm-devel}
 %{?with_memcache:BuildRequires:        libmemcache-devel}
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 %{?with_webdav_props:BuildRequires:    libxml2-devel}
-%{?with_lua:BuildRequires:     lua50-devel >= 5.0.2-5.1}
+%{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
@@ -167,6 +172,7 @@ powodu problem
 
 %package mod_access
 Summary:       lighttpd module for making access restrictions
+Summary(pl):   Modu³ lighttpd ograniczaj±cy dostêp
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(access)
@@ -175,26 +181,40 @@ Provides: webserver(access)
 The access module is used to deny access to files with given trailing
 path names.
 
+%description mod_access -l pl
+Modu³ access s³u¿y do ograniczania dostêpu do plików o podanych
+¶cie¿kach.
+
 %package mod_accesslog
 Summary:       lighttpd module to record access logs
+Summary(pl):   Modu³ lighttpd do zapisu logów dostêpu
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_accesslog
 CLF like by default, flexible like Apache.
 
+%description mod_accesslog -l pl
+Domy¶lnie podobny do CLF, elastyczny jak Apache.
+
 %package mod_alias
-Summary:       lighttpd module for making url aliasing
+Summary:       lighttpd module for making URL aliasing
+Summary(pl):   Modu³ lighttpd odpowiadaj±cy za aliasy URL-i
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(alias)
 
 %description mod_alias
 The alias module is used to specify a special document-root for a
-given url-subset.
+given URL-subset.
+
+%description mod_alias -l pl
+Modul alias s³u¿y do okre¶lania specjalnego drzewa (document-roota)
+dla podanego podzbioru URL-i.
 
 %package mod_auth
 Summary:       lighttpd module for authentication support
+Summary(pl):   Modu³ lighttpd do obs³ugi uwierzytelniania
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(auth)
@@ -203,8 +223,13 @@ Provides:  webserver(auth)
 lighttpd supportes both authentication method described by RFC 2617:
 basic and digest.
 
+%description mod_auth -l pl
+lighttpd obs³uguje obie metody uwierzytelniania opisane w RFC 2617:
+basic i digest.
+
 %package mod_cgi
 Summary:       lighttpd module for CGI handling
+Summary(pl):   Modu³ lighttpd do obs³ugi CGI
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(cgi)
@@ -213,7 +238,13 @@ Provides:  webserver(cgi)
 The cgi module provides a CGI-conforming interface.
 
 CGI programs allow you to enhance the functionality of the server in a
-very straight and simple way...
+very straight and simple way.
+
+%description mod_cgi -l pl
+Modu³ cgi udostêpnia interfejs zgodny z CGI.
+
+Programy CGI pozwalaj± rozszerzaæ funkcjonalno¶æ serwera w bardzo
+prosty i naturalny sposób.
 
 %package mod_cml
 Summary:       lighttpd module for Cache Meta Language
@@ -232,7 +263,7 @@ z drugiej strony do budowania strony z fragment
 
 %package mod_compress
 Summary:       lighttpd module for output compression
-Summary(pl):   Kompresja wyj¶cia
+Summary(pl):   Modu³ lighttpd do kompresji wyj¶cia
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -255,8 +286,8 @@ Serwer automatycznie negocjuje, kt
 Obs³ugiwane s± gzip, deflate i bzip.
 
 %package mod_deflate
-Summary:       lighttpd module for output compression
-Summary(pl):   Kompresja wyj¶cia
+Summary:       lighttpd module for output compression using deflate method
+Summary(pl):   Modu³ lighttpd do kompresji wyj¶cia metod± deflate
 Group:         Networking/Daemons
 URL:           http://trac.lighttpd.net/trac/wiki/Mod_Deflate
 Requires:      %{name} = %{version}-%{release}
@@ -265,8 +296,14 @@ Requires:  %{name} = %{version}-%{release}
 mod_deflate can compress any output from lighttpd static or dynamic.
 It doesn't support caching compressed output like mod_compress.
 
+%description mod_deflate -l pl
+mod_deflate potrafi kompresowaæ statyczne i dynamiczne wyj¶cie z
+lighttpd. Nie obs³uguje cache'owania wyniku kompresji, jak robi to
+mod_compress.
+
 %package mod_dirlisting
 Summary:       lighttpd module for directory listings
+Summary(pl):   Modu³ lighttpd do tworzenia listingów katalogów
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -274,15 +311,25 @@ Requires: %{name} = %{version}-%{release}
 mod_dirlisting generates HTML based directory listings with full CSS
 control.
 
+%description mod_dirlisting -l pl
+mod_dirlisting tworzy listingi katalogów w formacie HTML z pe³n±
+kontrol± CSS.
+
 %package mod_evasive
 Summary:       lighttpd evasive module
+Summary(pl):   Modu³ evasive dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_evasive
+lighttpd evasive module.
+
+%description mod_evasive -l pl
+Modu³ evasive dla lighttpd.
 
 %package mod_evhost
 Summary:       lighttpd module for enhanced virtual-hosting
+Summary(pl):   Modu³ lighttpd rozszerzaj±cy obs³ugê hostów wirtualnych
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -291,16 +338,26 @@ mod_evhost builds the document-root based on a pattern which contains
 wildcards. Those wildcards can represent parts of the submitted
 hostname.
 
+%description mod_evhost -l pl
+mod_evhost tworzy document-root w oparciu o wzorzec zawieraj±cy znaki
+wieloznaczne (wildcards). Znaki te reprezentuj± czê¶ci przekazanej
+nazwy hosta.
+
 %package mod_expire
 Summary:       lighttpd module for controlling the expiration of content in caches
+Summary(pl):   Modu³ lighttpd steruj±cy wygasaniem tre¶ci w cache'ach
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_expire
 mod_expire controls the setting of the the Expire response header.
 
+%description mod_expire -l pl
+mod_expire steruje ustawianiem nag³ówka odpowiedzi Expire.
+
 %package mod_fastcgi
 Summary:       lighttpd module for FastCGI interface
+Summary(pl):   Modu³ lighttpd do interfejsu FastCGI
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -309,16 +366,26 @@ The FastCGI interface is the fastest and most secure way to interface
 external process-handlers like Perl, PHP and your self-written
 applications.
 
+%description mod_fastcgi -l pl
+Interfejs FastCGI to najszybszy i najbezpieczniejszy sposób
+komunikacji z zewnêtrznymi programami obs³uguj±cymi procesy, takimi
+jak Perl, PHP czy w³asne aplikacje.
+
 %package mod_flv_streaming
 Summary:       lighttpd module for flv streaming
+Summary(pl):   Modu³ lighttpd do streamingu flv
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_flv_streaming
 lighttpd module for flv streaming.
 
+%description mod_flv_streaming -l pl
+Modu³ lighttpd do streamingu flv.
+
 %package mod_indexfile
 Summary:       lighttpd indexfile module
+Summary(pl):   Modu³ indexfile dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Provides:      webserver(indexfile)
@@ -326,17 +393,24 @@ Provides: webserver(indexfile)
 %description mod_indexfile
 indexfile module.
 
+%description mod_indexfile -l pl
+Modu³ indexfile.
+
 %package mod_magnet
 Summary:       lighttpd powermagnet module
+Summary(pl):   Modu³ powermagnet dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_magnet
 mod_magnet is a module to control the request handling in lighty.
 
+%description mod_magnet -l pl
+mod_magnet to modu³ steruj±cy obs³ug± ¿±dañ w lighty.
+
 %package mod_mysql_vhost
 Summary:       lighttpd module for MySQL based vhosting
-Summary(pl):   vhosty oparte na MySQL-u
+Summary(pl):   Modu³ lighttpd obs³uguj±cy vhosty oparte na MySQL-u
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Conflicts:     %{name}-mod_simple_vhost
@@ -349,15 +423,21 @@ Ten modu
 
 %package mod_proxy
 Summary:       lighttpd module for proxying requests
+Summary(pl):   Modu³ lighttpd do przekazywania ¿±dañ
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_proxy
-The proxy module a simplest way to connect lighttpd to java servers
+The proxy module a simplest way to connect lighttpd to Java servers
 which have a HTTP-interface.
 
+%description mod_proxy -l pl
+Modu³ proxy to najprostszy sposób ³±czenia lighttpd z serwerami Javy
+maj±cymi interfejs HTTP.
+
 %package mod_proxy_core
 Summary:       lighttpd module for proxying requests
+Summary(pl):   Modu³ lighttpd do przekazywania ¿±dañ
 Group:         Networking/Daemons
 URL:           http://blog.lighttpd.net/articles/2006/07/18/mod_proxy_core-commited-to-svn
 Requires:      %{name} = %{version}-%{release}
@@ -368,16 +448,28 @@ which have a HTTP-interface.
 
 This is the new proxy code.
 
+%description mod_proxy_core -l pl
+Modu³ proxy to najprostszy sposób ³±czenia lighttpd z serwerami Javy
+maj±cymi interfejs HTTP.
+
+Ten pakiet zawiera nowy modu³ proxy.
+
 %package mod_redirect
 Summary:       lighttpd module for URL redirects
+Summary(pl):   Modu³ lighttpd do przekierowañ URL-i
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_redirect
-With mod_redirect module you can redirects a set of URLs externally.
+With mod_redirect module you can redirect a set of URLs externally.
+
+%description mod_redirect -l pl
+Przy u¿yciu modu³u mod_redirect mo¿na przekierowaæ zbiór URL-i na
+zewn±trz.
 
 %package mod_rewrite
 Summary:       lighttpd module for internal redirects, URL rewrite
+Summary(pl):   Modu³ lighttpd do wewnêtrznych przekierowañ i przepisywania URL-i
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -385,8 +477,13 @@ Requires:  %{name} = %{version}-%{release}
 This module allows you rewrite a set of URLs interally in the
 webserver BEFORE they are handled.
 
+%description mod_rewrite -l pl
+Ten modu³ pozwala na przepisywanie zbioru URL-i wewnêtrznie w serwerze
+WWW _przed_ ich obs³ug±.
+
 %package mod_rrdtool
 Summary:       lighttpd module for monitoring traffic and server load
+Summary(pl):   Modu³ lighttpd do monitorowania ruchu i obci±¿enia serwera
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      rrdtool
@@ -398,8 +495,17 @@ bandwidth, machine-room temperature, server load average).
 With this module you can monitor the traffic and load on the
 webserver.
 
+%description mod_rrdtool -l pl
+RRD to system przechowywania i wy¶wietlania danych zale¿nych od czasu
+(np. obci±¿enia sieci, temperatury w serwerowni, ¶redniego obci±¿enia
+serwera).
+
+Przy u¿yciu tego modu³u mo¿na monitorowaæ ruch i obci±¿enie serwera
+WWW.
+
 %package mod_scgi
 Summary:       lighttpd module for SCGI interface
+Summary(pl):   Modu³ lighttpd do interfejsu SCGI
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -407,8 +513,13 @@ Requires:  %{name} = %{version}-%{release}
 SCGI is a fast and simplified CGI interface. It is mostly used by
 Python + WSGI.
 
+%description mod_scgi -l pl
+SCGI to szybki i uproszczony interfejs CGI. Jest u¿ywany g³ównie przez
+Pythona z WSGI.
+
 %package mod_secdownload
 Summary:       lighttpd module for secure and fast downloading
+Summary(pl):   Modu³ lighttpd do bezpiecznego i szybkiego ¶ci±gania danych
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -416,16 +527,25 @@ Requires: %{name} = %{version}-%{release}
 With this module you can easily achieve authenticated file requests
 and a countermeasure against deep-linking.
 
+%description mod_secdownload -l pl
+Przy u¿yciu tego modu³u mo¿na ³atwo umo¿liwiæ ¶ci±ganie plików z
+uwierzytelnieniem i zapobiec u¿ywaniu bezpo¶rednich odno¶ników.
+
 %package mod_setenv
 Summary:       lighttpd module for setting conditional request headers
+Summary(pl):   Modu³ lighttpd do ustawiania warunkowych nag³ówków ¿±dañ
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_setenv
 mod_setenv is used to add request headers.
 
+%description mod_setenv -l pl
+mod_setenv s³u¿y do dodawania nag³ówków ¿±dañ.
+
 %package mod_simple_vhost
 Summary:       lighttpd module for simple virtual-hosting
+Summary(pl):   Modu³ lighttpd do prostych hostów wirtualnych
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Conflicts:     %{name}-mod_mysql_vhost
@@ -433,8 +553,12 @@ Conflicts: %{name}-mod_mysql_vhost
 %description mod_simple_vhost
 lighttpd module for simple virtual-hosting.
 
+%description mod_simple_vhost -l pl
+Modu³ lighttpd do prostych hostów wirtualnych.
+
 %package mod_ssi
 Summary:       lighttpd module for server-side includes
+Summary(pl):   Modu³ lighttpd do SSI (server-side includes)
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -442,22 +566,34 @@ Requires: %{name} = %{version}-%{release}
 The module for server-side includes provides a compatability layer for
 NSCA/Apache SSI.
 
+%description mod_ssi -l pl
+Modu³ server-side includes udostêpnia warstwê kompatybilno¶ci z SSI
+znanym z NSCA/Apache'a.
+
 %package mod_staticfile
 Summary:       lighttpd module for static file serving
+Summary(pl):   Modu³ lighttpd do serwowania statycznych plików
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_staticfile
 lighttpd module for static file serving.
 
+%description mod_staticfile -l pl
+Modu³ lighttpd do serwowania statycznych plików.
+
 %package mod_status
 Summary:       lighttpd module for displaying server status
+Summary(pl):   Modu³ lighttpd do wy¶wietlania stanu serwera
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_status
 mod_status displays the server's status and configuration.
 
+%description mod_status -l pl
+mod_status wy¶wietla stan i konfiguracjê serwera.
+
 %package mod_trigger_b4_dl
 Summary:       Trigger before Download
 Summary(pl):   Wyzwalacz przed ¶ci±ganiem
@@ -472,6 +608,7 @@ Jeszcze jeden modu
 
 %package mod_userdir
 Summary:       lighttpd module for user homedirs
+Summary(pl):   Modu³ lighttpd obs³uguj±cy katalogi domowe u¿ytkowników
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
@@ -479,18 +616,32 @@ Requires: %{name} = %{version}-%{release}
 The userdir module provides a simple way to link user-based
 directories into the global namespace of the webserver.
 
+%description mod_userdir -l pl
+Modu³ userdir udostêpnia prosty sposób w³±czenia katalogów
+u¿ytkowników do globalnej przestrzeni nazw serwera WWW.
+
 %package mod_usertrack
 Summary:       lighttpd usertrack module
+Summary(pl):   Modu³ usertrack dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description mod_usertrack
+lighttpd usertrack module.
+
+%description mod_usertrack -l pl
+Modu³ usertrack dla lighttpd.
 
 %package mod_webdav
 Summary:       WebDAV module for lighttpd
 Summary(pl):   Modu³ WebDAV dla libghttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
+%{?with_webdav_locks:Requires: e2fsprogs}
+%if %{with webdav_progs}
+Requires:      libxml
+Requires:      sqlite
+%endif
 
 %description mod_webdav
 The WebDAV module is a very minimalistic implementation of RFC 2518.
@@ -502,6 +653,7 @@ So far we have
 - MKCOL
 - DELETE
 - PUT
+- LOCK (experimental)
 
 and the usual GET, POST, HEAD from HTTP/1.1.
 
@@ -517,6 +669,7 @@ zaimplementowane. Jak na razie s
 - MKCOL
 - DELETE
 - PUT
+- LOCK (experimental)
 oraz zwyk³e GET, POST, HEAD z HTTP/1.1.
 
 Jak na razie montowanie zasobu webdav pod Windows XP dzia³a i
@@ -537,6 +690,7 @@ pomocy serwera WWW ani samego programu.
 
 %package php-spawned
 Summary:       PHP support via FastCGI, spawned by lighttpd
+Summary(pl):   Obs³uga PHP przez FastCGI, uruchamiane przez lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      %{name}-mod_fastcgi = %{version}-%{release}
@@ -544,10 +698,14 @@ Requires: php-fcgi
 Obsoletes:     lighttpd-php-external
 
 %description php-spawned
-PHP support via FastCGI, spawned by lighttpd
+PHP support via FastCGI, spawned by lighttpd.
+
+%description php-spawned -l pl
+Obs³uga PHP przez FastCGI, uruchamiane przez lighttpd.
 
 %package php-external
 Summary:       PHP support via FastCGI, spawning controlled externally
+Summary(pl):   Obs³uga PHP przez FastCGI, uruchamianie sterowane zewnêtrznie
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      %{name}-mod_fastcgi = %{version}-%{release}
@@ -555,24 +713,28 @@ Requires: php-fcgi-init
 Obsoletes:     lighttpd-php-spawned
 
 %description php-external
-PHP support via FastCGI, spawning controlled externally
+PHP support via FastCGI, spawning controlled externally.
+
+%description php-external -l pl
+Obs³uga PHP przez FastCGI, uruchamianie sterowane zewnêtrznie.
 
 %package ssl
 Summary:       lighttpd support for SSLv2 and SSLv3
+Summary(pl):   Obs³uga SSLv2 i SSLv3 dla lighttpd
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description ssl
 lighttpd support for SSLv2 and SSLv3.
 
+%description ssl -l pl
+Obs³uga SSLv2 i SSLv3 dla lighttpd.
+
 %prep
 %setup -q
 #%patch100 -p1
-#%patch0 -p1 # applied already?
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-#%patch3 -p1
-%patch4 -p0
 
 # build mime.types.conf
 sh %{SOURCE6} /etc/mime.types
@@ -584,6 +746,7 @@ sh %{SOURCE6} /etc/mime.types
 %{__automake}
 
 %configure \
+       --enable-maintainer-mode \
        %{!?with_ipv6:--disable-ipv6} \
        %{!?with_largefile:--disable-lfs} \
        %{?with_valgrind:--with-valgrind} \
@@ -591,9 +754,10 @@ sh %{SOURCE6} /etc/mime.types
        %{?with_mysql:--with-mysql} \
        %{?with_ldap:--with-ldap} \
        %{?with_ssl:--with-openssl} \
-       %{?with_lua:--with-lua} \
+       %{?with_lua:--with-lua=lua51} \
        %{?with_memcache:--with-memcache} \
        %{?with_webdav_props:--with-webdav-props} \
+       %{?with_webdav_locks:--with-webdav-locks} \
        %{?with_gamin:--with-gamin} \
        %{?with_gdbm:--with-gdbm}
 
@@ -601,7 +765,7 @@ sh %{SOURCE6} /etc/mime.types
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig}} \
+install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig,monit}} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{conf,webapps}.d \
        $RPM_BUILD_ROOT{/var/log/{%{name},archiv/%{name}},/var/run/%{name}}
 
@@ -612,6 +776,7 @@ install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 install %{SOURCE2} %{SOURCE3} mime.types.conf $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
+install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 
@@ -669,7 +834,6 @@ install %{SOURCE132} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/ssl.conf
 %if %{without mysql}
 # avoid packaging dummy module
 rm -f $RPM_BUILD_ROOT%{_libdir}/mod_mysql_vhost.so
-rm -f $RPM_BUILD_ROOT%{_libdir}/mod_sql_vhost_core.so
 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/*_mod_mysql_vhost.conf
 %endif
 %if %{without deflate}
@@ -780,11 +944,13 @@ EOF
 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
 %dir %attr(750,root,lighttpd) %{_sysconfdir}
 %dir %attr(750,root,root) %{_sysconfdir}/webapps.d
+%dir %attr(570,root,root) %{_sysconfdir}/lighttpd/conf.d
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.types.conf
 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.user
 
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
 %attr(750,root,root) %dir /var/log/archiv/%{name}
 %dir %attr(770,root,lighttpd) /var/log/%{name}
 %dir %attr(770,root,lighttpd) /var/run/%{name}
This page took 0.059414 seconds and 4 git commands to generate.