]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
- added webdav-locks
[packages/lighttpd.git] / lighttpd.spec
index 376728e5d064f869f07ae8c04d882d959d7fff79..b4863b16844e21dd1993911c71d81a1891bf5228 100644 (file)
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost
 %bcond_with    ldap            # ldap support in mod_auth
-%bcond_with    lua             # LUA support in mod_cml (needs LUA >= 5.1)
+%bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
                                # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
 %bcond_with    gdbm            # gdbm in mod_trigger_b4_dl
 %bcond_with    webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
+%bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %bcond_with    deflate         # build deflate module (needs patch update with current svn)
 
 # Prerelease
 #define _snap r1332
 
-%define                _rel 3
+%if %{with_webdav_locks}
+%define                webdav_progs    1
+%endif
+
+%define                _rel 2
 Summary:       Fast and light HTTP server
 Summary(pl):   Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.12
+Version:       1.4.13
 Release:       %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
 License:       BSD
 Group:         Networking/Daemons
 Source0:       http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
-# Source0-md5: 8f6756452138f5da384251f849b329f2
+# Source0-md5: d775d6478391b95d841a1018c8db0b95
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -95,24 +100,22 @@ Source132: %{name}-ssl.conf
 Source133:     %{name}-mod_mysql_vhost.conf
 Source134:     %{name}-mod_magnet.conf
 #Patch100: %{name}-branch.diff
-Patch0:                %{name}-mod_deflate.patch
-Patch1:                %{name}-use_bin_sh.patch
-Patch2:                %{name}-initgroups.patch
-# http://trac.lighttpd.net/trac/ticket/444
-Patch3:                %{name}-apr1.patch
-Patch4:                %{name}-mod_evasive-status_code.patch
+Patch0:                %{name}-use_bin_sh.patch
+Patch1:                %{name}-mod_evasive-status_code.patch
+Patch2:                %{name}-mod_deflate.patch
 URL:           http://www.lighttpd.net/
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
+%{?with_webdav_locks:BuildRequires:    e2fsprogs-devel}
 %{?with_gamin:BuildRequires:   gamin-devel}
 %{?with_gdbm:BuildRequires:    gdbm-devel}
 %{?with_memcache:BuildRequires:        libmemcache-devel}
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 %{?with_webdav_props:BuildRequires:    libxml2-devel}
-%{?with_lua:BuildRequires:     lua51-devel >= 5.1}
+%{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
@@ -132,6 +135,11 @@ Requires(pre):     /usr/lib/rpm/user_group.sh
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/sbin/usermod
+%{?with_webdav_locks:Requires: e2fsprogs}
+%if %{with webdav_progs}
+Requries:      libxml
+Requires:      sqlite
+%endif
 Requires:      %{name}-mod_dirlisting
 Requires:      %{name}-mod_indexfile
 Requires:      %{name}-mod_staticfile
@@ -645,6 +653,7 @@ So far we have
 - MKCOL
 - DELETE
 - PUT
+- LOCK (experimental)
 
 and the usual GET, POST, HEAD from HTTP/1.1.
 
@@ -660,6 +669,7 @@ zaimplementowane. Jak na razie s
 - MKCOL
 - DELETE
 - PUT
+- LOCK (experimental)
 oraz zwyk³e GET, POST, HEAD z HTTP/1.1.
 
 Jak na razie montowanie zasobu webdav pod Windows XP dzia³a i
@@ -723,11 +733,8 @@ Obs
 %prep
 %setup -q
 #%patch100 -p1
-#%patch0 -p1
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p0
 
 # build mime.types.conf
 sh %{SOURCE6} /etc/mime.types
@@ -747,9 +754,10 @@ sh %{SOURCE6} /etc/mime.types
        %{?with_mysql:--with-mysql} \
        %{?with_ldap:--with-ldap} \
        %{?with_ssl:--with-openssl} \
-       %{?with_lua:--with-lua} \
+       %{?with_lua:--with-lua=lua51} \
        %{?with_memcache:--with-memcache} \
        %{?with_webdav_props:--with-webdav-props} \
+       %{?with_webdav_locks:--with-webdav-locks} \
        %{?with_gamin:--with-gamin} \
        %{?with_gdbm:--with-gdbm}
 
This page took 0.093843 seconds and 4 git commands to generate.