]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
Add requires auth to authn modules
[packages/lighttpd.git] / lighttpd.spec
index f3fa1a89bcfd4aa1f20a44851dd6c45b4854e362..a54fa54e01ee26c8d847703a4eaf202732a9bf40 100644 (file)
@@ -7,48 +7,47 @@
 # - add db specific mod_vhostdb_* sub-packages
 # - package mod_sockproxy
 #   https://github.com/lighttpd/lighttpd1.4/commit/c4d743bb4d0cc045d41322169a4e36a151e247f1
+# - TLS library options
+#    - mod_openssl (existing)
+#    - mod_mbedtls (experimental)
+#    - mod_wolfssl (experimental)
+#    - mod_gnutls  (experimental)
+#    - mod_nss     (experimental)
 #
 # Conditional build:
 %bcond_with            tests           # build with tests
 %bcond_without xattr           # support of extended attributes
 %bcond_without ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
 %bcond_without largefile       # largefile support (see notes above)
-%bcond_without dbi             # libdbi, enables mod_vhostdb_dbi
+%bcond_without dbi             # libdbi, enables mod_vhostdb_dbi, mod_authn_dbi
 %bcond_without ssl             # ssl support
-%bcond_without mysql           # mysql support in mod_mysql_vhost, mod_vhostdb_mysql
+%bcond_without mysql           # mysql support in mod_vhostdb_mysql
 %bcond_without pgsql           # PgSQL, enables mod_vhostdb_pgsql
-%bcond_without geoip           # GeoIP support
+%bcond_without bzip2           # Enable bzip2 support for mod_deflate
+%bcond_without brotli          # Enable brotli support for mod_deflate
 %bcond_without maxminddb       # MaxMind GeoIP2 module
 %bcond_with    krb5            # krb5 support (does not work with heimdal)
 %bcond_without ldap            # ldap support in mod_auth, mod_vhostdb_ldap
-%bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
+%bcond_without lua             # LUA support (needs LUA >= 5.1)
 %bcond_with    gamin           # gamin for reducing number of stat() calls. must be enabled in config: server.stat-cache-engine = "fam"
-%bcond_without mod_trigger_b4_dl               # mod_trigger_b4_dl
 %bcond_with    webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
 %bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %bcond_with    h264_streaming          # build h264_streaming module
-%bcond_without storage_memcached       # memcached storage for mod_trigger_b4_dl/mod_cml
-%bcond_without storage_gdbm            # gdbm storage for mod_trigger_b4_dl
 
 %if %{with webdav_locks}
 %define                webdav_progs    1
 %endif
 
-# if(WITH_PCRE AND (WITH_MEMCACHED OR WITH_GDBM))
-%if %{without storage_memcached} && %{without storage_gdbm}
-%undefine      with_mod_trigger_b4_dl
-%endif
-
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.55
+Version:       1.4.66
 Release:       1
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       https://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
-# Source0-md5: be4bda2c28bcbdac6eb941528f6edf03
+# Source0-md5: 78b43d1dc36e1cf34d4003bc5e97a964
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -73,15 +72,14 @@ Source101:  mod_accesslog.conf
 Source102:     mod_alias.conf
 Source103:     mod_auth.conf
 Source104:     mod_cgi.conf
-Source105:     mod_cml.conf
-Source106:     mod_compress.conf
+
 Source107:     mod_deflate.conf
 Source108:     mod_dirlisting.conf
 Source109:     mod_evasive.conf
 Source110:     mod_evhost.conf
 Source111:     mod_expire.conf
 Source112:     mod_fastcgi.conf
-Source113:     mod_flv_streaming.conf
+
 Source114:     mod_indexfile.conf
 Source115:     mod_proxy.conf
 Source116:     mod_redirect.conf
@@ -94,26 +92,25 @@ Source122:  mod_simple_vhost.conf
 Source123:     mod_ssi.conf
 Source124:     mod_staticfile.conf
 Source125:     mod_status.conf
-Source126:     mod_trigger_b4_dl.conf
+
 Source127:     mod_userdir.conf
 Source128:     mod_usertrack.conf
 Source129:     mod_webdav.conf
 Source130:     php-spawned.conf
 Source131:     php-external.conf
 Source132:     ssl.conf
-Source133:     mod_mysql_vhost.conf
+
 Source134:     mod_magnet.conf
 Source135:     mod_extforward.conf
 Source136:     mod_h264_streaming.conf
 Source137:     mod_cgi_php.conf
-Source138:     mod_compress.tmpwatch
 Source139:     mod_uploadprogress.conf
-Source140:     mod_geoip.conf
+
 Source141:     mod_authn_ldap.conf
 Source142:     mod_openssl.conf
 Source143:     mod_vhostdb.conf
 Source144:     mod_wstunnel.conf
-Source145:     mod_authn_mysql.conf
+
 Source146:     mod_sockproxy.conf
 Source147:     mod_maxminddb.conf
 # use branch.sh script to create branch.diff
@@ -123,22 +120,21 @@ Patch1:           %{name}-mod_evasive-status_code.patch
 Patch2:                %{name}-mod_h264_streaming.patch
 Patch3:                %{name}-branding.patch
 Patch4:                systemd.patch
-Patch5:                test-port-setup.patch
 URL:           https://www.lighttpd.net/
-%{?with_geoip:BuildRequires:   GeoIP-devel}
-%{?with_maxminddb:BuildRequires:       libmaxminddb-devel}
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf >= 2.57
+%{?with_maxminddb:BuildRequires:       libmaxminddb-devel}
 %if "%{pld_release}" != "ac"
 BuildRequires: automake >= 1:1.11.2
 %else
 BuildRequires: automake
 %endif
-BuildRequires: bzip2-devel
+%{?with_bzip2:BuildRequires:   bzip2-devel}
 BuildRequires: fcgi-devel
 %{?with_gamin:BuildRequires:   gamin-devel}
 %{?with_storage_gdbm:BuildRequires:    gdbm-devel}
 %{?with_krb5:BuildRequires:    krb5-devel}
+%{?with_brotli:BuildRequires:  libbrotli-devel}
 %{?with_dbi:BuildRequires:     libdbi-devel}
 %{?with_storage_memcached:BuildRequires:       libmemcached-devel}
 BuildRequires: libtool
@@ -147,11 +143,11 @@ BuildRequires:    libuuid-devel
 %{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
-%{?with_pgsql:BuildRequires:   postgresql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 %{?with_ssl:BuildRequires:     openssl-devel}
-BuildRequires: pcre-devel
+BuildRequires: pcre2-8-devel
 BuildRequires: pkgconfig
+%{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.647
 %{?with_webdav_props:BuildRequires:    sqlite3-devel}
@@ -255,6 +251,16 @@ given URL-subset.
 Modul alias służy do określania specjalnego drzewa (document-roota)
 dla podanego podzbioru URL-i.
 
+%package mod_ajp13
+Summary:       Apache JServ Protocol version 1.3 (AJP13) gateway
+Group:         Networking/Daemons/HTTP
+URL:           https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModAJP13
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_ajp13
+lighttpd mod_ajp13 is a gateway implementing Apache JServ Protocol
+version 1.3 (AJP13).
+
 %package mod_auth
 Summary:       lighttpd module for authentication support
 Summary(pl.UTF-8):     Moduł lighttpd do obsługi uwierzytelniania
@@ -265,9 +271,6 @@ Requires:   %{name}-mod_authn_file = %{version}-%{release}
 %if %{with ldap}
 Suggests:      %{name}-mod_authn_ldap = %{version}-%{release}
 %endif
-%if %{with mysql}
-Suggests:      %{name}-mod_authn_mysql = %{version}-%{release}
-%endif
 Provides:      webserver(auth)
 
 %description mod_auth
@@ -278,10 +281,21 @@ basic and digest.
 lighttpd obsługuje obie metody uwierzytelniania opisane w RFC 2617:
 basic i digest.
 
+%package mod_authn_dbi
+Summary:       lighttpd authn_dbi module
+Group:         Networking/Daemons/HTTP
+URL:           https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModAuth
+Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-auth = %{version}-%{release}
+
+%description mod_authn_dbi
+lighttpd authn_dbi module.
+
 %package mod_authn_file
 Summary:       lighttpd authn_file module
 Group:         Networking/Daemons/HTTP
 Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-auth = %{version}-%{release}
 
 %description mod_authn_file
 lighttpd authn_file module.
@@ -290,6 +304,7 @@ lighttpd authn_file module.
 Summary:       lighttpd authn_gssapi module
 Group:         Networking/Daemons/HTTP
 Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-auth = %{version}-%{release}
 
 %description mod_authn_gssapi
 lighttpd authn_gssapi module.
@@ -298,18 +313,11 @@ lighttpd authn_gssapi module.
 Summary:       lighttpd authn_ldap module
 Group:         Networking/Daemons/HTTP
 Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-auth = %{version}-%{release}
 
 %description mod_authn_ldap
 lighttpd authn_ldap module.
 
-%package mod_authn_mysql
-Summary:       lighttpd authn_mysql module
-Group:         Networking/Daemons/HTTP
-Requires:      %{name} = %{version}-%{release}
-
-%description mod_authn_mysql
-lighttpd authn_mysql module.
-
 %package mod_cgi
 Summary:       lighttpd module for CGI handling
 Summary(pl.UTF-8):     Moduł lighttpd do obsługi CGI
@@ -352,22 +360,6 @@ PHP.
 Programy CGI pozwalają rozszerzać funkcjonalność serwera w bardzo
 prosty i naturalny sposób.
 
-%package mod_cml
-Summary:       lighttpd module for Cache Meta Language
-Summary(pl.UTF-8):     Moduł Cache Meta Language
-Group:         Networking/Daemons/HTTP
-URL:           http://redmine.lighttpd.net/projects/lighttpd/wiki/Docs:ModCML
-Requires:      %{name} = %{version}-%{release}
-
-%description mod_cml
-CML is a Meta language to describe the dependencies of a page at one
-side and building a page from its fragments on the other side using
-LUA.
-
-%description mod_cml -l pl.UTF-8
-CML to metajęzyk służący z jednej strony do opisu zależności strony i
-z drugiej strony do budowania strony z fragmentów przy użyciu LUA.
-
 %package mod_compress
 Summary:       lighttpd module for output compression
 Summary(pl.UTF-8):     Moduł lighttpd do kompresji wyjścia
@@ -384,6 +376,11 @@ Only static content is supported up to now.
 The server negotiates automatically which compression method is used.
 Supported are gzip, deflate, bzip.
 
+mod_compress is DEPRECATED; use mod_deflate. mod_compress has been
+subsumed by mod_deflate.
+
+Note: mod_compress config options may be removed in a future release.
+
 %description mod_compress -l pl.UTF-8
 Kompresja wyjścia zmniejsza obciążenie sieci i może poprawić całkowitą
 przepustowość serwera WWW.
@@ -397,12 +394,32 @@ Obsługiwane są gzip, deflate i bzip.
 Summary:       lighttpd module for output compression using deflate method
 Summary(pl.UTF-8):     Moduł lighttpd do kompresji wyjścia metodą deflate
 Group:         Networking/Daemons/HTTP
-URL:           http://redmine.lighttpd.net/projects/lighttpd/wiki/Mod_Deflate
+URL:           https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModDeflate
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     lighttpd-mod_compress < 1.4.56
+
+%define        _deflate_encodings deflate gzip %{?with_bzip2:bzip2} %{?with_brotli:brotli}
+%define        deflate_encodings %(echo %_deflate_encodings | sed -e 's/ /, /g')
 
 %description mod_deflate
-mod_deflate can compress any output from lighttpd static or dynamic.
-It doesn't support caching compressed output like mod_compress.
+mod_deflate enables output compression of responses
+(Content-Encoding).
+
+Output compression reduces the network load and can improve the
+overall throughput of the webserver. All major http-clients support
+compression by announcing it in the Accept-Encoding header. This is
+used to negotiate the most suitable compression method.
+
+This module supports %{deflate_encodings} encodings.
+
+deflate (RFC1950, RFC1951) and gzip (RFC1952) depend on zlib while
+bzip2 depends on libbzip2. bzip2 is only supported by lynx and some
+other console text-browsers. brotli (RFC7932) is supported in most
+popular browsers.
+
+Since lighttpd 1.4.56, mod_deflate subsumes and replaces mod_compress.
+mod_deflate can compress static and dynamic responses, while
+mod_compress could compress only static files.
 
 %description mod_deflate -l pl.UTF-8
 mod_deflate potrafi kompresować statyczne i dynamiczne wyjście z
@@ -502,33 +519,6 @@ Interfejs FastCGI to najszybszy i najbezpieczniejszy sposób
 komunikacji z zewnętrznymi programami obsługującymi procesy, takimi
 jak Perl, PHP czy własne aplikacje.
 
-%package mod_flv_streaming
-Summary:       lighttpd module for flv streaming
-Summary(pl.UTF-8):     Moduł lighttpd do streamingu flv
-Group:         Networking/Daemons/HTTP
-URL:           http://redmine.lighttpd.net/projects/lighttpd/wiki/Docs:ModFLVStreaming
-Requires:      %{name} = %{version}-%{release}
-
-%description mod_flv_streaming
-lighttpd module for flv streaming.
-
-%description mod_flv_streaming -l pl.UTF-8
-Moduł lighttpd do streamingu flv.
-
-%package mod_geoip
-Summary:       lighttpd module for IP Based Geographic Lookups
-Group:         Networking/Daemons/HTTP
-URL:           https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModGeoip
-Requires:      %{name} = %{version}-%{release}
-
-%description mod_geoip
-mod_geoip is a module for fast ip/location lookups. It uses MaxMind
-GeoIP / GeoCity databases.
-
-If the ip was found in the database the module sets the appropriate
-environment variables to the request, thus making other modules/fcgi
-be informed.
-
 %package mod_h264_streaming
 Summary:       lighttpd module for h264 streaming
 Summary(pl.UTF-8):     Moduł lighttpd do emisji strumieni h264
@@ -578,20 +568,6 @@ Requires:  %{name} = %{version}-%{release}
 
 %description mod_maxminddb
 
-%package mod_mysql_vhost
-Summary:       lighttpd module for MySQL based vhosting
-Summary(pl.UTF-8):     Moduł lighttpd obsługujący vhosty oparte na MySQL-u
-Group:         Networking/Daemons/HTTP
-URL:           http://redmine.lighttpd.net/projects/lighttpd/wiki/Docs:ModMySQLVhost
-Requires:      %{name} = %{version}-%{release}
-Conflicts:     %{name}-mod_simple_vhost
-
-%description mod_mysql_vhost
-This module provides virtual hosts (vhosts) based on a MySQL table.
-
-%description mod_mysql_vhost -l pl.UTF-8
-Ten moduł udostępnia wirtualne hosty (vhosty) oparte na tabeli MySQL.
-
 %package mod_openssl
 Summary:       TLS/SSL for lighttpd
 Group:         Networking/Daemons/HTTP
@@ -797,19 +773,6 @@ mod_status displays the server's status and configuration.
 %description mod_status -l pl.UTF-8
 mod_status wyświetla stan i konfigurację serwera.
 
-%package mod_trigger_b4_dl
-Summary:       Trigger before Download
-Summary(pl.UTF-8):     Wyzwalacz przed ściąganiem
-Group:         Networking/Daemons/HTTP
-URL:           http://redmine.lighttpd.net/projects/lighttpd/wiki/Docs:ModTriggerBeforeDownload
-Requires:      %{name} = %{version}-%{release}
-
-%description mod_trigger_b4_dl
-Another anti hot-linking module.
-
-%description mod_trigger_b4_dl -l pl.UTF-8
-Jeszcze jeden moduł blokujący bezpośrednie linkowanie.
-
 %package mod_uploadprogress
 Summary:       lighttpd module for upload progress
 Group:         Networking/Daemons/HTTP
@@ -975,7 +938,6 @@ Plik monitrc do monitorowania serwera www lighttpd.
 %{?with_h264_streaming:%patch2 -p1}
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 
 rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
@@ -989,7 +951,7 @@ cp -p %{SOURCE14} PLD-TODO
 %endif
 
 %build
-ver=$(awk '/AC_INIT/{a=$2;gsub(/[\[\],]/, "", a); print a}' configure.ac)
+ver=$(awk -F ',' '/AC_INIT/{a=$2;gsub(/[\[\],]/, "", a); print a}' configure.ac)
 if [ "$ver" != "%{version}" ]; then
        : configure.ac specifies wrong version
        exit 1
@@ -1002,25 +964,24 @@ fi
 %{__automake}
 
 %configure \
-       --libdir=%{pkglibdir} \
        %{!?with_ipv6:--disable-ipv6} \
        %{!?with_largefile:--disable-lfs} \
-       %{?with_valgrind:--with-valgrind} \
-       %{?with_xattr:--with-attr} \
+       %{?with_brotli:--with-brotli} \
+       %{?with_bzip2:--with-bzip2} \
        %{?with_dbi:--with-dbi} \
+       %{?with_gamin:--with-gamin} \
        %{?with_krb5:--with-krb5} \
-       %{?with_geoip:--with-geoip} \
+       %{?with_ldap:--with-ldap} \
+       %{?with_lua:--with-lua=lua51} \
        %{?with_maxminddb:--with-maxminddb} \
        %{?with_mysql:--with-mysql} \
-       %{?with_ldap:--with-ldap} \
-       %{?with_ssl:--with-openssl} \
        %{?with_pgsql:--with-pgsql} \
-       %{?with_lua:--with-lua=lua51} \
-       %{?with_storage_memcached:--with-memcached} \
-       %{?with_webdav_props:--with-webdav-props} \
+       %{?with_ssl:--with-openssl} \
+       %{?with_valgrind:--with-valgrind} \
        %{?with_webdav_locks:--with-webdav-locks} \
-       %{?with_gamin:--with-gamin} \
-       %{?with_storage_gdbm:--with-gdbm}
+       %{?with_webdav_props:--with-webdav-props} \
+       %{?with_xattr:--with-attr} \
+       --libdir=%{pkglibdir}
 
 # -j1 as src/mod_ssi_exprparser.h regeneration deps are broken
 %{__make} -j1
@@ -1037,7 +998,6 @@ install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d
        $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}} \
        $RPM_BUILD_ROOT%{_datadir}/lighttpd/errordocs \
        $RPM_BUILD_ROOT/var/lib/lighttpd \
-       $RPM_BUILD_ROOT/var/cache/lighttpd/mod_compress \
        $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir}}
 
 %{__make} install \
@@ -1073,25 +1033,18 @@ cp -p %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_alias.conf
 cp -p %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_auth.conf
 cp -p %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi.conf
 cp -p %{SOURCE137} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi_php.conf
-cp -p %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cml.conf
+
 cp -p %{SOURCE107} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_deflate.conf
 cp -p %{SOURCE108} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_dirlisting.conf
 cp -p %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
 cp -p %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
 cp -p %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
-cp -p %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
-%if %{with geoip}
-cp -p %{SOURCE140} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_geoip.conf
-%endif
 %if %{with maxminddb}
 cp -p %{SOURCE147} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_maxminddb.conf
 %endif
 %if %{with ldap}
 cp -p %{SOURCE141} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_authn_ldap.conf
 %endif
-%if %{with ldap}
-cp -p %{SOURCE145} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_authn_mysql.conf
-%endif
 %if %{with h264_streaming}
 cp -p %{SOURCE136} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_h264_streaming.conf
 %endif
@@ -1106,25 +1059,17 @@ cp -p %{SOURCE122} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_simple_vhost.conf
 cp -p %{SOURCE123} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_ssi.conf
 cp -p %{SOURCE124} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_staticfile.conf
 cp -p %{SOURCE125} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_status.conf
-%if %{with mod_trigger_b4_dl}
-cp -p %{SOURCE126} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_trigger_b4_dl.conf
-%endif
 cp -p %{SOURCE139} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_uploadprogress.conf
 cp -p %{SOURCE127} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_userdir.conf
 cp -p %{SOURCE128} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_usertrack.conf
 cp -p %{SOURCE143} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_vhostdb.conf
 cp -p %{SOURCE129} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_webdav.conf
 cp -p %{SOURCE144} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_wstunnel.conf
-%if %{with mysql}
-cp -p %{SOURCE133} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_mysql_vhost.conf
-%endif
 cp -p %{SOURCE146} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_sockproxy.conf
 
 cp -p %{SOURCE134} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/55_mod_magnet.conf
 cp -p %{SOURCE111} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/55_mod_expire.conf
 
-cp -p %{SOURCE106} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/60_mod_compress.conf
-
 cp -p %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_accesslog.conf
 cp -p %{SOURCE135} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/91_mod_extforward.conf
 
@@ -1135,7 +1080,6 @@ cp -p %{SOURCE132} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/ssl.conf
 touch $RPM_BUILD_ROOT/var/lib/lighttpd/lighttpd.rrd
 
 install -d $RPM_BUILD_ROOT/etc/tmpwatch
-cp -p %{SOURCE138} $RPM_BUILD_ROOT/etc/tmpwatch/lighttpd-mod_compress.conf
 
 touch $RPM_BUILD_ROOT/var/log/%{name}/{access,error,breakage}.log
 
@@ -1208,15 +1152,14 @@ fi
 
 %module_scripts mod_access
 %module_scripts mod_accesslog
+%module_scripts mod_ajp13
 %module_scripts mod_alias
 %module_scripts mod_auth
+%module_scripts mod_authn_dbi
 %module_scripts mod_authn_file
 %module_scripts mod_authn_gssapi
 %module_scripts mod_authn_ldap
-%module_scripts mod_authn_mysql
 %module_scripts mod_cgi
-%module_scripts mod_cml
-%module_scripts mod_compress
 %module_scripts mod_deflate
 %module_scripts mod_dirlisting
 %module_scripts mod_evasive
@@ -1224,13 +1167,10 @@ fi
 %module_scripts mod_expire
 %module_scripts mod_extforward
 %module_scripts mod_fastcgi
-%module_scripts mod_flv_streaming
-%module_scripts mod_geoip
 %module_scripts mod_h264_streaming
 %module_scripts mod_indexfile
 %module_scripts mod_magnet
 %module_scripts mod_maxminddb
-%module_scripts mod_mysql_vhost
 %module_scripts mod_openssl
 %module_scripts mod_proxy
 %module_scripts mod_redirect
@@ -1243,7 +1183,6 @@ fi
 %module_scripts mod_ssi
 %module_scripts mod_staticfile
 %module_scripts mod_status
-%module_scripts mod_trigger_b4_dl
 %module_scripts mod_uploadprogress
 %module_scripts mod_userdir
 %module_scripts mod_usertrack
@@ -1313,9 +1252,6 @@ fi
 # rrdtool database is stored there
 %dir %attr(771,root,lighttpd) /var/lib/lighttpd
 
-# mod_compress can put cached files there
-%dir /var/cache/lighttpd
-
 %files mod_access
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_access.conf
@@ -1331,11 +1267,21 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_alias.conf
 %attr(755,root,root) %{pkglibdir}/mod_alias.so
 
+%files mod_ajp13
+%defattr(644,root,root,755)
+%attr(755,root,root) %{pkglibdir}/mod_ajp13.so
+
 %files mod_auth
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_auth.conf
 %attr(755,root,root) %{pkglibdir}/mod_auth.so
 
+%if %{with dbi}
+%files mod_authn_dbi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{pkglibdir}/mod_authn_dbi.so
+%endif
+
 %files mod_authn_file
 %defattr(644,root,root,755)
 %attr(755,root,root) %{pkglibdir}/mod_authn_file.so
@@ -1353,13 +1299,6 @@ fi
 %attr(755,root,root) %{pkglibdir}/mod_authn_ldap.so
 %endif
 
-%if %{with mysql}
-%files mod_authn_mysql
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_authn_mysql.conf
-%attr(755,root,root) %{pkglibdir}/mod_authn_mysql.so
-%endif
-
 %files mod_cgi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi.conf
@@ -1369,18 +1308,6 @@ fi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi_php.conf
 
-%files mod_cml
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cml.conf
-%attr(755,root,root) %{pkglibdir}/mod_cml.so
-
-%files mod_compress
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/tmpwatch/lighttpd-mod_compress.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_compress.conf
-%attr(755,root,root) %{pkglibdir}/mod_compress.so
-%dir %attr(775,root,lighttpd) /var/cache/lighttpd/mod_compress
-
 %files mod_deflate
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_deflate.conf
@@ -1416,18 +1343,6 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_fastcgi.conf
 %attr(755,root,root) %{pkglibdir}/mod_fastcgi.so
 
-%files mod_flv_streaming
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_flv_streaming.conf
-%attr(755,root,root) %{pkglibdir}/mod_flv_streaming.so
-
-%if %{with geoip}
-%files mod_geoip
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_geoip.conf
-%attr(755,root,root) %{pkglibdir}/mod_geoip.so
-%endif
-
 %if %{with h264_streaming}
 %files mod_h264_streaming
 %defattr(644,root,root,755)
@@ -1452,13 +1367,6 @@ fi
 %attr(755,root,root) %{pkglibdir}/mod_maxminddb.so
 %endif
 
-%if %{with mysql}
-%files mod_mysql_vhost
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_mysql_vhost.conf
-%attr(755,root,root) %{pkglibdir}/mod_mysql_vhost.so
-%endif
-
 %files mod_proxy
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_proxy.conf
@@ -1525,13 +1433,6 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_status.conf
 %attr(755,root,root) %{pkglibdir}/mod_status.so
 
-%if %{with mod_trigger_b4_dl}
-%files mod_trigger_b4_dl
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_trigger_b4_dl.conf
-%attr(755,root,root) %{pkglibdir}/mod_trigger_b4_dl.so
-%endif
-
 %files mod_uploadprogress
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_uploadprogress.conf
This page took 0.264328 seconds and 4 git commands to generate.