]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
Up to lighttpd 1.4.58
[packages/lighttpd.git] / lighttpd.spec
index cacfa9d36fe5799a523c6ca40742a2de1c1a3866..37123da87c0ba38eb9d809131aab456ea02437fb 100644 (file)
@@ -13,7 +13,6 @@
 #    - mod_wolfssl (experimental)
 #    - mod_gnutls  (experimental)
 #    - mod_nss     (experimental)
-# - mod_deflate brotli support
 #
 # Conditional build:
 %bcond_with            tests           # build with tests
@@ -24,6 +23,8 @@
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost, mod_vhostdb_mysql
 %bcond_without pgsql           # PgSQL, enables mod_vhostdb_pgsql
+%bcond_without bzip2           # Enable bzip2 support for mod_deflate
+%bcond_without brotli          # Enable brotli support for mod_deflate
 %bcond_without geoip           # GeoIP support
 %bcond_without maxminddb       # MaxMind GeoIP2 module
 %bcond_with    krb5            # krb5 support (does not work with heimdal)
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.56
+Version:       1.4.58
 Release:       1
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       https://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
-# Source0-md5: 9d94f68c8106bfcdfe7aafa0a13f45a8
+# Source0-md5: 8d12a31bd3fdd7eab85cf9a6d2cfa92e
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -131,19 +132,20 @@ Patch4:           systemd.patch
 Patch5:                test-port-setup.patch
 URL:           https://www.lighttpd.net/
 %{?with_geoip:BuildRequires:   GeoIP-devel}
-%{?with_maxminddb:BuildRequires:       libmaxminddb-devel}
 %{?with_xattr:BuildRequires:   attr-devel}
 BuildRequires: autoconf >= 2.57
+%{?with_maxminddb:BuildRequires:       libmaxminddb-devel}
 %if "%{pld_release}" != "ac"
 BuildRequires: automake >= 1:1.11.2
 %else
 BuildRequires: automake
 %endif
-BuildRequires: bzip2-devel
+%{?with_bzip2:BuildRequires:   bzip2-devel}
 BuildRequires: fcgi-devel
 %{?with_gamin:BuildRequires:   gamin-devel}
 %{?with_storage_gdbm:BuildRequires:    gdbm-devel}
 %{?with_krb5:BuildRequires:    krb5-devel}
+%{?with_brotli:BuildRequires:  libbrotli-devel}
 %{?with_dbi:BuildRequires:     libdbi-devel}
 %{?with_storage_memcached:BuildRequires:       libmemcached-devel}
 BuildRequires: libtool
@@ -152,11 +154,11 @@ BuildRequires:    libuuid-devel
 %{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
-%{?with_pgsql:BuildRequires:   postgresql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 %{?with_ssl:BuildRequires:     openssl-devel}
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
+%{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.647
 %{?with_webdav_props:BuildRequires:    sqlite3-devel}
@@ -315,6 +317,10 @@ Requires:  %{name} = %{version}-%{release}
 %description mod_authn_mysql
 lighttpd authn_mysql module.
 
+mod_authn_mysql is DEPRECATED; use mod_authn_dbi.
+
+Note: mod_authn_mysql will be removed from a future lighttpd release.
+
 %package mod_cgi
 Summary:       lighttpd module for CGI handling
 Summary(pl.UTF-8):     Moduł lighttpd do obsługi CGI
@@ -369,6 +375,10 @@ CML is a Meta language to describe the dependencies of a page at one
 side and building a page from its fragments on the other side using
 LUA.
 
+mod_cml is DEPRECATED; use mod_magnet.
+
+Note: mod_cml will be removed from a future lighttpd release.
+
 %description mod_cml -l pl.UTF-8
 CML to metajęzyk służący z jednej strony do opisu zależności strony i
 z drugiej strony do budowania strony z fragmentów przy użyciu LUA.
@@ -389,6 +399,11 @@ Only static content is supported up to now.
 The server negotiates automatically which compression method is used.
 Supported are gzip, deflate, bzip.
 
+mod_compress is DEPRECATED; use mod_deflate. mod_compress has been
+subsumed by mod_deflate.
+
+Note: mod_compress config options may be removed in a future release.
+
 %description mod_compress -l pl.UTF-8
 Kompresja wyjścia zmniejsza obciążenie sieci i może poprawić całkowitą
 przepustowość serwera WWW.
@@ -404,7 +419,10 @@ Summary(pl.UTF-8): Moduł lighttpd do kompresji wyjścia metodą deflate
 Group:         Networking/Daemons/HTTP
 URL:           https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModDeflate
 Requires:      %{name} = %{version}-%{release}
-Obsoletes:     lighttpd-mod_deflate < 1.4.56
+Obsoletes:     lighttpd-mod_compress < 1.4.56
+
+%define        _deflate_encodings deflate gzip %{?with_bzip2:bzip2} %{?with_brotli:brotli}
+%define        deflate_encodings %(echo %_deflate_encodings | sed -e 's/ /, /g')
 
 %description mod_deflate
 mod_deflate enables output compression of responses
@@ -415,6 +433,13 @@ overall throughput of the webserver. All major http-clients support
 compression by announcing it in the Accept-Encoding header. This is
 used to negotiate the most suitable compression method.
 
+This module supports %{deflate_encodings} encodings.
+
+deflate (RFC1950, RFC1951) and gzip (RFC1952) depend on zlib while
+bzip2 depends on libbzip2. bzip2 is only supported by lynx and some
+other console text-browsers. brotli (RFC7932) is supported in most
+popular browsers.
+
 Since lighttpd 1.4.56, mod_deflate subsumes and replaces mod_compress.
 mod_deflate can compress static and dynamic responses, while
 mod_compress could compress only static files.
@@ -544,6 +569,10 @@ If the ip was found in the database the module sets the appropriate
 environment variables to the request, thus making other modules/fcgi
 be informed.
 
+mod_geoip is DEPRECATED; use mod_maxminddb.
+
+Note: mod_geoip will be removed from a future lighttpd release.
+
 %package mod_h264_streaming
 Summary:       lighttpd module for h264 streaming
 Summary(pl.UTF-8):     Moduł lighttpd do emisji strumieni h264
@@ -604,6 +633,11 @@ Conflicts: %{name}-mod_simple_vhost
 %description mod_mysql_vhost
 This module provides virtual hosts (vhosts) based on a MySQL table.
 
+mod_mysql_vhost is DEPRECATED; use mod_vhostdb_dbi or
+mod_vhostdb_mysql.
+
+Note: mod_mysql_vhost will be removed from a future lighttpd release.
+
 %description mod_mysql_vhost -l pl.UTF-8
 Ten moduł udostępnia wirtualne hosty (vhosty) oparte na tabeli MySQL.
 
@@ -1017,25 +1051,27 @@ fi
 %{__automake}
 
 %configure \
-       --libdir=%{pkglibdir} \
        %{!?with_ipv6:--disable-ipv6} \
        %{!?with_largefile:--disable-lfs} \
-       %{?with_valgrind:--with-valgrind} \
-       %{?with_xattr:--with-attr} \
+       %{?with_brotli:--with-brotli} \
+       %{?with_bzip2:--with-bzip2} \
        %{?with_dbi:--with-dbi} \
-       %{?with_krb5:--with-krb5} \
+       %{?with_gamin:--with-gamin} \
        %{?with_geoip:--with-geoip} \
+       %{?with_krb5:--with-krb5} \
+       %{?with_ldap:--with-ldap} \
+       %{?with_lua:--with-lua=lua51} \
        %{?with_maxminddb:--with-maxminddb} \
        %{?with_mysql:--with-mysql} \
-       %{?with_ldap:--with-ldap} \
-       %{?with_ssl:--with-openssl} \
        %{?with_pgsql:--with-pgsql} \
-       %{?with_lua:--with-lua=lua51} \
+       %{?with_ssl:--with-openssl} \
+       %{?with_storage_gdbm:--with-gdbm} \
        %{?with_storage_memcached:--with-memcached} \
-       %{?with_webdav_props:--with-webdav-props} \
+       %{?with_valgrind:--with-valgrind} \
        %{?with_webdav_locks:--with-webdav-locks} \
-       %{?with_gamin:--with-gamin} \
-       %{?with_storage_gdbm:--with-gdbm}
+       %{?with_webdav_props:--with-webdav-props} \
+       %{?with_xattr:--with-attr} \
+       --libdir=%{pkglibdir}
 
 # -j1 as src/mod_ssi_exprparser.h regeneration deps are broken
 %{__make} -j1
This page took 0.034623 seconds and 4 git commands to generate.