]> git.pld-linux.org Git - packages/liferea.git/blobdiff - liferea.spec
- updated to 1.4.10
[packages/liferea.git] / liferea.spec
index 99a85b8d64a85d7b93527299ecb55b1606fb2d61..93d86f6375c12d4101a56cc61b537bf4072c5ad1 100644 (file)
@@ -1,48 +1,62 @@
+# TODO:
+# - create subpackage -lua (?)
+# - webkit support
 #
 # Conditional build:
 %bcond_without dbus            # without DBUS support
-%bcond_without mozilla         # without mozilla
 %bcond_without gtkhtml         # without GtkHTML
-%bcond_without mozilla_firefox # build with mozilla-firefox-devel
+%bcond_without xulrunner       # without XULRunner backend
+%bcond_without lua             # without LUA scripting support
+%bcond_with    nm              # with NetworkManager support
 #
+%ifarch %{x8664}
+%undefine      with_gtkhtml    # GtkHTML backend disabled on x86_64
+%endif
 Summary:       A RSS feed reader
 Summary(pl.UTF-8):     Program do pobierania informacji w formacie RSS
 Name:          liferea
-Version:       1.2.4
+Version:       1.4.10
 Release:       1
 License:       GPL v2
 Group:         X11/Applications/Networking
 Source0:       http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
-# Source0-md5: 2bed06c06e7b90281cf51fa3e83ee023
+# Source0-md5: 7a60b58fc0044f72fb0d67f77eaffad5
 Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-xulrunner.patch
+Patch2:                %{name}-lua51.patch
 URL:           http://liferea.sourceforge.net/
 BuildRequires: GConf2-devel >= 2.10.0
-BuildRequires: autoconf
+%{?with_nm:BuildRequires:      NetworkManager-devel}
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 %{?with_dbus:BuildRequires:    dbus-glib-devel >= 0.33}
+BuildRequires: gnutls-devel
 BuildRequires: gtk+2-devel >= 2:2.8.0
+BuildRequires: intltool >= 0.35.5
+BuildRequires: libglade2-devel >= 2.0.0
 %{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
 BuildRequires: libnotify-devel >= 0.3.2
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: libxml2-devel >= 1:2.6.19
-BuildRequires: libxslt-devel
-%if %{with mozilla}
-%if %{with mozilla_firefox}
-BuildRequires: mozilla-firefox-devel
-%else
-BuildRequires: mozilla-devel
-%endif
-%endif
+BuildRequires: libxml2-devel >= 1:2.6.27
+BuildRequires: libxslt-devel >= 1.1.19
+%{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.311
+BuildRequires: sqlite3-devel
+%{?with_xulrunner:BuildRequires:       xulrunner-devel}
 Requires(post,postun): gtk+2
 Requires(post,postun): hicolor-icon-theme
 Requires(post,preun):  GConf2
 Requires:      %{name}-backend = %{version}-%{release}
+%ifarch %{x8664}
+Obsoletes:     liferea-gtkhtml
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libgtkembedmoz.so libxpcom.so
+# we have strict deps for it
+%define                _noautoreq      libxpcom.so
 
 %description
 Liferea is a GTK+ clone of FeedReader.
@@ -69,11 +83,7 @@ Summary:     Mozilla HTML browser module for Liferea
 Summary(pl.UTF-8):     Moduł przeglądarki HTML dla Liferea oparty na Mozilli
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-%if %{with mozilla_firefox}
-%requires_eq   mozilla-firefox-libs
-%else
-Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
-%endif
+%requires_eq_to        xulrunner xulrunner-devel
 Provides:      %{name}-backend = %{version}-%{release}
 
 %description mozilla
@@ -85,9 +95,12 @@ Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-#%{__glib_gettextize}
+%{__glib_gettextize}
+%{__intltoolize}
 %{__aclocal}
 %{__libtoolize}
 %{__autoheader}
@@ -97,7 +110,9 @@ Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
        --disable-schemas-install \
        %{!?with_dbus: --disable-dbus} \
        %{!?with_gtkhtml: --disable-gtkhtml2} \
-       %{!?with_mozilla: --disable-gecko}
+       %{!?with_lua: --disable-lua} \
+       %{!?with_nm: --disable-nm} \
+       %{!?with_xulrunner: --disable-xulrunner}
 %{__make}
 
 %install
@@ -132,10 +147,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
 %{_iconsdir}/hicolor/48x48/apps/liferea.png
 %{_mandir}/pl/man1/liferea.1*
-%{_sysconfdir}/gconf/schemas/*.schemas
+%{_sysconfdir}/gconf/schemas/liferea.schemas
 %{_datadir}/%{name}
 %{_desktopdir}/*.desktop
 %{_mandir}/man1/liferea.1*
+%if %{with lua}
+%attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
+%endif
 
 %if %{with gtkhtml}
 %files gtkhtml
@@ -143,8 +161,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
 %endif
 
-%if %{with mozilla}
+%if %{with xulrunner}
 %files mozilla
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
+%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
 %endif
This page took 0.090962 seconds and 4 git commands to generate.