]> git.pld-linux.org Git - packages/liferea.git/blobdiff - liferea.spec
- updated to 1.4.10
[packages/liferea.git] / liferea.spec
index 5d7eaff64c38b1ca1c5aef6592543b0a79a210d8..93d86f6375c12d4101a56cc61b537bf4072c5ad1 100644 (file)
@@ -1,54 +1,73 @@
+# TODO:
+# - create subpackage -lua (?)
+# - webkit support
+#
 # Conditional build:
 %bcond_without dbus            # without DBUS support
-%bcond_without mozilla         # without mozilla
 %bcond_without gtkhtml         # without GtkHTML
-%bcond_with    mozilla_firefox # build with mozilla-firefox-devel
+%bcond_without xulrunner       # without XULRunner backend
+%bcond_without lua             # without LUA scripting support
+%bcond_with    nm              # with NetworkManager support
 #
+%ifarch %{x8664}
+%undefine      with_gtkhtml    # GtkHTML backend disabled on x86_64
+%endif
 Summary:       A RSS feed reader
-Summary(pl):   Program do pobierania informacji w formacie RSS
+Summary(pl.UTF-8):     Program do pobierania informacji w formacie RSS
 Name:          liferea
-Version:       1.0
+Version:       1.4.10
 Release:       1
-License:       GPL
+License:       GPL v2
 Group:         X11/Applications/Networking
 Source0:       http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
-# Source0-md5: ba3a520361e5b02a27f93ee5ecda4448
+# Source0-md5: 7a60b58fc0044f72fb0d67f77eaffad5
 Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-xulrunner.patch
+Patch2:                %{name}-lua51.patch
 URL:           http://liferea.sourceforge.net/
 BuildRequires: GConf2-devel >= 2.10.0
-BuildRequires: autoconf
+%{?with_nm:BuildRequires:      NetworkManager-devel}
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 %{?with_dbus:BuildRequires:    dbus-glib-devel >= 0.33}
-BuildRequires: gtk+2-devel >= 2:2.6.4
-BuildRequires: libxml2-devel >= 1:2.6.19
+BuildRequires: gnutls-devel
+BuildRequires: gtk+2-devel >= 2:2.8.0
+BuildRequires: intltool >= 0.35.5
+BuildRequires: libglade2-devel >= 2.0.0
 %{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
+BuildRequires: libnotify-devel >= 0.3.2
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-%if %{with mozilla}
-%if %{with mozilla_firefox}
-BuildRequires: mozilla-firefox-devel
-%else
-BuildRequires: mozilla-devel
-%endif
-%endif
+BuildRequires: libxml2-devel >= 1:2.6.27
+BuildRequires: libxslt-devel >= 1.1.19
+%{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.197
+BuildRequires: rpmbuild(macros) >= 1.311
+BuildRequires: sqlite3-devel
+%{?with_xulrunner:BuildRequires:       xulrunner-devel}
+Requires(post,postun): gtk+2
+Requires(post,postun): hicolor-icon-theme
 Requires(post,preun):  GConf2
 Requires:      %{name}-backend = %{version}-%{release}
+%ifarch %{x8664}
+Obsoletes:     liferea-gtkhtml
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libgtkembedmoz.so libxpcom.so
+# we have strict deps for it
+%define                _noautoreq      libxpcom.so
 
 %description
 Liferea is a GTK+ clone of FeedReader.
 
-%description -l pl
-Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
+%description -l pl.UTF-8
+Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
 FeedReader.
 
 %package gtkhtml
 Summary:       GtkHTML module for Liferea
-Summary(pl):   Modu³ GtkHTML dla Liferea
+Summary(pl.UTF-8):     Moduł GtkHTML dla Liferea
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
 Provides:      %{name}-backend = %{version}-%{release}
@@ -56,33 +75,32 @@ Provides:   %{name}-backend = %{version}-%{release}
 %description gtkhtml
 GtkHTML module for Liferea.
 
-%description gtkhtml -l pl
-Modu³ GtkHTML dla Liferea.
+%description gtkhtml -l pl.UTF-8
+Moduł GtkHTML dla Liferea.
 
 %package mozilla
 Summary:       Mozilla HTML browser module for Liferea
-Summary(pl):   Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
+Summary(pl.UTF-8):     Moduł przeglądarki HTML dla Liferea oparty na Mozilli
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-%if %{with mozilla_firefox}
-%requires_eq   mozilla-firefox
-%else
-Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
-%endif
+%requires_eq_to        xulrunner xulrunner-devel
 Provides:      %{name}-backend = %{version}-%{release}
 
 %description mozilla
 Mozilla HTML browser module for Liferea.
 
-%description mozilla -l pl
-Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
+%description mozilla -l pl.UTF-8
+Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %{__glib_gettextize}
+%{__intltoolize}
 %{__aclocal}
 %{__libtoolize}
 %{__autoheader}
@@ -92,7 +110,9 @@ Modu
        --disable-schemas-install \
        %{!?with_dbus: --disable-dbus} \
        %{!?with_gtkhtml: --disable-gtkhtml2} \
-       %{!?with_mozilla: --disable-gecko}
+       %{!?with_lua: --disable-lua} \
+       %{!?with_nm: --disable-nm} \
+       %{!?with_xulrunner: --disable-xulrunner}
 %{__make}
 
 %install
@@ -108,10 +128,14 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
 
 %post
 %gconf_schema_install liferea.schemas
+%update_icon_cache hicolor
 
 %preun
 %gconf_schema_uninstall liferea.schemas
 
+%postun
+%update_icon_cache hicolor
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -120,11 +144,16 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/%{name}
-%{_sysconfdir}/gconf/schemas/*.schemas
+%attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
+%{_iconsdir}/hicolor/48x48/apps/liferea.png
+%{_mandir}/pl/man1/liferea.1*
+%{_sysconfdir}/gconf/schemas/liferea.schemas
 %{_datadir}/%{name}
-%{_desktopdir}/*
-%{_pixmapsdir}/*
+%{_desktopdir}/*.desktop
 %{_mandir}/man1/liferea.1*
+%if %{with lua}
+%attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
+%endif
 
 %if %{with gtkhtml}
 %files gtkhtml
@@ -132,8 +161,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
 %endif
 
-%if %{with mozilla}
+%if %{with xulrunner}
 %files mozilla
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
+%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
 %endif
This page took 0.091587 seconds and 4 git commands to generate.