]> git.pld-linux.org Git - packages/liferea.git/blobdiff - liferea.spec
- added -libnotify-0.7.patch and -nm09.patch
[packages/liferea.git] / liferea.spec
index ca5cc069d1b18885bcdca4e4aac73112905ef71d..3a16d4902e63d8fee95b6fee86e6ab470b8fdda8 100644 (file)
@@ -1,64 +1,56 @@
 # TODO:
 # - create subpackage -lua (?)
-# - webkit support
 #
 # Conditional build:
-%bcond_without dbus            # without DBUS support
-%bcond_without gtkhtml         # without GtkHTML
-%bcond_without xulrunner       # without XULRunner backend
+%bcond_without dbus            # without D-Bus support
 %bcond_without lua             # without LUA scripting support
-%bcond_with    nm              # with NetworkManager support
+%bcond_without nm              # with NetworkManager support
 #
-%ifarch %{x8664}
-%undefine      with_gtkhtml    # GtkHTML backend disabled on x86_64
-%endif
 Summary:       A RSS feed reader
 Summary(pl.UTF-8):     Program do pobierania informacji w formacie RSS
 Name:          liferea
-Version:       1.4.15
-Release:       1
+Version:       1.6.5
+Release:       3
 License:       GPL v2
 Group:         X11/Applications/Networking
-Source0:       http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
-# Source0-md5: e4ae96a0d41d94c31271ba791caec922
+Source0:       http://downloads.sourceforge.net/liferea/%{name}-%{version}.tar.gz
+# Source0-md5: b5a2c0803eec5d0aff0b9ca4114eaf16
 Patch0:                %{name}-desktop.patch
-Patch1:                %{name}-xulrunner.patch
-Patch2:                %{name}-lua51.patch
+Patch1:                %{name}-lua51.patch
+Patch2:                %{name}-libnotify-0.7.patch
+Patch3:                %{name}-nm09.patch
 URL:           http://liferea.sourceforge.net/
 BuildRequires: GConf2-devel >= 2.10.0
 %{?with_nm:BuildRequires:      NetworkManager-devel}
 BuildRequires: autoconf >= 2.59
-BuildRequires: automake
+BuildRequires: automake >= 1:1.6
+BuildRequires: avahi-glib-devel >= 0.6.0
 %{?with_dbus:BuildRequires:    dbus-glib-devel >= 0.33}
+BuildRequires: geoclue-devel
 BuildRequires: gettext-devel
-BuildRequires: gnutls-devel
-BuildRequires: gtk+2-devel >= 2:2.8.0
+BuildRequires: gstreamer-devel >= 0.10
+BuildRequires: gtk+2-devel >= 2:2.16.0
+BuildRequires: gtk-webkit-devel >= 1.1.7
 BuildRequires: intltool >= 0.35.5
-BuildRequires: libglade2-devel >= 2.0.0
-%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
-BuildRequires: libnotify-devel >= 0.3.2
-BuildRequires: libstdc++-devel
+BuildRequires: libglade2-devel >= 1:2.0.0
+BuildRequires: libnotify-devel >= 0.7.0
+BuildRequires: libsoup-devel >= 2.26.1
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 1:2.6.27
 BuildRequires: libxslt-devel >= 1.1.19
 %{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.311
-BuildRequires: sqlite3-devel
-%{?with_xulrunner:BuildRequires:       xulrunner-devel}
-Requires(post,postun): gtk+2
+BuildRequires: sqlite3-devel >= 3.6.10
+BuildRequires: xorg-lib-libSM-devel
+Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): hicolor-icon-theme
 Requires(post,preun):  GConf2
-Requires:      %{name}-backend = %{version}-%{release}
-%ifarch %{x8664}
 Obsoletes:     liferea-gtkhtml
-%endif
+Obsoletes:     liferea-mozilla
+Obsoletes:     liferea-webkit
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libgtkembedmoz.so libxpcom.so
-# we have strict deps for it
-%define                _noautoreq      libxpcom.so
-
 %description
 Liferea is a GTK+ clone of FeedReader.
 
@@ -66,62 +58,34 @@ Liferea is a GTK+ clone of FeedReader.
 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
 FeedReader.
 
-%package gtkhtml
-Summary:       GtkHTML module for Liferea
-Summary(pl.UTF-8):     Moduł GtkHTML dla Liferea
-Group:         X11/Applications/Networking
-Requires:      %{name} = %{version}-%{release}
-Provides:      %{name}-backend = %{version}-%{release}
-
-%description gtkhtml
-GtkHTML module for Liferea.
-
-%description gtkhtml -l pl.UTF-8
-Moduł GtkHTML dla Liferea.
-
-%package mozilla
-Summary:       Mozilla HTML browser module for Liferea
-Summary(pl.UTF-8):     Moduł przeglądarki HTML dla Liferea oparty na Mozilli
-Group:         X11/Applications/Networking
-Requires:      %{name} = %{version}-%{release}
-%requires_eq_to        xulrunner xulrunner-devel
-Provides:      %{name}-backend = %{version}-%{release}
-
-%description mozilla
-Mozilla HTML browser module for Liferea.
-
-%description mozilla -l pl.UTF-8
-Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
-
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__glib_gettextize}
 %{__intltoolize}
 %{__aclocal}
 %{__libtoolize}
-%{__autoheader}
 %{__automake}
+%{__autoheader}
 %{__autoconf}
 %configure \
        --disable-schemas-install \
        %{!?with_dbus: --disable-dbus} \
-       %{!?with_gtkhtml: --disable-gtkhtml2} \
        %{!?with_lua: --disable-lua} \
-       %{!?with_nm: --disable-nm} \
-       %{!?with_xulrunner: --disable-xulrunner}
+       %{!?with_nm: --disable-nm}
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+       DESTDIR=$RPM_BUILD_ROOT
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
 
@@ -145,27 +109,15 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/liferea
 %attr(755,root,root) %{_bindir}/liferea-add-feed
-%attr(755,root,root) %{_bindir}/liferea-bin
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
-%{_iconsdir}/hicolor/48x48/apps/liferea.png
-%{_sysconfdir}/gconf/schemas/liferea.schemas
-%{_datadir}/%{name}
-%{_desktopdir}/*.desktop
-%{_mandir}/man1/liferea.1*
-%{_mandir}/pl/man1/liferea.1*
 %if %{with lua}
 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
 %endif
-
-%if %{with gtkhtml}
-%files gtkhtml
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
-%endif
-
-%if %{with xulrunner}
-%files mozilla
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
-%endif
+%{_iconsdir}/hicolor/*/*/*.png
+%{_iconsdir}/hicolor/*/*/*.svg
+%{_sysconfdir}/gconf/schemas/liferea.schemas
+%{_datadir}/%{name}
+%{_desktopdir}/liferea.desktop
+%{_mandir}/man1/liferea.1*
+%lang(pl) %{_mandir}/pl/man1/liferea.1*
This page took 0.043743 seconds and 4 git commands to generate.