]> git.pld-linux.org Git - packages/liferea.git/blobdiff - liferea.spec
- do not require xulrunner when building without it
[packages/liferea.git] / liferea.spec
index cb5d0dd4857538fc0628517574d729c797b29d10..141feb33362051ddd4b97c20690c93d98194a3fe 100644 (file)
@@ -1,27 +1,45 @@
+#
 # Conditional build:
-%bcond_without mozilla # without mozilla
-
+%bcond_without dbus            # without DBUS support
+%bcond_without gtkhtml         # without GtkHTML
+%bcond_without xulrunner       # without XULRunner backend
+#
+%ifarch %{x8664}
+%undefine      with_gtkhtml    # GtkHTML backend disabled on x86_64
+%endif
 Summary:       A RSS feed reader
-Summary(pl):   Program do pobierania informacji w formacie RSS
+Summary(pl.UTF-8):     Program do pobierania informacji w formacie RSS
 Name:          liferea
-Version:       0.9.1
-Release:       1
-License:       GPL
+Version:       1.2.7
+Release:       2
+License:       GPL v2
 Group:         X11/Applications/Networking
 Source0:       http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
-# Source0-md5: f0d5f184034697522e68e92909897043
+# Source0-md5: e15b37b9f96606581c941431a38fd933
 Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-xulrunner.patch
 URL:           http://liferea.sourceforge.net/
-BuildRequires: GConf2-devel >= 2.4.0
-BuildRequires: autoconf
+BuildRequires: GConf2-devel >= 2.10.0
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
-BuildRequires: gtk+2-devel >= 2:2.4.0
-BuildRequires: libxml2-devel >= 2.4.1
-BuildRequires: libgtkhtml-devel >= 2.4.0
+%{?with_dbus:BuildRequires:    dbus-glib-devel >= 0.33}
+BuildRequires: gtk+2-devel >= 2:2.8.0
+%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
+BuildRequires: libnotify-devel >= 0.3.2
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-%{?with_mozilla:BuildRequires: mozilla-devel}
+BuildRequires: libxml2-devel >= 1:2.6.19
+BuildRequires: libxslt-devel >= 1.1.19
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.311
+%{?with_xulrunner:BuildRequires:       xulrunner-devel}
+Requires(post,postun): gtk+2
+Requires(post,postun): hicolor-icon-theme
+Requires(post,preun):  GConf2
+Requires:      %{name}-backend = %{version}-%{release}
+%ifarch %{x8664}
+Obsoletes:     liferea-gtkhtml
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libgtkembedmoz.so libxpcom.so
@@ -29,28 +47,44 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 Liferea is a GTK+ clone of FeedReader.
 
-%description -l pl
-Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
+%description -l pl.UTF-8
+Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
 FeedReader.
 
+%package gtkhtml
+Summary:       GtkHTML module for Liferea
+Summary(pl.UTF-8):     Moduł GtkHTML dla Liferea
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-backend = %{version}-%{release}
+
+%description gtkhtml
+GtkHTML module for Liferea.
+
+%description gtkhtml -l pl.UTF-8
+Moduł GtkHTML dla Liferea.
+
 %package mozilla
 Summary:       Mozilla HTML browser module for Liferea
-Summary(pl):   Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
+Summary(pl.UTF-8):     Moduł przeglądarki HTML dla Liferea oparty na Mozilli
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
+%requires_eq_to        xulrunner xulrunner-devel
+Provides:      %{name}-backend = %{version}-%{release}
 
 %description mozilla
 Mozilla HTML browser module for Liferea.
 
-%description mozilla -l pl
-Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
+%description mozilla -l pl.UTF-8
+Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-glib-gettextize -f
+#%{__glib_gettextize}
 %{__aclocal}
 %{__libtoolize}
 %{__autoheader}
@@ -58,7 +92,9 @@ glib-gettextize -f
 %{__autoconf}
 %configure \
        --disable-schemas-install \
-    %{!?with_mozilla:--without-mozilla}
+       %{!?with_dbus: --disable-dbus} \
+       %{!?with_gtkhtml: --disable-gtkhtml2} \
+       %{!?with_xulrunner: --disable-xulrunner}
 %{__make}
 
 %install
@@ -73,7 +109,14 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
 %find_lang %{name}
 
 %post
-%gconf_schema_install
+%gconf_schema_install liferea.schemas
+%update_icon_cache hicolor
+
+%preun
+%gconf_schema_uninstall liferea.schemas
+
+%postun
+%update_icon_cache hicolor
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -83,15 +126,22 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
+%attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
+%{_iconsdir}/hicolor/48x48/apps/liferea.png
+%{_mandir}/pl/man1/liferea.1*
 %{_sysconfdir}/gconf/schemas/*.schemas
 %{_datadir}/%{name}
-%{_desktopdir}/*
-%{_pixmapsdir}/*
+%{_desktopdir}/*.desktop
 %{_mandir}/man1/liferea.1*
 
-%if %{with mozilla}
+%if %{with gtkhtml}
+%files gtkhtml
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
+%endif
+
+%if %{with xulrunner}
 %files mozilla
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
+%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
 %endif
This page took 0.188867 seconds and 4 git commands to generate.