]> git.pld-linux.org Git - packages/liferea.git/blobdiff - liferea.spec
- do not require xulrunner when building without it
[packages/liferea.git] / liferea.spec
index 44227659456acf2a9cdf43e9d1069bf1d6000a58..141feb33362051ddd4b97c20690c93d98194a3fe 100644 (file)
+#
+# Conditional build:
+%bcond_without dbus            # without DBUS support
+%bcond_without gtkhtml         # without GtkHTML
+%bcond_without xulrunner       # without XULRunner backend
+#
+%ifarch %{x8664}
+%undefine      with_gtkhtml    # GtkHTML backend disabled on x86_64
+%endif
 Summary:       A RSS feed reader
-Summary(pl):   Program do pobierania informacji w formacie RSS
+Summary(pl.UTF-8):     Program do pobierania informacji w formacie RSS
 Name:          liferea
-Version:       0.5.2
-Release:       1
-License:       GPL
+Version:       1.2.7
+Release:       2
+License:       GPL v2
 Group:         X11/Applications/Networking
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
-# Source0-md5: 4790c907f018e7f6c92e2b922a250ac8
+Source0:       http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
+# Source0-md5: e15b37b9f96606581c941431a38fd933
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-xulrunner.patch
 URL:           http://liferea.sourceforge.net/
-BuildRequires: GConf2-devel >= 2.4.0
-BuildRequires: gtk+2-devel >= 2.2.0
-BuildRequires: libxml2-devel >= 2.0.0
-BuildRequires: libgtkhtml-devel >= 2.4.0
+BuildRequires: GConf2-devel >= 2.10.0
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake
+%{?with_dbus:BuildRequires:    dbus-glib-devel >= 0.33}
+BuildRequires: gtk+2-devel >= 2:2.8.0
+%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
+BuildRequires: libnotify-devel >= 0.3.2
+BuildRequires: libstdc++-devel
+BuildRequires: libtool
+BuildRequires: libxml2-devel >= 1:2.6.19
+BuildRequires: libxslt-devel >= 1.1.19
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.311
+%{?with_xulrunner:BuildRequires:       xulrunner-devel}
+Requires(post,postun): gtk+2
+Requires(post,postun): hicolor-icon-theme
+Requires(post,preun):  GConf2
+Requires:      %{name}-backend = %{version}-%{release}
+%ifarch %{x8664}
+Obsoletes:     liferea-gtkhtml
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _noautoreqdep   libgtkembedmoz.so libxpcom.so
+
 %description
 Liferea is a GTK+ clone of FeedReader.
 
-%description -l pl
-Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
+%description -l pl.UTF-8
+Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
 FeedReader.
 
+%package gtkhtml
+Summary:       GtkHTML module for Liferea
+Summary(pl.UTF-8):     Moduł GtkHTML dla Liferea
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-backend = %{version}-%{release}
+
+%description gtkhtml
+GtkHTML module for Liferea.
+
+%description gtkhtml -l pl.UTF-8
+Moduł GtkHTML dla Liferea.
+
+%package mozilla
+Summary:       Mozilla HTML browser module for Liferea
+Summary(pl.UTF-8):     Moduł przeglądarki HTML dla Liferea oparty na Mozilli
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{version}-%{release}
+%requires_eq_to        xulrunner xulrunner-devel
+Provides:      %{name}-backend = %{version}-%{release}
+
+%description mozilla
+Mozilla HTML browser module for Liferea.
+
+%description mozilla -l pl.UTF-8
+Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
+
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
-%configure
+#%{__glib_gettextize}
+%{__aclocal}
+%{__libtoolize}
+%{__autoheader}
+%{__automake}
+%{__autoconf}
+%configure \
+       --disable-schemas-install \
+       %{!?with_dbus: --disable-dbus} \
+       %{!?with_gtkhtml: --disable-gtkhtml2} \
+       %{!?with_xulrunner: --disable-xulrunner}
 %{__make}
 
 %install
@@ -36,8 +104,20 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT \
        GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
 
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
+
 %find_lang %{name}
 
+%post
+%gconf_schema_install liferea.schemas
+%update_icon_cache hicolor
+
+%preun
+%gconf_schema_uninstall liferea.schemas
+
+%postun
+%update_icon_cache hicolor
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -45,11 +125,23 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/*
-%{_datadir}/%{name}
-%{_desktopdir}/*
-%{_pixmapsdir}/*
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/lib*.so*
-%{_libdir}/%{name}/lib*.la
+%attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
+%{_iconsdir}/hicolor/48x48/apps/liferea.png
+%{_mandir}/pl/man1/liferea.1*
+%{_sysconfdir}/gconf/schemas/*.schemas
+%{_datadir}/%{name}
+%{_desktopdir}/*.desktop
 %{_mandir}/man1/liferea.1*
-#%{_pixmapsdir}/*
+
+%if %{with gtkhtml}
+%files gtkhtml
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
+%endif
+
+%if %{with xulrunner}
+%files mozilla
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
+%endif
This page took 0.035306 seconds and 4 git commands to generate.