]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- disable possible strip via HAVE_GNU_STRIP=no
[packages/libvpx.git] / libvpx.spec
index e1602c5f079cebfdbe6550e208d2711523e9c4df..b984ce3f797638b4cc9d6fc71208ab6d728dc863 100644 (file)
+#
+# Conditional build:
+%bcond_without asm     # x86 assembler
+
 Summary:       VP8, a high-quality video codec
+Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakości
 Name:          libvpx
-Version:       0.9.0
-Release:       0.1
+Version:       0.9.5
+Release:       2
 License:       BSD
 Group:         Libraries
-Source0:       http://webm.googlecode.com/files/%{name}-%{version}.tar.bz2
-# Source0-md5: 9eb8e818d2f3263623c258fe66924082
+#Source0-Download: http://code.google.com/p/webm/downloads/list
+Source0:       http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
+# Source0-md5: 4bf2f2c76700202c1fe9201fcb0680e3
+Source1:       %{name}.ver
 Patch0:                %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
 URL:           http://www.webmproject.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: /usr/bin/php
 BuildRequires: doxygen
-BuildRequires: yasm
+BuildRequires: php-common >= 4:5.0.0
+BuildRequires: php-pcre
+%ifarch %{ix86} %{x8664}
+%{?with_asm:BuildRequires:     yasm}
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 VP8, a high-quality video codec.
 
+%description -l pl.UTF-8
+VP8 - kodek obrazu wysokiej jakości.
+
 %package devel
-Summary:       Header files and develpment documentation for libvpx
+Summary:       Header files for libvpx
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libvpx
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
-Header files and documentation for libvpx.
+Header files for libvpx library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki libvpx.
 
 %package static
 Summary:       Static libvpx library
+Summary(pl.UTF-8):     Statyczna biblioteka libvpx
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static libvpx library.
 
+%description static -l pl.UTF-8
+Statyczna biblioteka libvpx.
+
 %prep
-%setup -q
+%setup -q -n %{name}-v%{version}
 %patch0 -p1
 
 %build
-install -d build
-cd build
+install -d obj
+cd obj
 # not autoconf configure
+CFLAGS="%{rpmcflags} %{rpmcppflags}" \
 ../configure \
+%if %{with asm}
 %ifarch %{x8664}
        --target=x86_64-linux-gcc \
 %endif
 %ifarch %{ix86}
        --target=x86-linux-gcc \
 %endif
-       --enable-pic \
+%else
+       --target=generic-gnu \
+%endif
+       --enable-shared \
        --disable-optimizations \
        --enable-vp8 \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
-# Hack our optflags in.
-sed -i "s|\"vpx_config.h\"|\"vpx_config.h\" %{rpmcflags} %{rpmcppflags} -fPIC|g" libs-*.mk
-sed -i "s|\"vpx_config.h\"|\"vpx_config.h\" %{rpmcflags} %{rpmcppflags} -fPIC|g" examples-*.mk
-sed -i "s|\"vpx_config.h\"|\"vpx_config.h\" %{rpmcflags} %{rpmcppflags} -fPIC|g" docs-*.mk
-
 %{__make} verbose=true target=libs \
-       CC="%{__cc}"
-
-%{__cc} %{rpmldflags} -fPIC -o libvpx.so.0.0.0 -shared -Wl,-soname,libvpx.so.0 vpx_codec/src/*.o vpx_mem/*.o \
-       vpx_scale/generic/*.o vp8/common/*.o vp8/common/generic/*.o vp8/*.o vp8/encoder/*.o \
-       vp8/encoder/generic/*.o vp8/decoder/*.o vp8/decoder/generic/*.o vpx_config.c.o \
-       vp8/common/x*/*.o vp8/encoder/x*/*.o vp8/decoder/x*/*.o vpx_ports/*.o -lm -lpthread
-
-# Temporarily dance the static libs out of the way
-mv libvpx.a libNOTvpx.a
-mv libvpx_g.a libNOTvpx_g.a
-
-# We need to do this so the examples can link against it.
-ln -sf libvpx.so.0.0.0 libvpx.so
+       HAVE_GNU_STRIP=no \
+       CC="%{__cc}" \
+       LDFLAGS="%{rpmldflags}"
 
 %{__make} verbose=true target=examples \
-       CC="%{__cc}"
+       CC="%{__cc}" \
+       LDFLAGS="%{rpmldflags}"
 %{__make} verbose=true target=docs
 
-# Put them back so the install doesn't fail
-mv libNOTvpx.a libvpx.a
-mv libNOTvpx_g.a libvpx_g.a
-
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
 
-install -d outdir
-%{__make} -C build install \
-       DIST_DIR=$(pwd)/outdir
-
-mv outdir/bin/{simple_decoder,vp8_simple_decoder}
-mv outdir/bin/{twopass_encoder,vp8_twopass_encoder}
-install -m755 outdir/bin/* $RPM_BUILD_ROOT%{_bindir}
-
-ln -s libvpx.so.0.0.0 build/libvpx.so.0.0
-ln -s libvpx.so.0.0.0 build/libvpx.so.0
-install -m755 -p build/libvpx.so* $RPM_BUILD_ROOT%{_libdir}
-ldconfig -X -n $RPM_BUILD_ROOT%{_libdir}
-
-install outdir/include/*.h $RPM_BUILD_ROOT%{_includedir}/vpx
+%{__make} -C obj verbose=true install \
+       LIBSUBDIR=%{_lib} \
+       DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
 
-install outdir/lib/*.a $RPM_BUILD_ROOT%{_libdir}
+rm $RPM_BUILD_ROOT%{_libdir}/libvpx.so.0.?
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -112,13 +108,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/libvpx.so.*.*
+%doc AUTHORS CHANGELOG LICENSE PATENTS README
+%attr(755,root,root) %{_bindir}/vpxdec
+%attr(755,root,root) %{_bindir}/vpxenc
+%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libvpx*.so
+%attr(755,root,root) %{_libdir}/libvpx.so
 %{_includedir}/vpx
 
 %files static
This page took 0.26428 seconds and 4 git commands to generate.