]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- release 2 (by relup.sh)
[packages/libvpx.git] / libvpx.spec
index 209e7c9ce5f2ab16aec4e105cf6b3359b09c8235..3b90984d4df29d319df790ca3c0c381ee4481b76 100644 (file)
@@ -1,26 +1,48 @@
 #
 # Conditional build:
 %bcond_without asm     # x86 assembler
+%bcond_without doc     # don't build doc
+%bcond_with    tests   # build tests (not useful, creates libgtest.a)
+%bcond_without ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
+%bcond_without vp9_encoder     # vp9 encoder
+
+%ifnarch %{ix86} %{x8664}
+%undefine      with_asm
+%endif
+
+%if "%{pld_release}" == "ac"
+# not supported by compiler
+%undefine      with_ssse3
+%endif
+
+# old gcc gets stuck on ac
+%ifarch sparc
+%undefine      with_vp9_encoder
+%endif
 
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakoĊ›ci
 Name:          libvpx
 Version:       1.3.0
-Release:       1
+Release:       2
 License:       BSD
 Group:         Libraries
 #Source0Download: http://code.google.com/p/webm/downloads/list
 #Source0:      https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
-Source0:       https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
+# source, but regenerated on each fetch
+#Source0:      https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}.tar.gz
 # Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
 URL:           http://www.webmproject.org/
-BuildRequires: /usr/bin/php
 BuildRequires: doxygen
-BuildRequires: php-common >= 4:5.0.0
-BuildRequires: php-pcre
+%{?with_tests:BuildRequires:   libstdc++-devel}
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.673
 BuildRequires: sed >= 4.0
-%ifarch %{ix86} %{x8664}
 %{?with_asm:BuildRequires:     yasm >= 0.8}
+%if %{with doc}
+BuildRequires: %{php_name}-pcre
+BuildRequires: %{php_name}-program
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -71,7 +93,7 @@ Statyczna biblioteka libvpx.
 
 %prep
 #%setup -q -n %{name}-v%{version}
-%setup -q -c
+%setup -qc
 
 %build
 install -d obj
@@ -83,11 +105,14 @@ CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        --as=yasm \
 %endif
        --target=%{vpxtarget} \
-%if "%{vpxtarget}" != "%{generic_target}"
        --enable-shared \
-%endif
+       %{!?with_ssse3:--disable-ssse3} \
        --disable-optimizations \
+       --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
+       --%{!?with_doc:dis}%{?with_doc:en}able-docs \
+       --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
        --enable-vp8 \
+       %{!?with_vp9_encoder:--disable-vp9-encoder} \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
@@ -101,7 +126,10 @@ CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        CC="%{__cc}" \
        LD="%{__cc}" \
        LDFLAGS="%{rpmldflags} -L."
+
+%if %{with doc}
 %{__make} verbose=true target=docs
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -119,14 +147,14 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
-%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
+%{?with_vp9_encoder:%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder}
 %attr(755,root,root) %{_bindir}/vpxdec
 %attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
This page took 0.033702 seconds and 4 git commands to generate.