]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- release 2 (by relup.sh)
[packages/libvpx.git] / libvpx.spec
index 0b5dccd85c7dccff919edcac339aec4148eff6e6..3b90984d4df29d319df790ca3c0c381ee4481b76 100644 (file)
@@ -1,29 +1,66 @@
 #
 # Conditional build:
 %bcond_without asm     # x86 assembler
+%bcond_without doc     # don't build doc
+%bcond_with    tests   # build tests (not useful, creates libgtest.a)
+%bcond_without ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
+%bcond_without vp9_encoder     # vp9 encoder
+
+%ifnarch %{ix86} %{x8664}
+%undefine      with_asm
+%endif
+
+%if "%{pld_release}" == "ac"
+# not supported by compiler
+%undefine      with_ssse3
+%endif
+
+# old gcc gets stuck on ac
+%ifarch sparc
+%undefine      with_vp9_encoder
+%endif
 
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakoĊ›ci
 Name:          libvpx
-Version:       0.9.6
-Release:       1
+Version:       1.3.0
+Release:       2
 License:       BSD
 Group:         Libraries
-#Source0-Download: http://code.google.com/p/webm/downloads/list
-Source0:       http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
-# Source0-md5: 383f3f07a76099682abb43f79b692b72
-Source1:       %{name}.ver
-Patch0:                %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
+#Source0Download: http://code.google.com/p/webm/downloads/list
+#Source0:      https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
+# source, but regenerated on each fetch
+#Source0:      https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}.tar.gz
+# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
 URL:           http://www.webmproject.org/
-BuildRequires: /usr/bin/php
 BuildRequires: doxygen
-BuildRequires: php-common >= 4:5.0.0
-BuildRequires: php-pcre
-%ifarch %{ix86} %{x8664}
-%{?with_asm:BuildRequires:     yasm}
+%{?with_tests:BuildRequires:   libstdc++-devel}
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.673
+BuildRequires: sed >= 4.0
+%{?with_asm:BuildRequires:     yasm >= 0.8}
+%if %{with doc}
+BuildRequires: %{php_name}-pcre
+BuildRequires: %{php_name}-program
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define        generic_target  generic-gnu
+%define        vpxtarget       %{generic_target}
+%ifarch %{x8664}
+%define        vpxtarget       x86_64-linux-gcc
+%endif
+%ifarch %{ix86}
+%define        vpxtarget       x86-linux-gcc
+%endif
+%ifarch ppc
+%define        vpxtarget       ppc32-linux-gcc
+%endif
+%ifarch ppc64
+%define        vpxtarget       ppc64-linux-gcc
+%endif
+
 %description
 VP8, a high-quality video codec.
 
@@ -55,8 +92,8 @@ Static libvpx library.
 Statyczna biblioteka libvpx.
 
 %prep
-%setup -q -n %{name}-v%{version}
-%patch0 -p1
+#%setup -q -n %{name}-v%{version}
+%setup -qc
 
 %build
 install -d obj
@@ -66,30 +103,33 @@ CFLAGS="%{rpmcflags} %{rpmcppflags}" \
 ../configure \
 %if %{with asm}
        --as=yasm \
-%ifarch %{x8664}
-       --target=x86_64-linux-gcc \
-%endif
-%ifarch %{ix86}
-       --target=x86-linux-gcc \
-%endif
-%else
-       --target=generic-gnu \
 %endif
+       --target=%{vpxtarget} \
        --enable-shared \
+       %{!?with_ssse3:--disable-ssse3} \
        --disable-optimizations \
+       --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
+       --%{!?with_doc:dis}%{?with_doc:en}able-docs \
+       --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
        --enable-vp8 \
+       %{!?with_vp9_encoder:--disable-vp9-encoder} \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
 %{__make} verbose=true target=libs \
        HAVE_GNU_STRIP=no \
        CC="%{__cc}" \
+       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags}"
 
 %{__make} verbose=true target=examples \
        CC="%{__cc}" \
+       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags} -L."
+
+%if %{with doc}
 %{__make} verbose=true target=docs
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -99,26 +139,32 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
        LIBSUBDIR=%{_lib} \
        DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
 
-rm $RPM_BUILD_ROOT%{_libdir}/libvpx.so.0.?
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
+
+# adjust prefix and libdir
+%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
+%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
+%{?with_vp9_encoder:%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder}
 %attr(755,root,root) %{_bindir}/vpxdec
 %attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libvpx.so.0
+%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvpx.so
 %{_includedir}/vpx
+%{_pkgconfigdir}/vpx.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.11998 seconds and 4 git commands to generate.